Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows cannot initialize the device driver for this hardware. Code 37


10 Dec 2012   #1

Windows 7
 
 
Windows cannot initialize the device driver for this hardware. Code 37

Long story short, I tested a friends graphics card in my homebuilt computer to see if it worked. I took my Ati Radeon 9800 Pro out, and put in this other card, and then replaced the other card back with my Ati Radeon 9800 Pro. Since then, I cannot get the drivers to work again for my 9800.

I have Windows 7, 32 bit. I am positive that I did a fresh install of windows 7, not an upgrade. I cant remember if I installed specific drivers for my graphics card at that time, or if windows did it. All I know is that the card was running good, with two monitors running together. Everything stopped working after I tried my friends card out.

Ive downloaded so many Ati Catalysts, 10.2, 9.3, 9.1, 8.7, 8.1, and also different versions (XP and Vista) and none of them will work. Sometimes it will just say "The current driver is up to date" and its showing the standard VGA graphics adapter. Sometimes it will say "Radeon 9800 PRO installed, reboot now" then when I reboot, it will give me this error
"Windows cannot initialize the device driver for this hardware. (Code 37)" when I check device manager. Basically any driver I try will give me this error.

Basically what I was doing was boot into safe mode, use DriveSweeper to delete all ATI files, then reboot and install different catalyst, then go through device manager to "update driver". Then I would get the error above.

So now, In my device manager I have this (both with the exclamation point on them):

RADEON 9800 Pro
RADEON 9800 Pro - Secondary

and in control panel display I am only showing one monitor (not my 2nd monitor), and it just says "default monitor on".

From what I found out, the 9800 Pro is such an old card that windows 7 has no drivers for it...but like I said it was working perfect before, until I tried my friends card out.

My hardware:
Asus Ic7-g
Radeon 9800 Pro AGP
4GB memory
P4, 3Ghz

Thanks a bunch.

My System SpecsSystem Spec
.

10 Dec 2012   #2

Windows 7 Pro X64 SP1
 
 

Have you tried removing both entries from Device Manager?

Clearing the motherboard's CMOS?

This may not be relevant to a 9800 Pro, but see:

AMD Catalyst

I get the feeling that recent AMD/ATI drivers may not like AGP very much. "Recent" may include the 10.2 ones, which are from February of 2010 (2 digit year,1 or 2 digit month).
My System SpecsSystem Spec
Reply

 Windows cannot initialize the device driver for this hardware. Code 37




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:18 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33