Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XFX Radeon HD4670, no signal on monitor when used.

15 Dec 2012   #41
petko131

Windows 7 x86 Ultimate
 
 

Quote   Quote: Originally Posted by InfernoRogue View Post
Quote   Quote: Originally Posted by petko131 View Post
Quote   Quote: Originally Posted by InfernoRogue View Post
Don't wanna be that person, but *she, lol.

So I've updated (to the best of my ability) my system specs, so you guys can click on them to assess what would be the best PSU to remedy this problem. If there is anything else I can do to further this, let me know.
You should edit the ram memory info- is it a single stick of 4 Gb or are there 2 sticks of 2 Gb. If you know @ wich frequency they are, it would be good to write that too. Use the PSU calculators to see how much are you using now and add ~200 W to be safe with the new graphics card.
Scrolling down, under Memory, is my ram. Friend gave that to me also.
I think I put in everything mostly correct in the calculator and got like 275, but I don't think that sounds right. Plus 200 would only be 475 w. I was just gonna go with a good 650 w or greater PSU, if anyone could point me in the direction of a good one.

Ok. I deffinetly miscalculated !
I would certenly go for the 650+ psu and maybe a Corsair,Seasonic, Antec...


My System SpecsSystem Spec
.
15 Dec 2012   #42
InfernoRogue

Windows 7 Home Premium 64bit
 
 

I was looking at this one on Newegg, what do you guys think? It kind of stinks though because I can't return the PSU and I have nothing to do with it. :/
My System SpecsSystem Spec
15 Dec 2012   #43
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

When did you buy the Coolmax 400w ?
My System SpecsSystem Spec
.

15 Dec 2012   #44
InfernoRogue

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by DocBrown View Post
When did you buy the Coolmax 400w ?
Bought it from Newegg last month on the 14th. Unfortunately I'm just barely over the 30 day period.
My System SpecsSystem Spec
15 Dec 2012   #45
petko131

Windows 7 x86 Ultimate
 
 

With 62 amps on the 12 V rail, wich is single, 80+ efficiency and 750W.. no comment needed. Maybe a less powerful psu would do the job for you, but when making a pc, never save mony on the power suply! If its weak and bad ,the entire system can "die".

Smart choose, go for it!
My System SpecsSystem Spec
15 Dec 2012   #46
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

If you still have the box it came in, Call customer service tomorrow. Explain it is not enough watts for your card. Tell them you want to buy the one you linked to above. I will bet they will let you send it back for credit since you will buy the new one. I have bought $$$$$$ from NewEgg. They are always willing to work with the customer.
My System SpecsSystem Spec
15 Dec 2012   #47
InfernoRogue

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by petko131 View Post
With 62 amps on the 12 V rail, wich is single, 80+ efficiency and 750W.. no comment needed. Maybe a less powerful psu would do the job for you, but when making a pc, never save mony on the power suply! If its weak and bad ,the entire system can "die".

Smart choose, go for it!
Thanks, I plan to upgrade little bits and pieces of the computer as time passes, so I went with a more powerful psu just to play it safe. I'll wait to make the purchase in case anyone else has anything to say about this.
My System SpecsSystem Spec
15 Dec 2012   #48
InfernoRogue

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by DocBrown View Post
If you still have the box it came in, Call customer service tomorrow. Explain it is not enough watts for your card. Tell them you want to buy the one you linked to above. I will bet they will let you send it back for credit since you will buy the new one. I have bought $$$$$$ from NewEgg. They are always willing to work with the customer.
Oh great, hopefully they'll be cooperative. Thanks for the idea.


Edit: I can't call until Monday, service hours are only Mon-Fri. I'll let you guys know how it goes.
My System SpecsSystem Spec
16 Dec 2012   #49
InfernoRogue

Windows 7 Home Premium 64bit
 
 

So are we certain that the problem is the psu? Just to clarify, every fan spins when I turn the computer on with the graphics card inserted to the mobo. The power button will turn the computer on but cannot turn it off.

I'm also debating whether to buy the new psu tonight (with one day shipping it would be here faster, and I am really anxious to get this all working) and ask them about sending the original back tomorrow, or just buying tomorrow.

What do you guys think? :P

EDIT: I just read the max TDP on my cpu is 65 w. Not sure if this affects what we believe to be the issue.
My System SpecsSystem Spec
17 Dec 2012   #50
InfernoRogue

Windows 7 Home Premium 64bit
 
 

Alright guys, sorry for so many posts, but it's decision time. If we all agree that this really is the fault of the psu, I'll call newegg right now to return the other one. Thoughts?
My System SpecsSystem Spec
Reply

 XFX Radeon HD4670, no signal on monitor when used.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Upgrading graphics card from Radeon HD4670
Hey guys, just wondering if anyone can shine some light on my situation, im wanting to upgrade my graphics card from a Radeon HD4670 but I'm unsure what would be my best option without a massive price tag. Any ideas?
Graphic Cards
SR1135cl running win 7 wont power up with ATI radeon HD4670 installed
Hi after switching from win xp to win 7 I decided on installing a good graphic card on my compaq presario SR1135cl so I got me a ATI radeon HD4670 1024mb agp card now my issue is while the card is installed the computer will not power up when I removed the card the comp power fine what do you think...
Hardware & Devices
ATI Radeon 4600 HD - No signal ...
Hi , Sorry for my bad English. I have an ATI Radeon 4600 HD on my PC which is running Win -7. I installed the latest Catalyst driver from ATI. The problem : I connected my PC to my Plasma TV, which is 720 but capable of showing 1080p broadcast. I can see picture when I connected the PC to...
Graphic Cards
Windows 7 64bit not working with my Radeon HD4670
Hi everyone, Im new here and registered because i am at a total loss :( I recently aquired Windows 7 Installation cd and tried to install it o n my CPU: Processor: AMD Athlon x2 2.60 GHz Motherboard: Biostar A690M2+ VGA: Sapphire Radeon HD 4670 GRAM: 2x 2GB RAM
Graphic Cards
Ati Radeon HD4670 Error Code 43
Sorry about the double post, but I think a topic would be better. My new HD 4670 displays a Code 43 at the Device Manager. I installed the latest catalyst version and even the agp hotfix, they don't work. Any suggestions? Hardware ID's: PCI\VEN_1002&DEV_9495&SUBSYS_00281787&REV_00...
Graphic Cards
Radeon HD4670 Odd Blue
Hey W7 Forums, When my screen displays a picture or video that had black in it there is a large amount of blue pixels around it that keep moving... I don't know what is causing this, My resolution is 1920x1080 I have my gfx set at deafult/ RGB 4:4:4 Pixel Format (Full RGB) the drivers are fully...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App