Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XFX Radeon HD4670, no signal on monitor when used.


15 Dec 2012   #1

Windows 7 Home Premium 64bit
 
 
XFX Radeon HD4670, no signal on monitor when used.

Hey guys. I recently put together a new computer, and my situation with my graphics card has left me completely stumped at this point. I have a XFX Radeon HD4670 ( http://www.newegg.com/Product/Prod [...] 6814150450 ) for my graphics card, and the MS-7525 ( http://h20000.www2.hp.com/bizsuppo [...] peId=12454 ) for my motherboard. Also, my power supply is here: http://www.newegg.com/Product/Prod [...] 6817159045

My problem is that whenever I connect my monitor to my graphics card, the monitor will read "no signal". Also happens if I have the card in with the monitor plugged into the motherboard. The fan does indeed spin on the graphics card. I can only access the graphics if I take out the graphics card completely and use the onboard graphics. I have tried to disable the onboard graphics and changing my graphics settings in my bios to PCI-E rather than onboard or just PCI.
Also, if I turn the computer on with the graphics card in, not only will I get no signal, but I will not be able to turn off the computer with the power button.

Thanks for reading, appreciate any help I can get.

My System SpecsSystem Spec
.

15 Dec 2012   #2

Windows 7 Ultimate 64 bit
 
 

What type of cable are you using to connect monitor to PC? From the links you've given, are you using the stock PSU from the slimline or the PSU from newegg? Have you installed the driver for the GPU? I see no mention of driver installation.
My System SpecsSystem Spec
15 Dec 2012   #3

Windows 7 Home Premium 64bit
 
 

I believe it is an RGB cable, thanks for the quick reply.
My System SpecsSystem Spec
.


15 Dec 2012   #4

Windows 7 Ultimate 64 bit
 
 

well from your links you provided the gpu shows 2 DVI ports and a S-video, so that might be a problem right there. Next, have you downloaded and installed the driver for that GPU?
My System SpecsSystem Spec
15 Dec 2012   #5

Windows 7 Home Premium 64bit
 
 

Sorry, I'm a little new to the whole computer building deal, so you'll have to pardon my lack of knowledge in some areas, but I think the cable is actually a VGA, as that is what I've been plugging the cable into on both the motherboard and the graphics card (one of my friends misinformed me, I apologize). I'm using the PSU from newegg (COOLMAX V-400 400W ATX v2.01 Power Supply). I don't believe I've installed any drivers for the GPU.
My System SpecsSystem Spec
15 Dec 2012   #6

Windows 7 Ultimate 64 bit
 
 

Download the drivers from here....

AMD Catalyst
My System SpecsSystem Spec
15 Dec 2012   #7

Windows 7 Ultimate 64 bit
 
 

what type of monitor are you using?
My System SpecsSystem Spec
15 Dec 2012   #8

Windows 7 Home Premium 64bit
 
 

I'll go ahead and download those then. My monitor is this: Westinghouse L1920NW Overview & Specs - LCD Monitors - CNET Reviews
My System SpecsSystem Spec
15 Dec 2012   #9

Windows 7 Home Premium 64bit
 
 

I installed the drivers. No luck.
My System SpecsSystem Spec
15 Dec 2012   #10
Microsoft MVP

Win 7 Ultimate x64
 
 

Seeing as the onboard video only has a VGA connection, I am assuming you are using a DVI-VGA adapter when connecting to the new card. If so try using the other DVI port on the card, as only one of the DVI ports supports VGA/analogue via adapter.

Alternatively seeing as that monitor also has a DVI port on it, you could use a DVI cable instead of a VGA cable.
My System SpecsSystem Spec
Reply

 XFX Radeon HD4670, no signal on monitor when used.




Thread Tools



Similar help and support threads for2: XFX Radeon HD4670, no signal on monitor when used.
Thread Forum
SR1135cl running win 7 wont power up with ATI radeon HD4670 installed Hardware & Devices
ATI Radeon 4600 HD - No signal ... Graphic Cards
Windows 7 64bit not working with my Radeon HD4670 Graphic Cards
no signal with catalyst drivers on hd tv (radeon hd 5700) Graphic Cards
ATI RADEON HD4670 Screen Resolution Issue Graphic Cards
Ati Radeon HD4670 Error Code 43 Graphic Cards
Radeon HD4670 Odd Blue Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:22 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33