Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XFX Radeon HD4670, no signal on monitor when used.

15 Dec 2012   #1
InfernoRogue

Windows 7 Home Premium 64bit
 
 
XFX Radeon HD4670, no signal on monitor when used.

Hey guys. I recently put together a new computer, and my situation with my graphics card has left me completely stumped at this point. I have a XFX Radeon HD4670 ( http://www.newegg.com/Product/Prod [...] 6814150450 ) for my graphics card, and the MS-7525 ( http://h20000.www2.hp.com/bizsuppo [...] peId=12454 ) for my motherboard. Also, my power supply is here: http://www.newegg.com/Product/Prod [...] 6817159045

My problem is that whenever I connect my monitor to my graphics card, the monitor will read "no signal". Also happens if I have the card in with the monitor plugged into the motherboard. The fan does indeed spin on the graphics card. I can only access the graphics if I take out the graphics card completely and use the onboard graphics. I have tried to disable the onboard graphics and changing my graphics settings in my bios to PCI-E rather than onboard or just PCI.
Also, if I turn the computer on with the graphics card in, not only will I get no signal, but I will not be able to turn off the computer with the power button.

Thanks for reading, appreciate any help I can get.


My System SpecsSystem Spec
.

15 Dec 2012   #2
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

What type of cable are you using to connect monitor to PC? From the links you've given, are you using the stock PSU from the slimline or the PSU from newegg? Have you installed the driver for the GPU? I see no mention of driver installation.
My System SpecsSystem Spec
15 Dec 2012   #3
InfernoRogue

Windows 7 Home Premium 64bit
 
 

I believe it is an RGB cable, thanks for the quick reply.
My System SpecsSystem Spec
.


15 Dec 2012   #4
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

well from your links you provided the gpu shows 2 DVI ports and a S-video, so that might be a problem right there. Next, have you downloaded and installed the driver for that GPU?
My System SpecsSystem Spec
15 Dec 2012   #5
InfernoRogue

Windows 7 Home Premium 64bit
 
 

Sorry, I'm a little new to the whole computer building deal, so you'll have to pardon my lack of knowledge in some areas, but I think the cable is actually a VGA, as that is what I've been plugging the cable into on both the motherboard and the graphics card (one of my friends misinformed me, I apologize). I'm using the PSU from newegg (COOLMAX V-400 400W ATX v2.01 Power Supply). I don't believe I've installed any drivers for the GPU.
My System SpecsSystem Spec
15 Dec 2012   #6
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

Download the drivers from here....

AMD Catalyst
My System SpecsSystem Spec
15 Dec 2012   #7
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

what type of monitor are you using?
My System SpecsSystem Spec
15 Dec 2012   #8
InfernoRogue

Windows 7 Home Premium 64bit
 
 

I'll go ahead and download those then. My monitor is this: Westinghouse L1920NW Overview & Specs - LCD Monitors - CNET Reviews
My System SpecsSystem Spec
15 Dec 2012   #9
InfernoRogue

Windows 7 Home Premium 64bit
 
 

I installed the drivers. No luck.
My System SpecsSystem Spec
15 Dec 2012   #10
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Seeing as the onboard video only has a VGA connection, I am assuming you are using a DVI-VGA adapter when connecting to the new card. If so try using the other DVI port on the card, as only one of the DVI ports supports VGA/analogue via adapter.

Alternatively seeing as that monitor also has a DVI port on it, you could use a DVI cable instead of a VGA cable.
My System SpecsSystem Spec
Reply

 XFX Radeon HD4670, no signal on monitor when used.




Thread Tools





Similar help and support threads
Thread Forum
Upgrading graphics card from Radeon HD4670
Hey guys, just wondering if anyone can shine some light on my situation, im wanting to upgrade my graphics card from a Radeon HD4670 but I'm unsure what would be my best option without a massive price tag. Any ideas?
Graphic Cards
SR1135cl running win 7 wont power up with ATI radeon HD4670 installed
Hi after switching from win xp to win 7 I decided on installing a good graphic card on my compaq presario SR1135cl so I got me a ATI radeon HD4670 1024mb agp card now my issue is while the card is installed the computer will not power up when I removed the card the comp power fine what do you think...
Hardware & Devices
ATI Radeon 4600 HD - No signal ...
Hi , Sorry for my bad English. I have an ATI Radeon 4600 HD on my PC which is running Win -7. I installed the latest Catalyst driver from ATI. The problem : I connected my PC to my Plasma TV, which is 720 but capable of showing 1080p broadcast. I can see picture when I connected the PC to...
Graphic Cards
Windows 7 64bit not working with my Radeon HD4670
Hi everyone, Im new here and registered because i am at a total loss :( I recently aquired Windows 7 Installation cd and tried to install it o n my CPU: Processor: AMD Athlon x2 2.60 GHz Motherboard: Biostar A690M2+ VGA: Sapphire Radeon HD 4670 GRAM: 2x 2GB RAM
Graphic Cards
Ati Radeon HD4670 Error Code 43
Sorry about the double post, but I think a topic would be better. My new HD 4670 displays a Code 43 at the Device Manager. I installed the latest catalyst version and even the agp hotfix, they don't work. Any suggestions? Hardware ID's: PCI\VEN_1002&DEV_9495&SUBSYS_00281787&REV_00...
Graphic Cards
Radeon HD4670 Odd Blue
Hey W7 Forums, When my screen displays a picture or video that had black in it there is a large amount of blue pixels around it that keep moving... I don't know what is causing this, My resolution is 1920x1080 I have my gfx set at deafult/ RGB 4:4:4 Pixel Format (Full RGB) the drivers are fully...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:29.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App