Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Ult and Nvidia Geforce 8400m gs problem


23 Dec 2012   #1

Windows 7 Ultimate x64
 
 
Windows 7 Ult and Nvidia Geforce 8400m gs problem

So I have a Sony Vaio VGN-SZ670N and I upgraded it to Windows 7 Ultimate 64 bit. Now for some reason it doesnt work or it doesnt recognise it or something. It now says it is a Standard VGA Graphics adapter. I tried downloading the driver but it doesnt work. Somebody please help.

My System SpecsSystem Spec
.

26 Dec 2012   #2

Windows 7 Ultimate x64
 
 

Bump~Please help me
My System SpecsSystem Spec
26 Dec 2012   #3

Genuine Windows 7 Home Premium x64
 
 

did you update the drivers from the nvidia website or sonys website, i know for a fact Sony makes it hard to update other than using their website (personal experiance)
My System SpecsSystem Spec
.


28 Dec 2012   #4

Windows 7 Ultimate x64
 
 

sony doesnt provide the driver so i went to nvidia geforce website but it didnt work
My System SpecsSystem Spec
28 Dec 2012   #5

Genuine Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by KingzofDawn View Post
sony doesnt provide the driver so i went to nvidia geforce website but it didnt work
Ah ok, I had trouble getting my video drivers for my laptop too, i upgraded from vista x32 to 7 x64 which sony did not provide drivers for.

Have you tried windows update? that worked for me, but no control panel for the driver.
My System SpecsSystem Spec
28 Dec 2012   #6

Windows 7 Ultimate x64 SP1
 
 

Windows Update should be able to find a driver for you.
My System SpecsSystem Spec
28 Dec 2012   #7

Windows 7 Ultimate x64
 
 

nope, it didnt work. they didnt give me anything regarding the graphcis card. all it showed me was a bunch of language packs
My System SpecsSystem Spec
28 Dec 2012   #8

Genuine Windows 7 Home Premium x64
 
 

i did some looking around and apparently Windows 7 does not support your 8400m gs card.
My System SpecsSystem Spec
29 Dec 2012   #9

Windows 7 Pro X64 SP1
 
 

Have you tried this one?

Sony eSupport - VGN-SZ670N - Drivers & Software

It's presumably a Vista driver, but it may work.

Windows Update may provide a newer driver, once the machine recognizes the graphics card. Or, you may be able to install the latest nVidia drivers over these. (Drivers | GeForce Notice that the 8400M GS is on the supported list.)

I wish that the laptop makers wouldn't use custom device IDs for their graphics. Maybe it's justified for some technical reason, but I doubt that.
My System SpecsSystem Spec
30 Dec 2012   #10

Windows 7 Ultimate x64
 
 

nope it didn't work :/
My System SpecsSystem Spec
Reply

 Windows 7 Ult and Nvidia Geforce 8400m gs problem




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33