Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphics lag/low FPS in full screen mode. Games and Video.

06 Jan 2013   #1

Windows 7 Professional x64
 
 
Graphics lag/low FPS in full screen mode. Games and Video.

Hi all,

I have really bad lag when running any application that requires full screen mode. I've got the latest AMD drivers that supports my GFX card (Asus Radeon 4850). I used to have a Nvidia card and I would just change one of the settings to get rid of the lag. I changed the Graphics card and reformatted the computer so it shouldn't be a driver issue. I have Service Pack 1 and all the updates for Windows installed.

The lag is unbearable for games, so I can't play any games that require full screen, no issues when it's run in windowed mode. I've used FPS monitors while running games (Fraps and MSI afterburner) and the frame rates readings are normal (above 60 always) but it always looks like 20-ish no matter which game I play.

For videos there's always some kind of problem. Used various media players, and different browsers for flash videos but sometime the video skips to the end very quickly, or won't continue playing and halts immediately somewhere along the way.

Used MSI Kombustor to stress out the GPU, and it maxes at 70 at 100% load. Directx 10 stress test seems to be blurry, every other test seems fine to run but would have the lag from being in full screen.

I searched online for possible solutions but couldn't find anything so far. Please help.

My System SpecsSystem Spec
.

06 Jan 2013   #2

 

hi, what applications are you running?
My System SpecsSystem Spec
06 Jan 2013   #3

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by Dorado View Post
hi, what applications are you running?
Many apps like ancient games (Counter Strike, Starcraft) old games (Warcraft III, Counter Strike Source) current Gen games (Starcraft II) + other games... For videos it could be avi, mp4, mkv, wmv format, and ran them under various programs (VLC, KM Player, Creative MediaSource Player, Windows Media Player). Also tried various types of browsers for Flash Player (I.E, Firefox, Chrome, Safari).
My System SpecsSystem Spec
.


06 Jan 2013   #4

 

Try installing catalyst 12.4 instead of 12.6, which is the last version that supports HD 4xxx cards.
My System SpecsSystem Spec
06 Jan 2013   #5

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by Dorado View Post
Try installing catalyst 12.4 instead of 12.6, which is the last version that supports HD 4xxx cards.
I currently have 12.6 installed, any tips on how to downgrade to 12.4?
My System SpecsSystem Spec
08 Jan 2013   #6

 

uninstall catalyst 12.6 and all his components, download catalyst 12.4 (google it) and install it.
My System SpecsSystem Spec
24 Jan 2013   #7

Windows 7 Professional x64
 
 

After uninstalling 12.6 and installing catalyst 12.4, flash player is still buggy. I think this has something to do with firefox based browsers, as they crash a lot less in chrome and IE based browsers. I think I shouldn't bother with my old games anymore since I can run them in Windows XP if I have time. SC2 in Windows 7 is fine but a bit laggy.

However I have a new problem, when booting up computer when it's been off for a long time, the screen appears to have artifacts, if I do nothing then it will fail to boot up Windows 7 and BSOD will occur, however if I enter BIOS, the artifacts are gone and if I exit BIOS and let my OS load, it will run completely fine( No overheating while gaming watching videos etc...) This only started happening after a couple of days of installing the 12.4 drivers.
My System SpecsSystem Spec
25 Jan 2013   #8

 

are you overclocking the card?
My System SpecsSystem Spec
25 Jan 2013   #9

Windows 7 Professional x64
 
 

I'll be planning to overclock it once I feel like it's stable enough to. Right now it's running on stock speeds and the temps are fine.
My System SpecsSystem Spec
25 Jan 2013   #10

Windows 7 Professional 64-bit
 
 

It has something to do with the flashplayer, Try to remove the flashplayer and mozzila and install them again then tell us the result.
My System SpecsSystem Spec
Reply

 Graphics lag/low FPS in full screen mode. Games and Video.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:23 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33