Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Mobility Radeon X2300 problem...help please!


02 Oct 2009   #1
adi4motion

 
ATI Mobility Radeon X2300 problem...help please!

My computer's graphic card acts strange:
On ac adaptor power the windows 7 bootscreen freezes long before the Microsoft logo is formed, if i power on my laptop only with battery power everything works fine...does anyone know how to solve this?...I'm assuming the graphic card does this because when i select "PCI Lock" in the boot menu, windows loads with a standard vga adapter driver and bootscreen runs as it should.
Need your help!


My System SpecsSystem Spec
.

03 Oct 2009   #2

Windows 7 Ultimate x64
 
 

Then you may have a driver incompatibility.

When you boot on battery only, your notebook will generally limit the video card to save on battery life. This may be why your computer works when you use it on battery only.

Try booting up in safe mode and see if that works as well.

Next, go to your device manager and see if there are any items listed with an exclamation mark next to them. If so, report what they are.
My System SpecsSystem Spec
05 Oct 2009   #3
adi4motion

 

thanks for the reply Zen00
If i boot in safe mode no boot logo appears...only list of loaded drivers and then the logon screen. No hardware conflicts/problems in device manager.Now I installed 64 bit edition of Windows 7, the problem pesists but now...it doesn't completely loads the boot screen even on battery power, however, both win x86 and x64 bootscreens load from Hybernate mode...I think is because the video driver is already loaded.In addition, niether Vista nor Seven recognise my videoboard at instalation...a low resolution "safe-mode-like" screen appears during instalation...Is there a way to fix this bootscreen problem?..my guess is if i somehow put the video driver same place as the windows built-in drivers may fix it (if there are in another location :-?), or load the video driver earlier than the bootscreen...
thanks again for trying to help me!
My System SpecsSystem Spec
.


05 Oct 2009   #4

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Hi adi4motion

Have on ATI web site for Windows 7 drivers:

Mobility Radeon™ X2300 - Overview
My System SpecsSystem Spec
05 Oct 2009   #5
adi4motion

 

i have the latest drivers for vista x64 from asus website and from what i know Windows 7 uses vista platform, so no driver compatibility problem, plus games working fine, aero as well, no complainings about that...just for the bootscreen.On ati/amd website i failed to find the drivers...last was told only the manufacturers produce the drivers for their graphic card (in my case asustek)...(sorry for my english)
My System SpecsSystem Spec
05 Oct 2009   #6
adi4motion

 

this is what they have support for


Attached Thumbnails
ATI Mobility Radeon X2300 problem...help please!-ati.amd-support.jpg  
My System SpecsSystem Spec
05 Oct 2009   #7

Windows 7 Ultimate x64
 
 

Another way to find drivers is to look on your computers manufacturer web site. Check there and they may have what you need.
My System SpecsSystem Spec
07 Oct 2009   #8
adi4motion

 

Yes, i know that, i have them from my manufacturer site.The ting is that i don't really think is just a driver problem it's more like a driver load problem, because, like i told you if i'm in hybernate mode (shutdown only with drivers already loaded) when i boot up, on windows resume, the bootscreen works...i do have the latest drivers avaible and no driver incompatibility detected.I don't know hoe to solve this, i've tried to change to bootscreen with metods used for vista (didn't work)..the first time they have a nice bootscreen my computer doesn't load it ...thanks for your help...maybe you will solve this ...i don't know...maybe a patch or driver mod?...
My System SpecsSystem Spec
07 Oct 2009   #9

Windows 7 Ultimate x64
 
 

Back there a ways, you mentioned that Windows doesn't recognize your video card, could you expound on that a little? When does it not recognize your card?
My System SpecsSystem Spec
07 Oct 2009   #10

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by adi4motion View Post
this is what they have support for
Yours is the 2000 series though.
My System SpecsSystem Spec
Reply

 ATI Mobility Radeon X2300 problem...help please!





Please note  Please note
        When your issue is fixed please remember to thank those that helped you and mark the thread as solved.
Thread Tools



Similar help and support threads for2: ATI Mobility Radeon X2300 problem...help please!
Thread Forum
ATI Mobility Radeon HD 4570 Series problem Graphic Cards
ATI Mobility Radeon HD 4570 problem Graphic Cards
ATI Mobility Radeon X2300 Modded Driver Help Graphic Cards
ATi Mobility Radeon HD 3470 Problem Graphic Cards
ATI Radeon Mobility 9200 Problem Graphic Cards
problem with ATI Mobility Radeon HD 3470 Graphic Cards
OSG Problem on 512MB ATI Mobility Radeon HD 4570 Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:03 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33