Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Laptop Graphics Card not functioning properly?

14 Jan 2013   #1
lastvelocirapto

Windows 7 Ultimate x64
 
 
Laptop Graphics Card not functioning properly?

I am not really good with computers, I know something is wrong but not really sure how to fix it

I use Windows 7 Ultimate with a dedicated graphics card 2GB GDDR5 AMD Radeon HD 7970M and a intergrated graphics card Intel HD Graphics 4000 installed in my laptop

I used to be able to play Total War Shogun 2 (and other games) with my AMD Radeon Graphics Card, but for some reason my laptop decides to run on my Intel HD Graphics 4000 instead now.

With my little knowledge that I have, when I go to device manager -> display adaptors, I can see both AMD Radeon 7970M and Intel HD Graphics 4000 there and my laptop shows that both graphics card are functioning properly (and up to date).

But when I go to DxDiag, it only shows the Intel HD Graphics 4000, and when I disable my Intel HD Graphics 4000, my laptop cannot detect any graphics card.

Not really sure what to do anymore, any help would be appreciated, thanks
*I am really bad with computers, I'll need step by step solution

edit: I am so desperate that I reinstalled windows 7, still no help


My System SpecsSystem Spec
15 Jan 2013   #2
bulletng

Windows 7 Pro x64
 
 

I don't have much experience with ATI/AMD, but is there an option in the AMD software to select default display adapter?
My System SpecsSystem Spec
15 Jan 2013   #3
lastvelocirapto

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by bulletng View Post
I don't have much experience with ATI/AMD, but is there an option in the AMD software to select default display adapter?
Yes, there is switchable graphics but I already set everything to high performance (my AMD graphics card)
My System SpecsSystem Spec
18 Jan 2013   #4
lastvelocirapto

Windows 7 Ultimate x64
 
 

No solutions?
My System SpecsSystem Spec
23 Jan 2013   #5
lastvelocirapto

Windows 7 Ultimate x64
 
 

Really no help???????????
My System SpecsSystem Spec
Reply

 Laptop Graphics Card not functioning properly?




Thread Tools





Similar help and support threads
Thread Forum
AMD Graphics Card is not functioning properly error
So, recently i downloaded the latest Catalyst Driver (14.12) from the AMD website Desktop But after installing it and rebooted my PC, my monitor's resolution became smaller (like 800x600 something) and an error showed up "No AMD graphics driver installed or the AMD driver is not functioning...
Graphic Cards
My graphic card isn't functioning properly, games/videos won't load
I've been having this problem for a while now, and I stopped using my Windows desktop and started using my Chromebook instead. I just got back into using my desktop again, and I restarted it factory fresh. After installing all possible Windows updates, installing the latest graphics drivers, and...
Graphic Cards
Acer laptop keyboard not functioning properly
Hi, We have Windows 7 64 bit with an Acer older laptop. We are not sure what we did but our keyboard has changed in that we cannot use Ctrl + C to copy or Ctrl + V for paste and other functions. Also our mouse pad does not work anymore. We are using an external USB keyboard and it works fine...
Hardware & Devices
Laptop keyboard certain keys not functioning properly at times
I've had this strange problem since couple of weeks. Some days certain alphabet keys stop functioning properly, I have to hit it hard to get them to work while after a while of hard hitting keys, it starts functioning properly & I've seen this happening to Space Bar too. Currently, I've issue with...
Hardware & Devices
E8600 not functioning properly, I think.
I jus took out my E8200 2.6 and dropped in a E8600 3.33 This is what it`s showing in CPU-z. Whay isn`t the core spedd at 3333 ? The fsb is at the stock 1333, is something wrong , here ? Thanks
Hardware & Devices
themes are not functioning properly.
hi, i recently decided to use themes again. for some reason i cant install any custom theme properly. whenever i install it, the background, right click menu etc work except the boarders on any open window and my taskbar(toolbar). i noticed the taskbar tool bar stays on classic. additional...
Themes and Styles

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:17.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App