Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Aero on ATI HD 4870 slow as hell


05 Oct 2009   #11

Win7 RTM
 
 

Quote   Quote: Originally Posted by bvinicius View Post
The problem is back again .

I've seen some people with similar problems, and many of them is using dual monitors. ATI fault perhaps?
I also have a 4870 and notice Aero slows down and has a "flicker" effect whenever I have (Aero-enabled) windows open on my second monitor. In my case both monitors are connected to my single 4870 via DVI.

If I only use the main monitor, even when playing videos in EVR, Aero is fine. It does seem to be dual-monitor related and may be a driver issue.

My System SpecsSystem Spec
.

28 Oct 2009   #12

Windows 7 Ultimate 64-bit build 7600
 
 

Quote   Quote: Originally Posted by stormy13 View Post
If I may ask,

Quote:
I am runing a dual monitor setup, one in the HD 4870 (primary) and the other on the onbord HD 3300 video.
why? Your 4870 is more than capable of running dual monitors, that and with the onboard enabled you are taking away from system ram. Disable the onboard, and connect the second monitor/display to the 4870, then once back in Windows go into your display properties and set it to "extended", that will allow bother monitors to show different things (clone mode is both showing the same thing).
Some Video card's doesn't have 2 D-Subs... or he's trying to 1 DVI and 1 D-Sub
My System SpecsSystem Spec
03 Nov 2009   #13

Win7
 
 

Quote   Quote: Originally Posted by Meistergimp View Post
Quote   Quote: Originally Posted by bvinicius View Post
The problem is back again .

I've seen some people with similar problems, and many of them is using dual monitors. ATI fault perhaps?
I also have a 4870 and notice Aero slows down and has a "flicker" effect whenever I have (Aero-enabled) windows open on my second monitor. In my case both monitors are connected to my single 4870 via DVI.

If I only use the main monitor, even when playing videos in EVR, Aero is fine. It does seem to be dual-monitor related and may be a driver issue.
I'm experiencing the same bug with a 4870x2 + 2x LCDs connected via DVI.

Any window on the extended lcd = flickering when moving it around and it just looks overall sluggish. All window on the primary lcd is fine. I tried reversing the order of the primary display (right LCD instead of left) and the same thing happens (primary display smooth, extended lcd slow).

Using catalyst 9.10 and the stock windows 7 drivers (cat 8.12) both produce the same problem.

Any ideas??
My System SpecsSystem Spec
.


03 Nov 2009   #14

Win7
 
 

Quote   Quote: Originally Posted by Meistergimp View Post
Quote   Quote: Originally Posted by bvinicius View Post
The problem is back again .

I've seen some people with similar problems, and many of them is using dual monitors. ATI fault perhaps?
I also have a 4870 and notice Aero slows down and has a "flicker" effect whenever I have (Aero-enabled) windows open on my second monitor. In my case both monitors are connected to my single 4870 via DVI.

If I only use the main monitor, even when playing videos in EVR, Aero is fine. It does seem to be dual-monitor related and may be a driver issue.
Where did you see other people with this issue BTW? I want to submit this bug to ATi but I want more evidence first. Please post a link if possible.

Thanks
My System SpecsSystem Spec
03 Nov 2009   #15

7 x64
 
 

Catalyst 9.10 fixed the issues here. And one of my programs is at fault too, RTTnews, if it was open then the aero becomes very slow.
My System SpecsSystem Spec
03 Nov 2009   #16

Win7 RTM
 
 

Just an update to my earlier post regarding the dual-monitor flicker issue with my 4870. I am able to make the problem go away if I power down the system and reboot. It seems that after UVD kicks in (after playing a video in EVR mode or using some other GPU-assisted app such as Flash or AVIVO converter) the problem arises. It's almost as if the GPU is "stuck" in UVD mode. Powering down the system seems to reset the GPU clocks and Aero is fine again - at least until UVD is activated once more.

It's most likely a driver issue, though I haven't ruled out a BIOS bug with the 4870 series cards. I don't remember it happening under Vista, but then again I haven't used that OS in a while. If it's a recent driver problem I've only been using Windows 7.
My System SpecsSystem Spec
04 Nov 2009   #17

Win 7 Home Premium
 
 

Just thought I'd through my 2 cents in here -

I have been having a flicker issue on my 2nd monitor (Panasonic Plasma TV connected via HDMI) when viewing videos through Media Center. I finally solved the flicker by disabling Aero. I have confirmed multiple times that with Aero on, I get a flicker in the video. With Aero off, no flicker.

I am using an ATI Radeon HD 4550 1GB 64-bit GDDR3 PCI Express 2.0 card with Catalyst 9.10 drivers. Saw the same issue on the Catalyst 9.9 drivers.

Also tried an ATI Radeon 3450 512MB 64-bit GDDR2 PCI Express 2.0 with the same results.
My System SpecsSystem Spec
Reply

 Aero on ATI HD 4870 slow as hell




Thread Tools



Similar help and support threads for2: Aero on ATI HD 4870 slow as hell
Thread Forum
Solved Slow boot along with aero lag Performance & Maintenance
Aero slow motion Drivers
3D gaming running slow like hell Gaming
Fresh install of Win 7 - Running slow as hell + keeps freezing Performance & Maintenance
aero slow motion General Discussion
Windows 7 Aero Peak Too Slow! Help! General Discussion
Aero is slow with RC and X1400 Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:16 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33