Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: updated to catalyst 13.3 but it still shows 13.1

05 Apr 2013   #1
archer

Windows 7 ultimate x64
 
 
updated to catalyst 13.3 but it still shows 13.1

Hey all, I just saw the beta drivers 13.3 for AMD. Downloaded them and did a clean install. Everything went well. But to my surprise, when I checked the version, it still says 13.1.

Not sure why this is happening. Any suggestions friends?


My System SpecsSystem Spec
.

05 Apr 2013   #2
Solarstarshines

Windows 7 Home Premium 64bit sp1
 
 

lol it's a beta driver mine says 13.3 I installed it after a fresh install of win 7 but like I said since it is beta it is going off the WHQL version instead of the beta I'm guessing
My System SpecsSystem Spec
05 Apr 2013   #3
archer

Windows 7 ultimate x64
 
 

thank solarstarshines......I guess then I will go back to 13.1 and install 13.3 after the full release. Wouldn't this better?
My System SpecsSystem Spec
.


05 Apr 2013   #4
Solarstarshines

Windows 7 Home Premium 64bit sp1
 
 

Quote   Quote: Originally Posted by archer View Post
thank solarstarshines......I guess then I will go back to 13.1 and install 13.3 after the full release. Wouldn't this better?
it probably be the same I would just leave it if it installed correctly
My System SpecsSystem Spec
12 Apr 2013   #5
archer

Windows 7 ultimate x64
 
 

hey! I resolved it....( I think I did)....anyways, I uninstalled and installed it back....now it is 13.3
My System SpecsSystem Spec
12 Apr 2013   #6
roboticarm

Windows 7 Home Premium x64
 
 

In my opinion, one should not update drivers unless and until the newer drivers are already known to improve performance and give added benefits. Newer drivers can even bring in new problems in some cases, latest drivers are not always stable.
My System SpecsSystem Spec
12 Apr 2013   #7
archer

Windows 7 ultimate x64
 
 

Quote   Quote: Originally Posted by roboticarm View Post
In my opinion, one should not update drivers unless and until the newer drivers are already known to improve performance and give added benefits. Newer drivers can even bring in new problems in some cases, latest drivers are not always stable.
I agree with you roboticarm. But, I have always found AMD drivers very stable and regarding the beneficial updates with the new drivers, AMD has always delivered good updates for games.
My System SpecsSystem Spec
12 Apr 2013   #8
roboticarm

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by archer View Post
Quote   Quote: Originally Posted by roboticarm View Post
In my opinion, one should not update drivers unless and until the newer drivers are already known to improve performance and give added benefits. Newer drivers can even bring in new problems in some cases, latest drivers are not always stable.
I agree with you roboticarm. But, I have always found AMD drivers very stable and regarding the beneficial updates with the new drivers, AMD has always delivered good updates for games.
Yeah, if it's AMD, you should download and install the latest "application profiles".
My System SpecsSystem Spec
Reply

 updated to catalyst 13.3 but it still shows 13.1




Thread Tools





Similar help and support threads
Thread Forum
DXDiag shows DirectX 11 but Windows Experience Index shows DirectX 10
Hello, I just did a clean install on my laptop after installing a new SSD. I installed the drivers that I had to install manually, and then I did a Windows update for anything else. After getting everything setup I ran my first Windows Experience Index. Surprising, the graphics score was...
Performance & Maintenance
No AMD Catalyst Control Center shows anywhere after installing driver?
I have a PC with HD 2600 Pro AGP video card. I downloaded the drivers, afterwards though there is no CCC? I see it installed a Catalyst install manager. I installed twice, so what to do to fix it? Legacy
Graphic Cards
1tb hard drive shows unallocated & shows error cyclic redundancy error
Hello, My toshiba extrnl 1tb hard disk changed to raw aftr abrupt power cut whn drive was cnnectd to pc. After sum research tried method of test disk on win 7. I followd the procedure and writed partion. But aftr rebootng nw disk changed to unallocated. I tried initializing disk to mbr but it...
Hardware & Devices
Catalyst Control Center shows second video card as 'Disabled Adapter'
Under hardware in CCC Primary adapter: AMD Radeon HD 6900 Series Disabled adapter: AMD Radeon HD 7800 Series Drivers are up to date. I installed the 7800 as a replacement for an older (second) graphics card. I hooked them together using a Crossfire bridge. Still, the device remains...
Graphic Cards
NVIDIA Geforce 210 shows 1GB when box shows 512
Hey so I have an Nvidia Geforce 210, and the box says its 512 MB, but both the info displays on Windows XP and 7 say It has 1 GB. I'll add a screenshot. Any clues? Thanks guys!
Graphic Cards
HDD shows up, shows data, no folders or files visible
I just reinstalled Windows 7 64bit after a crash. I reconnected my second HDD to the machine where prior to the crash I stored all my photos and music. The problem is that there appears to be no folders or files visible in the drive, despite it showing over 300GB of used space. See the...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:26.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App