Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Gts 250 issue

12 Oct 2009   #1

WIndows 7 ultimate 64 bit
Gts 250 issue

OK i just upgraded my windows xp to windows 7 64 bit. (ultimate edition) and I'm having some graphical issues. A friend of mine has done the same thing. with a 9400 gt and runs Champions online at 40 frames or so. I"m running at 15... and my card is Way beyond that (bfg tech gts 250 oc) I called tech support and was told windows 7 isn't supporting these cards so hot yet. But i've heard nothing but good from windows 7... This is the only problem i'm having with it.. But As far as gaming goes... I feel like i have downgraded my OS instead of upgrading... any thought guys? Thanks much.

My System SpecsSystem Spec

12 Oct 2009   #2

Windows 7 ultimate 64 bit / XP Home sp3

Their is a new driver out for your card. Which driver are you using?
My System SpecsSystem Spec
13 Oct 2009   #3

WIndows 7 ultimate 64 bit

I started out with the new driver. and I went backwards to try some older ones didn't really make a difference at all.. Still running Below what it should. Gr =/
My System SpecsSystem Spec

13 Oct 2009   #4


Hi Grant827.....

some older games are simply not supported with newer drivers, ive got a few older titles my end which i get terrible performance with on my setup..

according to this its not that old, & your specs far surpass the recommended requirements..

Name:  champ.PNG
Views: 18
Size:  28.6 KB

whats performance like on other games..??

have you run ''3dmark06''..??

My System SpecsSystem Spec
13 Oct 2009   #5

WIndows 7 ultimate 64 bit

well games like L4D ran ok... But I got on champions online... and wow. and my frames have dropped terribly... I just can't understand why lol

Edit: i did the update again. and i did disk cleanup and some programs that weren't working right before are now working. I'm going to try getting my drivers and all again and see how things go. *crosses Fingers*
My System SpecsSystem Spec

 Gts 250 issue

Thread Tools

Similar help and support threads
Thread Forum
Boot issue, 0xc0000098 ci.DLL file issue
OK so I hope this can be a quick fix and thanks for your help. * Randomly computer didn't start, get something telling me that the ci.dll file is missing or corrupt and error 0xc0000098 * safe mode and last know good configuration both result in bsod * Tried a few things, disconnect all...
BSOD Help and Support
net start command line issue - 64bit issue?
I am trying (in vain) to issue a net start command "net start - "C:\Program Files (x86)\uTorrent\utorrent.exe", on the command line. The error message is "the filename, directory name or volume label syntax is incorrect". I believe the 3 details are correct, as i am looking at the utorrent.exe file...
General Discussion
HP Multi Print/Scan Issue Re Install Issue?
I have an HP M1522 NF multi function peripheral attached to a PC running Windows 7. I needed to re install the drivers and software the other day but now it will only install the printer drivers and not the scanner drivers or any of the accompaying software?
Hardware & Devices
jpeg permission issue / possible encryption issue
Hello, I am new to the forums and have looked around just about everywhere I can think of for a similar topic and thus far have been unable to locate any help. If this has been previously covered, please point me in the direction and I will read up. So as for my issue.... I was running...
General Discussion
Interesting connectivity issue, just a browser issue
Opps, maybe not so unique since I just noticed an ENTIRE forum for browsers...perhaps moving this is appropriate...if so, please do. I will be reading up in there. Its interesting because I can't find any mention of it anywhere on this site. Specifically browser connectivity is lost after a...
Network & Sharing
8800GT Driver issue? Or maybe its a bios issue.
Hi all. I'm not sure where to start with this issue, it's bit spread out but it all started while I was gaming and the game froze and then the computer crashed. The freezing happened every once in a while, but the crashing had never happened. During the restart I see...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:14.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App