Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Green screen for videos using AMD Catalyst Legacy 13.1 drivers

26 Apr 2013   #1
lala1990

Windows 7 Ultimate x64
 
 
Green screen for videos using AMD Catalyst Legacy 13.1 drivers

Hi, I have an AMD Radeon HD 4870 card, prior to updating to 13.1 legacy drivers, 12.6 was working perfectly for me. However, after updating to 13.1 legacy drivers, videos can't play properly, they just show a green screen, and it happens to all sources: Online video players, Windows Media Player, Media Player Classic Home Cinema, VLC player. I wish to ask, anyone has any ideas what options are added to the control center i 13.1 legacy drivers, and how to solve this issue. Or, anyone would be kind to provide me the links to 12.6 legacy drivers. normal drivers will not work for my graphic card, only legacy drivers are working. I can't find any links myself . thanks in advance.


My System SpecsSystem Spec
.

27 Apr 2013   #2
Kari

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro with Media Center
 
 

I had a similar issue with Flash videos (Youtube etc.), streaming or watching locally stored videos. The solution was simple: disable Flash hardware acceleration. After this the videos played OK.

My thread about this issue: Flash videos: audio OK, no video, instead only solid green background (solution in post #5).

Might be it will not help you but it most certainly is worth to try.

Kari
My System SpecsSystem Spec
27 Apr 2013   #3
lala1990

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Kari View Post
I had a similar issue with Flash videos (Youtube etc.), streaming or watching locally stored videos. The solution was simple: disable Flash hardware acceleration. After this the videos played OK.

My thread about this issue: Flash videos: audio OK, no video, instead only solid green background (solution in post #5).

Might be it will not help you but it most certainly is worth to try.

Kari
disabling hardware acceleration fixes online video streaming, but watching videos locally on my computer with Windows Media Player and Media Player Classic Home Cinema still produces the error.
My System SpecsSystem Spec
.


27 Apr 2013   #4
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

My System SpecsSystem Spec
27 Apr 2013   #5
lala1990

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by stormy13 View Post
how did you find this? my windows is windows 7 ultimate x64 the driver is for windows 8...
My System SpecsSystem Spec
27 Apr 2013   #6
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

It is the same Windows 7 driver, just with Windows 8 support added to it. You can also find direct download links here,

AMD Catalyst 12.6 BETA (8.97.100.3 July 3) Legacy Driver - AnandTech Forums

without the Windows 8 support.
My System SpecsSystem Spec
27 Apr 2013   #7
lala1990

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by stormy13 View Post
It is the same Windows 7 driver, just with Windows 8 support added to it. You can also find direct download links here,

AMD Catalyst 12.6 BETA (8.97.100.3 July 3) Legacy Driver - AnandTech Forums

without the Windows 8 support.
ok since u said it's the same windows 7 drivers i will go download and install it thanks so much for the links.
My System SpecsSystem Spec
28 Apr 2013   #8
lala1990

Windows 7 Ultimate x64
 
 

i figured out something, the problem with the videos being unable to render properly is due to DXVA. The directx web installer doesn't install the proper direct x files required for DXVA to work, I tried installing directx using the june 2010 redistributable package, and surprisingly everything starts to work like normal.
My System SpecsSystem Spec
29 Apr 2013   #9
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

Guru3D.com for all your video driver sanity.... old and new.... plus utilities and custom made drivers, although those are use at your own risk.

I agree that this upgraded drivers worse than previous for people happens too much, so basically, I don't change drivers unless there is compelling reason to...

Learned this in Windows 95/98/XP, happened way way too frequently then.
My System SpecsSystem Spec
30 Apr 2013   #10
lala1990

Windows 7 Ultimate x64
 
 

i think that the DirectX web installer has some problems with the legacy graphic cards, as they do not detect and update the necessary DirectX components needed. If anyone is using direct x 9, remember to install through the redistributable, not the web installer.
My System SpecsSystem Spec
Reply

 Green screen for videos using AMD Catalyst Legacy 13.1 drivers




Thread Tools





Similar help and support threads
Thread Forum
BSOD watching videos at web screen turns green
So when i use my chrome and watch some videos i get on some pages a green screen on the videos then it plays for 10sec, and then i get it again, its really irritating. Occasionally but quite rarely my whole screen goes black and then blue screen appears with some txt. then the pc might reboot...
BSOD Help and Support
Flash videos: audio OK, no video, instead only solid green background
Dear fellow geeks, please help me to solve this mystery. When I boot the laptop mentioned in my specs, flash videos do normally not work. Audio is OK but instead of video the only thing I can see is solid green color. See screenshot: This is with all browsers, all sites with streaming...
Music, Pictures & Video
Black Screen after installing ATI Catalyst Drivers
Hi, the first time I installed Windows 7 Professional (clean install, not upgrade) and installed the catalyst drivers for my HD5750 video card (http://game.amd.com/us-en/drivers_catalyst.aspx?p=win7/windows-7-64bit), everything worked fine. I ended up formatting my hard drive and doing a...
Graphic Cards
Green Lines coming while watching youtube Videos.
Hello everyone I've had this problem for a while now. This problem occurs even after Re-Installing Windows 7 (With Samsung's recovery wizard.) So, this is the problem, If I watch a video (any kind ESPECIALLY WITH 240p) a green lines come up. The screen shot is below: ...
Music, Pictures & Video
Flash player problem: green lines through middle of YT videos?
Hi I don't remember recently updating or changing my Flash player in any way. However, for a week now I have been getting green/pink areas in any YouTube video I try to play. Problem is not only pertaining to YT and occurs with videos on other websites such as the BBC news site. ...
Browsers & Mail
Firewire drivers: the 'Legacy' one isn't there?
Hi everyone, I'm new here. I just bought a laptop with Windows 7, but already I'm having trouble connecting some firewire device to it (Presonus Inspire audio interface, for your information). Windows won't actually recognize the device. It knows whether or not it's plugged in, but it doesn't...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App