Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Radeon 7870 Driver Causing Graphics Glitch (Outside of games)


09 May 2013   #1

Windows 7 Home 64bit
 
 
Radeon 7870 Driver Causing Graphics Glitch (Outside of games)

I had this issue before formatting my hard drive, figured it was just a conflict with my old graphics driver.

The problem I am having is nothing major, but it is enough to bother me. The issue I'm having is with the mouse cursor. Whenever the arrow changes (to the link cursor/typing cursor,etc), it displays two small black bars, then back to being a normal cursor. It happens very quickly. I tried to record my screen using Fraps, but it didn't display in the video. I had to record my monitor using my camera. Also the other problem it presents, sometimes Firefox will have some "tearing" in the upper right corner, displaying black lines across the browser. It seems to be only these two things.

I am currently using AMD Catalyst 13.4. I rolled back to using version 12 and problem still persisted.

Not sure if I have the wrong driver installed or what. Like I said in the beginning, this was happening before I formatted my hard drive. It was a lot worse then. The graphic glitch doesn't seem to be as persistent now. But still annoying. And also, the arrow glitch happens outside of Firefox (On Chrome, IE, on the desktop).

I included a picture of the arrow glitch, not the greatest picture quality since it came from a video I took.

I am running Windows 7 64bit, AMD Radeon 7870 (HIS brand), Gigabyte GA-970A-UD3 mobo, 8GB dual-channel RAM, 1TB HDD, PSU @ 620w.

Any help is greatly appreciated.

Arrow glitch (Hard to see, best I can get though):


"Tearing" that happens on Firefox:


Another example on a forum I visit:


My System SpecsSystem Spec
.

09 May 2013   #2

Windows 7 Home Premium 64bit sp1
 
 

If you are having Artifacts first thing is to check temps second if not temps uninstall the driver and get driver sweeper Download Driver Fusion (Driver Sweeper) for free clean up all traces of AMD drivers then re install if it continues I would consider the card is just bad
My System SpecsSystem Spec
10 May 2013   #3

Windows 7 Home 64bit
 
 

Don't think it's temps. Here is a screenshot of SpeedFan (Note, I was gaming for 30 mins when this picture was taken)




These are the idle temps:



I have installed the drivers many times. I have uninstalled, reinstalled, problem still existed. When this began originally, I formatted my drive, installed the necessary drivers, and the problem came back.

If it is a bad card, then I am SOL then, since I bought it from Newegg back in mid March. No way I can RMA or return it now.
My System SpecsSystem Spec
.


10 May 2013   #4

Windows 7 Home Premium 64bit sp1
 
 

Quote   Quote: Originally Posted by Ech0es View Post
Don't think it's temps. Here is a screenshot of SpeedFan (Note, I was gaming for 30 mins when this picture was taken)




These are the idle temps:



I have installed the drivers many times. I have uninstalled, reinstalled, problem still existed. When this began originally, I formatted my drive, installed the necessary drivers, and the problem came back.

If it is a bad card, then I am SOL then, since I bought it from Newegg back in mid March. No way I can RMA or return it now.
you can always RMA a card if you can't do it through new egg do it through who ever made the card it's a no brainer man I know you got it from new egg but all you do is call the maker explain what it's doing and they will issue you a slip you can do it on the web it will be twice as fast as well
My System SpecsSystem Spec
10 May 2013   #5

Windows 7 Home 64bit
 
 

Yeah, I've already looked into that. HIS makes the video card. Anyway, I don't think there is a problem with the card. First of all, I get no issues during gaming. Second, I installed driver version 8.982.0.0 from 7/27/2012 and I had no issues. As soon as I updated to the current driver, the issues returned.
My System SpecsSystem Spec
10 May 2013   #6

Windows 7 Home Premium 64bit sp1
 
 

I'm using 13.5 and never had one issue

also check this out might be a 2d clock issue I forgot about that those cards had that issue big time http://www.sapphireforum.com/showthr...and-workaround
My System SpecsSystem Spec
Reply

 Radeon 7870 Driver Causing Graphics Glitch (Outside of games)




Thread Tools



Similar help and support threads for2: Radeon 7870 Driver Causing Graphics Glitch (Outside of games)
Thread Forum
Solved Radeon 7870 HDMI out to HDTV Plasma In - No Sound Graphic Cards
Under performing Sapphire AMD HD RADEON 7870 Graphic Cards
AMD Radeon HD 7970M Graphics Driver Not Installing Drivers
New Radeon HD 7870 not detected Graphic Cards
Solved Asus Radeon HD 7870 & Corsair A70 PC Custom Builds and Overclocking
Glitch causing quick interrupt of network? Network & Sharing
Laptop - black screen - graphics driver Radeon MV350 Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:07 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33