Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New card, Windows recoginzed it, but isn't listed in Device Manager

19 Jun 2013   #1
Spustatu

OR
 
 
New card, Windows recoginzed it, but isn't listed in Device Manager

I just installed a new HD 6670 into my computer, but the computer won't use it. Instead, it's defaulting to the onboard graphics. When I turned the computer on for the first time with the new card, Windows detected the new device and installed drivers. I installed drivers off of the CD that came with it anyway. After restarting, I could no display from the new card. I switched the monitor input to the onboard and checked Device Manager and the only video adapter shown was the onboard graphics. I downloaded the latest drivers from AMD, installed, and restarted. Same thing. I restarted and went into the BIOS and set it to pull graphics from the PCI slot first. Still nothing. I unplugged the VGA from the onboard and restarted with nothing but an HDMI going from the card to the monitor and still no display. The BIOS version is up to date. I don't really understand why Windows would recognize a new device, but then not recognize it at the same time.


My System SpecsSystem Spec
.

19 Jun 2013   #2
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

Disable the on-board in BIOS, you don't use both, once you add a PCIe card.
My System SpecsSystem Spec
19 Jun 2013   #3
Spustatu

OR
 
 

There doesn't appear to be a way to disable it in the BIOS. The two options I have are "Always Enable" and "Enable only when no PEG is detected" or something very close to that. No disable.
My System SpecsSystem Spec
.


19 Jun 2013   #4
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

OK, so you took the latter with Enable Only and still giving you grief? I would call the motherboard's tech support line, you didn't fill in your specs... so nothing else to go by.

Check the card and make sure it's fully in the slot is only thing left, while the power cord is not connected...
My System SpecsSystem Spec
20 Jun 2013   #5
Spustatu

OR
 
 

That's right. We selected the Enable Only option and it's still not working. I'm pretty sure it's firmly seated all the way into the board. The motherboard is a Gigabyte GA-M68MT-S2. I had this same problem with a card that I put into it a year ago, but it got worked out somehow. I don't even know how it happened.
My System SpecsSystem Spec
Reply

 New card, Windows recoginzed it, but isn't listed in Device Manager




Thread Tools





Similar help and support threads
Thread Forum
Wireless card dissapeared from device manager after Windows 7 installa
Hi there, I have a Dell latitude e6500 which I have installed Windows 7 professional on (quite a clean install as was a newish machine). After the install, I had no wireless connectivity so checked in device manager and my wireless card is just not there. It doesnít have an exclamation mark next...
Hardware & Devices
My Nvidia device is not listed in Device manager
i cant install nvidia drivers " this graphics driver could not find compatible graphic hardware", and i can't see my nvidia card on the device manager, and can't get the hardware ID, it looks like my laptop doesn't have this graphic card installed. my latop is: ASUS - K52JC 2 graphics card,...
Graphic Cards
my graphics card not listed in device manager
im useing a old graphics card leadtek myvivo winfast a280 agp 8x 128mb right its not listed in device manager its useing standard vga graphics adapter when i run drivers through leadtek site it says cannot find product but when i start up pc before windows loads it states leadtek graphics card and...
Graphic Cards
GPU is not listed under device manager
Hey I recently realized that my graphics card is not showing any where on my computer. I went to the control panel and went to Uninstall Programs and I found the Nvidia driver. Although I can see the driver, I can't see it under hardware, and I no longer see it running on the toolbar. I have a...
Graphic Cards
Intel Graphic card not listed in my Device manager
hi; My laptop config: Sony vaio (E- series) VPCEB24EN with intel i3 M350 @2.26 GHz processor, 512 MB ATI graphic card, 3Gb RAM. PROBLEM: Recently my laptop harddisk got repaired, i had thosiba MK3265GSX HDD with (320GB storage area, 8 MB buffer size & 5400 rpm). I replaced it with...
Graphic Cards
Where sould my Bluetooth hardware be listed in Device Manager?
I think I have Bluetooth ability but I can't seem to find any evidence of this in the Device Manager. Where would it generally be located? Thank you :geek:
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App