Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gigabyte Z77X-UD3H onboard Intel graphics - DVI issues

03 Jul 2013   #1
MassPantserson

Windows 7 Professional x64
 
 
Gigabyte Z77X-UD3H onboard Intel graphics - DVI issues

Hi all,

I'm trying to run two monitors in Win7 using my Gigabyte z77x-ud3h. If I install NO drivers, I get a mirrored display; if I install either the Gigabyte Intel VGA driver or the native Intel driver, however, I get dual monitor performance... but only when the driver is freshly installed and the computer is still on.

If I restart or reboot, Win7 "forgets" the second monitor and only uses the VGA monitor.

If I uninstall the drivers and disconnect the VGA monitor, Windows will use the DVI monitor with no drivers installed.

But if I install the drivers again, Windows -- even if the VGA monitor has never been connected -- will "use" the VGA monitor and the DVI monitor will stay dark.

Is the motherboard defective? Or is this something about Windows 7?


My System SpecsSystem Spec
.

03 Jul 2013   #2
bobafetthotmail

Win 7 Pro 64-bit 7601
 
 

after the reboot, can you rightclick on the desktop and select "screen resolution" then click on "detect" and see if it then detects both screens, then set them to work how both are supposed to work, click on save and then see if on reboot it works.
My System SpecsSystem Spec
03 Jul 2013   #3
MassPantserson

Windows 7 Professional x64
 
 

Thanks for the reply! That was the first thing I did, though -- and Windows says "Display not Detected." Again, it works *just fine* if I install the drivers fresh, so I know that the hardware is perfectly okay... something in Win7 is killing the dual-monitor drivers.
My System SpecsSystem Spec
.


03 Jul 2013   #4
ICIT2LOL

Desk1 8 Pro / Desk2 7 Home Prem / Main lap Asus ROG 7 Pro
 
 

Just as matter of interest where did you download the drivers from? I am not personally keen on the Windows check preferring to go to the manufacturers site in your case here GIGABYTE - Motherboard - Socket 1155 - GA-Z77X-UD3H (rev. 1.0)

If that doesn't work why not try a SFC and a chkdsk? Disk Check

SFC /SCANNOW Command - System File Checker as you say it works fine then the WMC just blocks what you want to do.
My System SpecsSystem Spec
04 Jul 2013   #5
MassPantserson

Windows 7 Professional x64
 
 

Drivers were downloaded directly from Gigabyte's support page for the mobo. Chkdsk turns up clean, but I haven't tried SFC.
My System SpecsSystem Spec
04 Jul 2013   #6
ICIT2LOL

Desk1 8 Pro / Desk2 7 Home Prem / Main lap Asus ROG 7 Pro
 
 

Quote   Quote: Originally Posted by MassPantserson View Post
Drivers were downloaded directly from Gigabyte's support page for the mobo. Chkdsk turns up clean, but I haven't tried SFC.
Give that one a go Mass it doesn't take long.
My System SpecsSystem Spec
04 Jul 2013   #7
MassPantserson

Windows 7 Professional x64
 
 

Just ran it -- comes out clean. After a quick evaluation of the value of my time and mental energy, I ordered a $35 dual DVI card from NewEgg -- I think it will be faster and easier just to upgrade the video with a PCIe card than to try to fix the drivers for the onboard video. :P
My System SpecsSystem Spec
04 Jul 2013   #8
ICIT2LOL

Desk1 8 Pro / Desk2 7 Home Prem / Main lap Asus ROG 7 Pro
 
 

Best idea mate it can be so frustrating at times eh?
My System SpecsSystem Spec
04 Jul 2013   #9
fireberd

Windows 7/10 64 bit
 
 

I have a similar Gigabyte motherboard, a Z77X UD5H. The DVI port on it died (not sure if its a problem in the motherboard or a problem in the i7 3770 CPU) but the VGA still works. I had been using the Intel graphics in my i7 3770, but just opted to install a separate video card (an AMD Radeon HD7770). It has dual display ports. My graphics scores (WEI) jumped from 5.2 to 7.6 with the separate video card.
My System SpecsSystem Spec
04 Jul 2013   #10
ICIT2LOL

Desk1 8 Pro / Desk2 7 Home Prem / Main lap Asus ROG 7 Pro
 
 

Thats interesting fireberd as I am sure my Asus Z77 board has dropped it's 3.0 USB back port bundle.

Nice pick up on the WEI!!

Sorry OP a bit OT
My System SpecsSystem Spec
Reply

 Gigabyte Z77X-UD3H onboard Intel graphics - DVI issues




Thread Tools





Similar help and support threads
Thread Forum
slow disk bandwidth with GA-Z77X-UD3H, Win 7 Ent
hi, in a nutshell, i've got some fast drives that should be transferring data much faster than they actually are , and i can't figure out why they're not performing right. i've got 2 disk drives i'm going to be copying data back and forth from -- a seagate st3320620as 320gb sata drive rated...
Hardware & Devices
Gigabyte GA-Z77X-UD3H drivers not loading
I am looking for drivers for Ethernet Controller, PCI Simple Communications Controller, SM Bus Controller, and 2 Universal Serial Bus (USB) Controllers. When I use update driver in the Device Manager, they will not load automatically. I do not find them on the Gigabyte or Intel websites.
Drivers
Overclocking guide for Gigabyte GA-Z77X-D3H
Hi am after a Tutorial for overclocking my Gigabyte GA-Z77X-D3H. Thx
PC Custom Builds and Overclocking
Gigabyte Z77X-UD5H WB Wireless Card Driver Will Not Take
The Gigabyte Z77X-UD5H WB comes with a Wireless Adapter/Bluetooth PCIe card. Atheros AR5BWB222. Gigabyte calls it a GC-WB300D The driver is being reported as having an issue by a splat in device manager with the following message: Windows cannot verify the digital signature for the drivers...
Drivers
Horizontal adjustment for onboard Intel graphics LCD TV
Hello, I just joined this site today because I can't seem to find an answer for a problem I am having. I have been on this site quite a bit just to find answers, and it seems to be very helpful. Ok, so I have a low profile Dell computer in the living room hooked up to an LG LCD TV. It did...
Graphic Cards
x-fi xtreme audio or gigabyte 880GA-UD3H onboard
hi folks id just like to pick some brains on this 1 plz. i hav just upgraded my mobo to a gigabyte 880GA-UD3H but i had a friend do the fitting. he put my x-fi extrem music soundcard back in too and i was wondering if there is realy any point in using the sound card as its a brand new mobo and i...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App