Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sapphire 5870 Problems installing Drivers


18 Oct 2009   #1

Windows 7 Professional 64 bit
 
 
Sapphire 5870 Problems installing Drivers

Well I do not really know where to start. I've bought myself a new computer and I'm trying to set it up and completing updating stuff.

And Everything goes smooth until the installation of my new Sapphire Radeon Hd 5870 Graphic card.

I'm not any expert in this field and could really need some help, directions or what to look after to make it work.

I'm able to install all except the actual driver. The drivers I'm trying to install is latest from Ati's homepage.

The error message i get is following:
"Driver install: user must be a member of the administrators group"

Error During installation of newest Drivers

I've tried right clicking and Run as Administrator but nothing changed and I still got the same "result" or problem after that.

I've checked in my Administrative Tools -> Computer Management -> Local Users and Groups -> Users

And there I've checked that my User is a member of Administrators.

I've tried starting up a game (Aion to be correct) and got this error:
Error Message Starting up Aion

I've tried to install new drivers by selecting the location off the driver but then windows gave me a message that said following:
"Windows has determined the driver software for your device is up to date"

Picture shows Advanced settings in Screen Resolution
Picture off Advanced Screen Res. Settings

On my Motherboard, Asus Rampage II Extreme, It said that if you were running a single GPU card it should stand at the top Pci-e slot, so it's mounted after the manual.

I don't know if that makes me unable to try the 2nd or 3rd Pci-e slot to test the actual slot or not?



Fix:
Had to make a new user account and give only that one administrator access. From there I deleted the "leftover" stuff from CCC and deleted the windows standard driver, which asked me to restart my computer.

I restarted the system into Safe Mode and on the new adminstrator user I had to install the Ati's newest driver with "run as adminstrator"...

First then I got it to install without any faults and now it's working perfect

My System SpecsSystem Spec
.

18 Oct 2009   #2

Windows 7 PRO x64
 
 

Welcome to the Forums!
Glad you got if fixed, and posted it!
You installed the drivers in safe mode?

Can you go ro run, type in DXDIAG, and see what you display next to DDI? I have an ongoing thread here 5850 stated DDI:10.1?! DX10.1?
Just want more feedback with people with directX 11 cards.
Thanks!
My System SpecsSystem Spec
Reply

 Sapphire 5870 Problems installing Drivers




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:38 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33