Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphics card not showing in device manager

03 Aug 2013   #1
CityLady

windows 7 64bit Enterprise
 
 
Graphics card not showing in device manager

Hi there, I have recently bought the nvidia geforce GT630 graphics card which is a pci slot card, I have put the card in to the slot and screwed it in place. there are no cables to attach to the motherboard and it's not powering up or installing from the dvd I got with it. When i plug the monitor cable into the card at the back and then boot up I get analogue monitor on power save click power on keyboard or move mouse...yet nothing happens and the monitor goes to sleep. My monitor is a dell as is my keyboard model Sk-8135 the keyboard has no power switch or power button and the monitor light goes orange leaving the screen black.

Please help me....

Citylady


My System SpecsSystem Spec
.
03 Aug 2013   #2
paulpicks21

Windows 7 Professional 64 bit
 
 

Hi,

When you switch the PC on, is the fan on the graphics card spinning?

You may want to try re-seating it.
My System SpecsSystem Spec
03 Aug 2013   #3
kbrady1979

Windows 7 Professional 64bit SP1
 
 

I'm with Paul....if it doesn't take any auxiliary power, make sure it is seated in the PCI slot all the way. If it is seated in completely, the latch on the PCI slot should engage itself.
My System SpecsSystem Spec
.

03 Aug 2013   #4
CityLady

windows 7 64bit Enterprise
 
 

Hi and thank you for your responses...I have looked again and it seems to be in as far as it will go...there is a clip like thing on the end which clicked when I placed into the pci slot... I will take it out again and try again...
My System SpecsSystem Spec
03 Aug 2013   #5
kbrady1979

Windows 7 Professional 64bit SP1
 
 

It seems that it was seated correctly if the latch engaged the hook of the card automatically. No problems there. What type of cable were you using to connect your monitor to your video card....VGA, DVI? If you were using VGA, try using a DVI cable(if your monitor has a DVI connection on it) and see what happens then.

Here is what I am talking about:

-gt630.jpg

Also, don't use the disk for any drivers....it's outdated by the time it gets to your door. Here is the lastest non-BETA driver for Win7 64-bit: GeForce 320.49 Driver


My System SpecsSystem Spec
03 Aug 2013   #6
paulpicks21

Windows 7 Professional 64 bit
 
 

Also could you answer my question in my last post regarding the fan?
My System SpecsSystem Spec
05 Aug 2013   #7
CityLady

windows 7 64bit Enterprise
 
 

Quote   Quote: Originally Posted by paulpicks21 View Post
Also could you answer my question in my last post regarding the fan?
Hi sorry for the delay in getting back too you...the fan is not spinning and it's still not running...my pc has been playing up since I put it in it's now out of my system and the pc is working fine. I have called the store where I bought it as i think it may be faulty...they asked me too bring it in so they can test it...

Thanks for all your help I will now see what they at the store say

Sincere regards

CityLady
My System SpecsSystem Spec
05 Aug 2013   #8
jimbo45

Linux CENTOS 7 / various Windows OS'es and servers
 
 

Hi there
If your computer already had an on board video card you'll probably have to disable that first otherwise it will continue to use the onboard card. You should find a setting somewhere in the BIOS or have a look at the MOBO manual -- you might have to set a dip switch or something.

Cheers
jimbo
My System SpecsSystem Spec
05 Aug 2013   #9
paulpicks21

Windows 7 Professional 64 bit
 
 

Quote   Quote: Originally Posted by CityLady View Post
Quote   Quote: Originally Posted by paulpicks21 View Post
Also could you answer my question in my last post regarding the fan?
Hi sorry for the delay in getting back too you...the fan is not spinning and it's still not running...my pc has been playing up since I put it in it's now out of my system and the pc is working fine. I have called the store where I bought it as i think it may be faulty...they asked me too bring it in so they can test it...

Thanks for all your help I will now see what they at the store say

Sincere regards

CityLady
No worries,

If the fan is not spinning then the card is dead/not getting any power so there is no way it will work.
Hopefully the store will test it and confirm it's faulty and give you a new one.

Let us know how you get on.

Paul.
My System SpecsSystem Spec
Reply

 Graphics card not showing in device manager




Thread Tools




Similar help and support threads
Thread Forum
how to make device manager detect my graphics card?
few days ago i tried to update my nvidia geforce gt 335m driver. but the update would not install, so i thought of deleting the nvidia driver and install the new version. i went to control panel(uninstall a program) and deleted everything with the name nvidia on it(physcs,graphics driver,control...
Graphic Cards
Device manager showing up the wrong card.
WTF happened? :)) Could someone help me please? I got a little confused by it.:p
Graphic Cards
Device manager showing Standard VGA graphics adapter after restore
I have been searching the internet for hours trying to find a solution to this problem to no avail :(. Computer: Dell precision workstation t3500, Intel Xeon W3503 @ 2.4ghz, 6gb ram, GTX 560 ti (not working now, worked before restore) I just restored my PC through Dell's backup and recovery...
Graphic Cards
Graphics Card in Device Manager showing with Caution? ! in a triangle
recently tried to run skyrim but the only video card it seems to detect is the intel hd one. im hoping this only happens on skyrim, but i fear its one of the reasons ive been lagging quite a bit in the other games cause it wont use the nvidia card instead it uses the weaker intel hd one.
Graphic Cards
my nvidia graphics card will not show up in device manager anymore
story: Okay so here's what happened, I Was working on photoshop one day and when i was trying to do more CPU hungry things on it (evan cropping) the screen started to flicker black and come right after 10 seconds OR evan flicker then turn off. One day it started flickering and then turned off, I...
Graphic Cards
my graphics card not listed in device manager
im useing a old graphics card leadtek myvivo winfast a280 agp 8x 128mb right its not listed in device manager its useing standard vga graphics adapter when i run drivers through leadtek site it says cannot find product but when i start up pc before windows loads it states leadtek graphics card and...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App