Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Doesn't work video driver

07 Aug 2013   #1
rx123yz

windows 7 home premium x64
 
 
Doesn't work video driver

Dear Sir,
yesterday I installed windows 7 home premium x64
Before installing nvidia driver it runs well with windows default video performace (800x600).
But after installing nvidia driver, it doesn't work perfectly
MY problems after installing nvidia driver
1. It runs well before showing the start up window (welcome window where I have to entry my password)
2. But when I run the windows in safe mode it works perfectly
3. You can say that it is for driver problem / driver software problem. But I used the driver in the previous windows 7 home premium x64
If you need anything related with my problem, then comment in down
Thanks.


My System SpecsSystem Spec
.
08 Aug 2013   #2
archer

Windows 7 ultimate x64
 
 

Hi rx123yz. Your issue sounds like that Windows have installed its own drivers over new ones that you installed. Remove all the old drivers and use Driver Sweeper. This little software removes all the bits of the old drivers. Below is the link to download the S/W. Before uninstalling the old drivers, download the latest drivers for your card from Sevenforums or from Nvidia site and install them after uninstalling and sweeping off the old drivers with driver sweeper.

Driver Sweeper Download

Keep us posted.
My System SpecsSystem Spec
08 Aug 2013   #3
rx123yz

windows 7 home premium x64
 
 

Quote   Quote: Originally Posted by archer View Post
Hi rx123yz. Your issue sounds like that Windows have installed its own drivers over new ones that you installed. Remove all the old drivers and use Driver Sweeper. This little software removes all the bits of the old drivers. Below is the link to download the S/W. Before uninstalling the old drivers, download the latest drivers for your card from Sevenforums or from Nvidia site and install them after uninstalling and sweeping off the old drivers with driver sweeper.

Driver Sweeper Download

Keep us posted.
thanks
My System SpecsSystem Spec
.

08 Aug 2013   #4
archer

Windows 7 ultimate x64
 
 

Is the issue solved?
My System SpecsSystem Spec
Reply

 Doesn't work video driver




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Radeon HD 3850 AGP, driver doesn't work.
Hello. I have Radeon HD 3850 AGP and Win7, and I tried to do almost everything ... I installed 9.12 drivers, 9.12 drivers with adding CL_91526 from the topic above), 9.11 drivers, 9.11 drivers with Hotfix (ATI), 9.11 drivers with adding CL_91526, manual driver install by right click . Absolutely...
Graphic Cards
Computer doesn't start up after installing video driver
Hi, I've just installed Win7 Ultimate on my laptop Sony Vaio. I have a problem with my video driver. I downloaded the driver from http://esupport.sony.com/US/p/model-home.pl mdl=VPCEH14FM&LOC=3#/downloadTab When I launch the installation process, it says "successfully installed" and I need to...
Drivers
Reinstallation of W-LAN driver doesn't work
Hi, I´ve got some problem with my W-LAN device. Recently I´ve got a strange feeling about it because some things didn´t work correctly, so I decided to reinstall the driver. It didn´t work directly (I don´t know why), so I tried to uninstall it first, to install it again. Now I got this message: ...
Drivers
Video card driver doesn't support Aero effects
I know there are many other people having this same problem... I just recently upgraded Windows 7 Ultimate from Vista Home premium. When I "upgraded" though I chose to completly reinstall my OS. Anyways I used to have transparency, but when I try to get that same effect it says "The...
Drivers
Add a Canon printer with no driver and Windows update doesn't work
I'm trying to add a Canon imageCLASS MF7470 printer to my laptop. When I plug it into the USB, Windows 7 detects it, but as unspecified. It says no driver is installed. When I do a Windows update it comes up with other imageCLASS models but not the one I have. I've tried going thru these...
Drivers
Driver for USB-functionality doesn't work
Hi, I'm running the german version of Windows 7 x64, so here is the original message I get when I click on "USB" in the menu-bar: "Der für die USB-Funktionalität erforderliche Virtualisierungstreiber funktioniert nicht." It's something like this in english: "The driver necessery for the...
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App