Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't Get New Installaton Out of Standard VGA Mode


18 Sep 2013   #1

Windows 7 Ultimate x64
 
 
Can't Get New Installaton Out of Standard VGA Mode

This problem is solved but the solution was not obvious. Please read my explanation far below; the actual cause of the driver installation problem may affect others as well so I encourage you to read the solution.
............

I just built a new desktop using ASUS Z87-Plus MB and HIS Radeon HD5750 graphics adapter. Using either the Radeon or the on-board iGPU, Windows sees only Standard VGA Graphics Adapter. I've re-installed Windows 7 both with and without the Radeon with same result. Device Manager reports only Standard VGA. Installing HIS drivers did not help and apparently really did not install, perhaps the utility did not see a Radeon board installed and did not install any Catalyst software. But, the shareware GPUx utility reports different details for each GPU but names both Standard VGA. The Radeon board's GPU and memory are correctly reported by GPUx. Both the on-board and Radeon board boot Windows in VGA mode but I can't find a way to get higher resolution set. Using Device Manager to Search for Hardware finds nothing.

I did install all the MB drivers from the ASUS CD and other MB features seem to work ok. This is a Windows 7 64-bit system with 32 GB of RAM. The monitor is connected by DVI.

I can boot Windows from either graphics adapter by removing the PCIe Radeon card; I move the monitor DVI cable to the Radeon or the MB iGPU DVI connector. Both will boot and display Windows but both are reported as Standard VGA adapters by Device Manager. However, I note that when Windows first starts before logging onto my user account, that the screen resolution is higher than 800 x 600 Standard VGA; after loggin onto my user account, the screen resolution drops back to Standard VGA 800 x 600.

The Windows 7 Ultimate and the Radeon card were bought two years ago and never used; the ASUS MB, i7 CPU and RAM are new. The HIS Radeon card is described as usable for Windows 7. I "install" the Radeon drivers by running the CD that came with the Radeon; it completes but does not seem to install anything. That is, I see no "Catlyst" in the program list. This driver install program has a step reported as finding the graphics card; it pauses there for perhaps ten seconds and the progress bar completes without reporting an error but I suspect drivers are not installed because the Radeon card is not identified.

I don't know how GPUx gets the data it reports. That is, does it read directly from the two cards, depending on which is in place when booted, or does it get data from what Windows has already read? Problem is, GPUx never reports the name of the graphics adapter as anything but Standard VGA Graphics Adapter, though iGPU and graphics memory are reported correctly for each adapter.

Why is Windows so fixed on identifying the graphics adapter as only Standard VGA? I would expect Windows 7 to read and correctly identify the adapter in use. I know either will operate as VGA for POST and BIOS review, but when Windows boots I expect it to identify the graphics adapter and report it in Device Manager, but it reports only Standard VGA.

If I were to download new drivers for the Radeon card (I have not yet tried to do so), how would I insist that Windows install them if Device Manager does not identify the Radeon card?

I know there is the option to "Disable" the Standard VGA adapter that Device Manager identifies but I have not done that. If I did and I had a black screen when Windows boots, how would I recover from that? And, would this help in some way?

Device Manager offers to search for new hardware; I've done that but the Radeon card is not reported (though I have not disabled the Standard VGA adapter from Device Manager).

The Radeon driver CD does not show drivers within Windows Explorer but it does have folders, nearly empty, for XP and Vista. I presume all the drivers are somehow hidden on this CD as the CD contains nearly 500 MB of data, though I see only a tiny amount of that shown in Windows Explorer. The CD is marked to show support for Windows 7.

It was necessary to install many drivers from the ASUS MB CD; until I did that, for example, even the Intel network adapter was reported as having no driver. This CD installed many Intel and thrid-party drivers for the MB. But, this made no difference in how Windows reports the Standard VGA adapter. Windows seems stable but I can't get it out of VGA mode. I have installed Windows 7 Service Pack 1 but it made no difference. I welcome your comments and suggestions! Larry

My System SpecsSystem Spec
.

18 Sep 2013   #2
Microsoft MVP

 

That's a placeholder driver not intended to be kept except on the oldest hardware which isn't really Windows 7 capable. It forfeits higher screen res and Sleep/Hibernate.

Have you enabled Automatically deliver drivers via Windows Update (Step 3)to run all rounds of Important and Optional Windows Updates with reboots, to completion? Windows 7 should deliver the driver it wants on modern hardware.

If not then import it from the Support Downloads webpage for HIS Radeon HD5750, after making sure the video card is enabled in BIOS, not the onboard video - this alone may cause Windows to load the driver.

If Video Card is not showing up in BIOS setup, reinstall it carefully until it does or return it to try another.
My System SpecsSystem Spec
18 Sep 2013   #3

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote:
ASUS Z87-Plus MB and HIS Radeon HD5750 graphics adapter. Using either the Radeon or the on-board iGPU,
ASUS Z87-Plus
Asus web site has drivers for the on-board VGA for Windows 7.
Z87-PLUS - Motherboards - ASUS
My System SpecsSystem Spec
.


18 Sep 2013   #4

Windows 7 Ultimate x64
 
 

My ASUS BIOS Graphics Adapter option is set to AUTO. That seems to work as the system boots with only the on-board iGPU or with the Radeon card installed. I move the monitor DVI cable to the MB DVI connector or to the Radeon DVI connector. The BIOS does have the option to set the graphics adapter to iGPU or to PCIe but so far I have left it as AUTO as that seems to work.

I'm concerned that Windows Device Manager does not report the presence of the Radeon graphics card. Device Manager shows ONLY the name, Standard VGA Graphics Adapter. Clicking Search for new hardware finds nothing. So, why is the Radeon card not identified. In fact, the MB iGPU is not identified either; when only that on-boare iGPU is present, Device Manager still shows only Standard VGA Graphics Adapter.

I wonder if ANY driver update method wold work if Device Manager does not report the presence of the graphics adapter present. So, how do I get Device Manager to recognize there is a PCIe graphics card installed?
My System SpecsSystem Spec
18 Sep 2013   #5
Microsoft MVP

 

If you are unwilling to enable the PCIe (if that's how it's installed) Video adapter to test it's efficacy then we can't troubleshoot. It is obviously not working correctly when set to Auto.

I told you what Standard VGA is but you seemed to ignore that also. It is most likely for the on board Display adapter, but you can check to be sure by tracing the Hardware Identification. That driver is updated via Windows Update in about 95% of installs, providing you ran all rounds of Important and Optional Updates to completion since there may be enabling Performance Updates needing install first. You must also first enable Automatically deliver drivers via Windows Update (Step 3)

We cannot know that the Video card will be detected until you enable it in the BIOS, not either/or. If it will not show up in BIOS by name then reinstall it checking its connections carefully, try another video card.
My System SpecsSystem Spec
18 Sep 2013   #6

Windows 7 Ultimate x64
 
 

The ASUS BIOS can be set to force only use of the installed PCIe card; I have not yet done that but I shall. But, in the Auto mode, the BIOS is supposed to use a PCIe card if it is present, or use the iGPU if no PCIe care is present. This seems to work because I can connect the DVI monitor cable to the MB connector if I don't have the Radeon PCIe care installed and the system boots normally; I can also connect the monitor cable to the PCIe card if that card is installed and the system boots normally. Regardless of which graphics card I use, Windows still calls it only a Standard VGA Graphics Adapter. This is clearly not the case as even the iGPU is much more capable than only VGA. When I use Device Manager to show hardware, only a Standard VGA device appears, not the MB iGPU and not the Radeon board.

I don't understand why Windows is not showing something other than Standard VGA. I can run GPUx utility and it correctly shows the details of the GPU and video memory but even GPUx calls both cards Standard VGA. But, I think FPUx is actually getting this information from Windows, rather than reading from the actual graphics adapter; since Windows thinks both adapters are Standard VGA for some reason, it apparently provides that device name to GPUx. GOUx does say this name shown is as seen by the OS.

I will try setting the BIOS to use only the PCIe card and report.
My System SpecsSystem Spec
18 Sep 2013   #7

Windows 7 Ultimate x64
 
 

I changed the ASUS BIOS to force video to use PCIe bus card only. This made no difference in the problem I described. Once logged into my Windows account, the display is in VGA mode. Device Manager reports only Standard VGA Graphics Adapter as installed. Command Search for new hardware from the graphics item in Device Manager does not find the Radeon card--only the Standard VGA adapter is shown after the search.
My System SpecsSystem Spec
18 Sep 2013   #8

W7 Pro x64 SP1 / W8.1 Pro x64
 
 

Tough read at 4:45am, and I may have this wrong, but have you installed the software/drivers that came with the GPU?
My System SpecsSystem Spec
18 Sep 2013   #9
Microsoft MVP

 

Please complete the rest of the steps I gave you.

Have I not explained what Standard VGA driver is sufficiently? On newer hardware it is a placeholder driver for the rare GPU which doesn't have a driver in the installer or available via Windows Updates. It is not intended to be used permanently except in the cases of the oldest hardware which is not Windows 7 compatible, and which own XP driver cannot be installed in Windows 7 Compatbility mode. Is this any clearer now?

Please confirm you enabled Auto update of drivers and have installed all rounds of Important and Optional Windows Updates to completion. Do this now, or check again once more for Updates.

It would be interesting to see what Hardware Identification shows is the device being detected for which only Standard VGA driver is given thusfar. Can you trace that now, or are you unable to complete more than one step of the half dozen I've given you to try?
My System SpecsSystem Spec
22 Sep 2013   #10

Windows 7 Ultimate x64
 
 
Solution Found and It was Not Obvious

I now at last have my new desktop computer video graphics working. I thank the several responders who constructively helped; those who simply complained should read below. Perhaps the greatest help was being convinced I could not put Windows 7 into a failed graphics mode from which I could not recover.

Recall that I could not get my new Windows 7 desktop out of Standard VGA graphics mode, the default installed when no drivers are found for a high-resolution graphics card. I repeatedly ran the AMD Catalyst graphics card driver installation CD without effect, no mater what I did first within Windows Device Manager. The Catalyst installation program ran, progress bars progressed and there was final notice of completion, with no errors reported. But, no Catalyst application to control the Radeon card ever appeared in the Start menu and clearly no new driver was installed. There was a new Catalyst Error Reporting application with an error log; this error log was... empty. Every time I tried. But, Windows persisted in operating only with a Standard VGA Graphics Adapter.

Yet, folks kept telling me to install the AMD drivers. I surely thought I had tried that. What I did finally do was peruse the AMD website hoping to find some guidance. Finally, I noticed a fine print note stating that the AMD graphics installation software requires Microsoft NetFramework 4. NF 4? Four? I checked my Windows 7 Ultimate SP1 installation and found NetFramework 3.5 and not NF 4.

Mind you, the Catalyst installer never reported any failure and there was certainly no notice that a required library was not found. Recall those progressing progress bars! I'm not thinking kind thoughts of AMD software engineers...

So, off I went to the Microsoft website to get NetFramework 4 and install it in Windows 7. In the end, I then took a forced shortcut. I downloaded the latest Radeon graphics card driver installation package (135 MB!) from the AMD website. I left all the Device Manager settings alone and first tried running the AMD Catalyst driver install software but now with NetFramework 4 installed.

That took a while to install! At least, it seemed to be doing something; unlike the graphics card original CD installation software, this newer installer now with NetFramework 4 reported what appeared to be valid info from the Radeon card--at least different from what was shown by the original CD software before I installed NF 4. Following that, there was no display change, but there was a very small note that said the driver installer changed system settings and a re-boot was required. I did that and... it worked!

Following the reboot, Windows fell into 1920 x 1080 pixel resolution. And, Device Manager now lists the actual Radeon graphics card and reports it is working correctly. Gone is the Standard VGA Graphics Adapter, finally. So, if you are trying to install graphics drivers, best check to see if Microsoft NetFramework is needed and what version is required; don't expect the installing software to report the wrong NF version! Larry
My System SpecsSystem Spec
Reply

 Can't Get New Installaton Out of Standard VGA Mode




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:53 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33