Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with EVGA GTX 680, very worried.


18 Oct 2013   #1
manwelb6

Windows 7 64 bit
 
 
Problem with EVGA GTX 680, very worried.

I bought my new computer about 1 and a half years ago. This "problem" has been going on from when I bought it... I find my GTX 680 to lag at points that it should not lag at. For example at the moment I am playing Dead Space 1 and whenever I shoot the monsters with a flamethrower, the game lags. When those exploding monsters come and I shoot them, it lags. It used to do this in some other games too but I forgot which. I also play World of Tanks, no lag at all. Am I exaggerating, might it be the game, badly optimized? Dead Space was not downloaded illegally, it was bought from the Humble Bundle Thanks...


My System SpecsSystem Spec
18 Oct 2013   #2
paulpicks21

Windows 7 Professional 64 bit
 
 

Hi bud, can we assume your GPU drivers are up to date?
My System SpecsSystem Spec
18 Oct 2013   #3
manwelb6

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by paulpicks21 View Post
Hi bud, can we assume your GPU drivers are up to date?
Yes, they are. And I forgot to tell you, it is an EVGA GTX 680 Superclocked 2GB if it helps. Might my card be defective or somethin'?
My System SpecsSystem Spec
18 Oct 2013   #4
paulpicks21

Windows 7 Professional 64 bit
 
 

I would say if the problem has been going on since you bought it then yeah it sounds like you might have a bad card. That card should run any game smooth as silk. You could check the settings in game, AA is a big hit, try lowering them a little and see how you get on.
My System SpecsSystem Spec
18 Oct 2013   #5
manwelb6

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by paulpicks21 View Post
I would say if the problem has been going on since you bought it then yeah it sounds like you might have a bad card. That card should run any game smooth as silk. You could check the settings in game, AA is a big hit, try lowering them a little and see how you get on.
I know this might be silly, but may dust affect performance?
My System SpecsSystem Spec
18 Oct 2013   #6
manwelb6

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by manwelb6 View Post
Quote   Quote: Originally Posted by paulpicks21 View Post
I would say if the problem has been going on since you bought it then yeah it sounds like you might have a bad card. That card should run any game smooth as silk. You could check the settings in game, AA is a big hit, try lowering them a little and see how you get on.
I know this might be silly, but may dust affect performance?
No man, I think it is the game, not sure though.
EDIT: Ok nothing, the card is the problem, I think. I am gonna take my PC to the local store ASAP. I am getting real frigging angry about this. First I had to send it for the ram, then the hard disk, now the frigging GPU. Everything is dying slowly.
My System SpecsSystem Spec
Reply

 Problem with EVGA GTX 680, very worried.




Thread Tools



Similar help and support threads for2: Problem with EVGA GTX 680, very worried.
Thread Forum
Solved Evga GTX 260 SLI with Evga x58 mother board reboot issues Graphic Cards
Should I be worried? Performance & Maintenance
So I'm a bit worried about a rat.. System Security
Problem using nVidia dual mode with EVGA GTX 280 Graphic Cards
Should i be worried? General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:12 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App