Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: can't find my graphic card on the device manager

19 Oct 2013   #1

windows 7 ultimate x64
 
 
can't find my graphic card on the device manager

HI
i just bought a new laptop (lenovo g500 freedos) and installed windows7 ultimate on it.
i installed the drivers from the cd that came with the laptop and everything works great...except for the graphic card...i cant find it on the device manager...the card is amd radeon hd 8750m...what can i do?
thank you


My System SpecsSystem Spec
.

20 Oct 2013   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Welcome to Seven Forums GUY6421. Your laptop has switchable graphics. Between the intel HD 4000 and the discrete hd 8750m. It looks like the power plan determines what GPU(s) are listed:

Quote:
When in Energy Savings mode, only the low-power integrated graphics adapter will be listed in Device Manager. When in High-Performance mode, the integrated and discrete graphics adapter will be listed in Device Manager.
Laptop Support

A Guy
My System SpecsSystem Spec
20 Oct 2013   #3

windows 7 ultimate x64
 
 

That sounds smart...but i have a new problem now...i accidently listened to some guy on another forum and he told me to disable my integrated graphic card from the bios...so i did...and now the screen is blank...i tried to connect it to another screen like some people told me...but it still doesn't work....i saw on the internet that i need to reset cmos but i cant open the computer or the warranty will expire
i would realy appreciate it if you help me with this one...i have zero ideas of what i should do now...
My System SpecsSystem Spec
.


20 Oct 2013   #4

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Oh boy, I would think the CMOS battery would be the way, but let me see if our hardware Gurus have any ideas. A Guy
My System SpecsSystem Spec
20 Oct 2013   #5
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Try powering the laptop off, remove the power adapter and battery. Hold the power switch down for thirty seconds. Reconnect everything and test..
My System SpecsSystem Spec
20 Oct 2013   #6
Microsoft MVP

 

What did you disable in the BIOS? If you disabled onboard graphics the video card should still work. If you disabled card then the chip should still work unless it was separately disabled.

Do you get the BIOS screen when you boot before it goes blank? If so enter BIOS setup and reset to Defaults. If that fails, use another method to reset the CMOS: Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOS.

You can refine the method to rest the jumper or unplug the CMOS battery on your mobo by consulting your Manual on the Support Downloads webpage for your model. If it isn't shown there how to do it, ask google for a tutorial or video for your model PC to reset CMOS. Be sure to take precautions to avoid static discharge by not working on carpet, and touching metal on the case before touching any electronics.
My System SpecsSystem Spec
21 Oct 2013   #7

windows 7 ultimate x64
 
 

i have disabled just the onboard graphics from the bios and now i can't see anything when i'm pressing the power switch...not even the lenovo logo
and i tried to remove the battery and power adapter and hold the power switch..didn't work
My System SpecsSystem Spec
21 Oct 2013   #8
Microsoft MVP

 

Was the video card working previously? If you didn't disable it in BIOS it should work.

I asked you if you get the BIOS splash screen when you boot the PC. Please be thorough as not working through all of the steps when given can stretch this out for days when it only needs to take hours or less.
My System SpecsSystem Spec
21 Oct 2013   #9

windows 7 ultimate x64
 
 

no...i don't get the BIOS splash screen when i boot...i don't get anything...
and yes...the graphic gard was working before...but i disabled it in BIOS
My System SpecsSystem Spec
21 Oct 2013   #10
Microsoft MVP

 

Quote   Quote: Originally Posted by GUY6421 View Post
i have disabled just the onboard graphics from the bios...
Quote   Quote: Originally Posted by GUY6421 View Post

and yes...the graphic gard was working before...but i disabled it in BIOS
Which? Both?
My System SpecsSystem Spec
Reply

 can't find my graphic card on the device manager




Thread Tools



Similar help and support threads for2: can't find my graphic card on the device manager
Thread Forum
Intel Graphic card not listed in my Device manager Graphic Cards
Solved Nvidia Optimus GT 555M Graphic Card Dissapeard from Device Manager! Graphic Cards
Solved Device Manager shows my graphic card as Standard VGA Graphic Cards
graphic card in device manager showed a code 10 and 43 Graphic Cards
Help me to find my best Graphic Card. Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:57 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33