Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sapphire HD3650 64-bit problem


24 Oct 2009   #1

Windows 7
 
 
Sapphire HD3650 64-bit problem

Hi I have just ugraded to Windows 7 64-bit and am having trouble getting my Sapphire HD3650 to work, I have had a look through the forums and have seen the addition to the .inf file that I can do but I think the line I keep finding is for the 32-bit version...

I'm using the 9.10 Hotfix version and my product key thingy is 9596

but the [ATI.Mfg.NTx86.6.0] section doesn't exist, I think it has been replaced with [ATI.Mfg.NTamd64.6.0]

but if I add the line:

"ATI Radeon HD 3650 AGP" = ati2mtag_RV630, PCI\VEN_1002&DEV_9596

in that section when the computer restarts after installing the driver I just get a black screen and then it restarts itself and then I have to load up in repair mode and restore it to a previous point to get it to work again..

Im getting quite frustrated to any help you guy can give would be greatly appreciated!


My System SpecsSystem Spec
.

24 Oct 2009   #2

7600.20510 x86
 
 

We'll get this to work somehow.

If I had to bet, you are using the wrong .inf, hence your troubles.
The line is the same for 32 or 64 bit, just different sections, as you've noted.

Generally, you want to use the first .inf in the folder, when looking at the folder contents in alphabetical order.

You're on the right track. Let me know if this helps or we need to do other stuff to get it working. In very rare instances, the CPU to AGP bridge comes into play.
My System SpecsSystem Spec
24 Oct 2009   #3

Windows 7
 
 

this is all I get just the one .inf


Attached Thumbnails
Sapphire HD3650 64-bit problem-inf.jpg  
My System SpecsSystem Spec
.


24 Oct 2009   #4

7600.20510 x86
 
 

Alright. I don't think that's the right folder. Let me download the x64 and look. I'll get back to ya on this in a few.
My System SpecsSystem Spec
24 Oct 2009   #5

7600.20510 x86
 
 

The correct folder is

C:\ATI\Support\9-10_vista64_win7_64_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W76A_INF

and the .inf you should be using to edit is C7_83743.inf

This is for Catalyst 9.10 Suite, Windows 7, 64-bit.


Attached Thumbnails
Sapphire HD3650 64-bit problem-capture.jpg  
My System SpecsSystem Spec
24 Oct 2009   #6

Windows 7
 
 

i'll try that again but the last time I edited that one as soon as it loaded up I got a blue screen like an old memory fault, if I get the same thing this time I'll note down the error code, cheers for the help dude this is starting to kill my brain...
My System SpecsSystem Spec
24 Oct 2009   #7

Windows 7
 
 

just done that and now Im getting a code 52 on the card....

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

wondering how to deal with that one?
My System SpecsSystem Spec
24 Oct 2009   #8

7600.20510 x86
 
 

Oh right. I forgot about that since I don't use x64. x64 doesn't allow unsigned drivers I believe. But someone else in another thread and I got it to work for x64. He reported back and said it went great.

So maybe someone on x64 could tell you how to force the driver, if there is indeed a way.
My System SpecsSystem Spec
24 Oct 2009   #9

Windows 7
 
 

I've got that thing sorted now, I do it the way I did safe mode but when the driver actually works I get a blue screen of death and a quick countdown so I can't even get the error code...

Heard of that blue screen before?
My System SpecsSystem Spec
25 Oct 2009   #10

Windows 7
 
 

help please!
My System SpecsSystem Spec
Reply

 Sapphire HD3650 64-bit problem




Thread Tools



Similar help and support threads for2: Sapphire HD3650 64-bit problem
Thread Forum
Sapphire x1550 problem Graphic Cards
Sapphire HD 4650 AGP problem Graphic Cards
Sapphire HD5770 problem. Graphic Cards
HD3650 agp help Graphic Cards
sapphire 5450 hd problem Graphic Cards
Sapphire Wonder TV USB problem!! Software
sapphire 4670 problem Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33