Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 x86 + Sapphire HD 3850 = problem

25 Oct 2009   #11

7600.20510 x86

How's it goin' Fokogrilo? Any success over there? Any problems?

My System SpecsSystem Spec
25 Oct 2009   #12

Windows 7

Well, when i turned on the PC the it was always crashing like i told so i needed to format the hard drive. Its now formatting but i don't know why its taking more time then usually (only 57% ) guess i just have to wait...

When its complete i let you know
My System SpecsSystem Spec
25 Oct 2009   #13

7600.20510 x86

Cool. Good idea. Starting fresh is the way to go since you're having problems. You can have full confidence that the driver package I uploaded for you is good. It will not mess anything up. Good luck to you!
My System SpecsSystem Spec

25 Oct 2009   #14

Windows 7

I'm going to try it right now!


No luck...same thing...after Win7 loading the PC crashes

My PC specs: (probably can help)

Motherboard Matsonic ms9388e
2Gb Kingston (1+1)
Sapphire HD 3850
Intel Pentium 4 3.0GHz
My System SpecsSystem Spec
25 Oct 2009   #15

7600.20510 x86

"Supports AGP 3.0 Including 2X/4X/8x AGP Data Transfer"

Go into your bios and make sure your AGP slot is set to run at 8x. You may enable fast writes. Also make sure AGP is the default first video device.

Disable any onboard video in bios if there is an option to do so. Make the AGP Aperature size 128 MB.

Failing all that, please post a screenshot of your device manager in Windows. Show me all of your system devices.
My System SpecsSystem Spec
18 Mar 2010   #16

Windows 7

Sorry hijacking... if I can get your thoughts on this
I had my 3850 Saphire running on my old P4 EE System, with the AGP hot fix drivers downloaded from the Sapphire tech site. That was until the PSU went after replacing the PSU with a better one I start to get the Code 43 error. I ended up re installing Win7 on a new partition and windows would see the 3850 but still gave the Code 43. I took the Video Card back to the store and was refunded. There is new one there they shipped in for me to buy. Should I give the new card a try? I am really worried about getting the code 43 again. But I really do not want to scrap the old system

Asus P4P800-E Deluxe
2560MB Ram 3200 Adata
500 GB Seagate SATA HDD
Phillips Semiconductor TV PCI Card (Cant Remember the model)
On board Sound
3850 AGP SAPPHIRE 512 DDR3 (currently not installed ATM)
Windows 7 x86 Build 7600
My System SpecsSystem Spec
07 May 2010   #17

Windows 7 32-bit

Hello all!
Please help me!
My problem that I bought Sapphire HD 3850 last year and now, I don't play a lot of games on windows 7, but when xp was on the computer, I play every games!
For example: Mirror's edge: I played on XP, but I don't play it on win 7!
Please anybody answer it!
My System SpecsSystem Spec

 Windows 7 x86 + Sapphire HD 3850 = problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Sapphire HD 3850 AGP Card driver not working in Win7
Hi, I have a Sapphire Radeon HD3850 AGP card in my system but windows will not install the driver from the latest release of the ATI Catalyst driver install. Instead it defaults to the Standard VGA From what i have read on these forums i may need to change some information the CH87739.inf...
Graphic Cards
Sapphire Radeon HD 3850 - Dual/triple monitors problem.
Hi, For the last 3 years i have worked with Windows XP , 2x Sapphire Radeon HD 3850 512 MB videocards and 3 monitors connected (2x 22inch and 1x 19inch). This worked without a single problem. Since i got a terrible virus i was forced to upgrade to Windows 7. And from this moment the...
Graphic Cards
Sapphire HD 3850 PCIe
Dear friends, I have just built my very first PC but am having problems with the above graphics card. In device manager I am able to see that my HD 3850 is being detected, but I cannot see any of the monitors I have plugged into it. I have updated the latest version of ATI Catalyst (10.1)...
Graphic Cards
SAPPHIRE HD 3850 512MB GDDR3 AGP driver
tried every ati/sapphire/amd package/hotfix and still wont work my graphic card :/ any think i should list for some help wif this?
Sapphire HD 3850 agp help please
i looked at the stickys about this card and i cant get the driver to work no clue why i have a ASUS P4R800-VM motherboardm 2gb ram, intel pentium 4 cpu duel core 3.0ghz,Sapphire radeon HD 3850 512 agp i used 2 b on win xp but got a deadly virus and had 2 install windows 7 32bit and havnt got my...
Graphic Cards
Sapphire Radeon HD 3850 AGP + Win7 x64 = Code 43
Hi all, I know that the Sapphire card has recvd a lot of attention in the forums which made me register here. My m'board is Gigabyte GA-K8U-939 with Athlon X2 2.6 GHz and 3GB DDR. Windows 7 x64 detected the card but had an yellow symbol with the status code 43. Aero could not be enabled because...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:02.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App