Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No GPU activity, low performance

06 Jan 2014   #1
Ricky93

7 Professional 32 bits
 
 
No GPU activity, low performance

Hi guys, today I moved from 32 to 64 bits W7 so I can make better use of my CPU and RAM. I installed the most recent AMD drivers, 13.9.
I noticed my GPU activity is most of the part at 0%. Sometimes it has spikes where it goes up to 30/40% for a sec. My performance is pretty bad, I can't play any games and even youtube's videos sometimes lag.

Does anyone experienced similar results?


My System SpecsSystem Spec
.
06 Jan 2014   #2
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

can you fill out your system specs and also is this with one or two GPU's installed?
My System SpecsSystem Spec
06 Jan 2014   #3
archer

Windows 7 ultimate x64
 
 

Quote   Quote: Originally Posted by Ricky93 View Post
Hi guys, today I moved from 32 to 64 bits W7 so I can make better use of my CPU and RAM. I installed the most recent AMD drivers, 13.9.
I noticed my GPU activity is most of the part at 0%. Sometimes it has spikes where it goes up to 30/40% for a sec. My performance is pretty bad, I can't play any games and even youtube's videos sometimes lag.

Does anyone experienced similar results?
Hi Ricky,

As mentioned, please update your system specs. You mentioned that you installed x64 on your PC. Did you install the 64 bit driver for your card on your PC?

Download driver sweeper and the latest 64 bit drivers for your card (which you will update ). Uninstall the current drivers, run driver sweeper to clean the left overs of the driver. Reboot and then install that beautiful 64 bit drivers and check.

Keep us posted.
My System SpecsSystem Spec
.

06 Jan 2014   #4
Ricky93

7 Professional 32 bits
 
 

Core 2 Quad Q8300 @ 2.5 Ghz
4 gb ram ddr2
1x 4870 1GB

Yes I installed the 64 bit version of the drivers.
My System SpecsSystem Spec
06 Jan 2014   #5
archer

Windows 7 ultimate x64
 
 

Quote   Quote: Originally Posted by Ricky93 View Post
Core 2 Quad Q8300 @ 2.5 Ghz
4 gb ram ddr2
1x 4870 1GB

Yes I installed the 64 bit version of the drivers.
Did you do a clean install as mentioned in my post?
My System SpecsSystem Spec
Reply

 No GPU activity, low performance




Thread Tools




Similar help and support threads
Thread Forum
BSOD while AV scan activity or medium app activity
I get random BSOD when I do a full antivirus scan, or any medium application activity from MS office or graphics programs
BSOD Help and Support
Intel 520 SSD, low performance, high performance, then low again...?
I just now installed an Intel 520 240GB SSD. Measuring the performance, got strange results. First it did not at all perform close to my expectations and Intels promises:...
Hardware & Devices
Excessive HDD activity
This might have already been discussed but I'm desperate. Starting a week ago my Win7 desktop with a fresh build started to have excessive and constant HDD activity. The task manager and process monitor shows nothing strange. But the performance is terrible. I've tried... -Killing all processes...
Performance & Maintenance
Best way to log activity
Hello everyone, I'm starting to learn ICT and want to know how I can log the activity on a Windows 7 system. At this moment I made a simple script which will log the username, when he/she logged in/out and the ipconfig settings from that machine. My school can log everything like what...
System Security
Performance Has Changed To Performance Moniter
I am going through sql server 2005 implemetation and maintenance book. On chapter 15 it is going through useing performance moniter. which was about long before windows 7. Now ive got up to specifying my counters but i cannot find options to: 1. Set the inteval to one second. 2....
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App