Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Display Adapter not showing up under device manager/AMD not working +


02 Feb 2014   #1

Microsoft Windows 7 Home Premium 64-bit
 
 
Display Adapter not showing up under device manager/AMD not working +

Hi, I've been trying to figure out how to fix this for about two days now.

I've uninstalled everything AMD/ATI (multiple times) and tried to reinstall my graphics driver using AMD Catalyst. It always says that my computer "does not contain a proper graphics adapter." I've used Driver Sweeper to get rid of remnants, I'm in safemode right now because suddenly I couldn't get into normal mode (where I'd only be able to use VGA, everything for my adapter was put as "unavailable" when I checked under advanced for display properties). After the startup screen it went black but I could still see my cursor and move it around, it might of worked if I waited a bit longer but the length seemed odd so I rebooted into safemode.

At first I couldn't even get into normal mode, it would just be black + without cursor until I uninstalled my driver from device manager, but now I can't get the display adapters to show up again.

I've read a couple things about bios and something called pci but I'm not sure how either of those work (or what they are)? I'm not super great at computers.

Thanks.

My System SpecsSystem Spec
.

02 Feb 2014   #2

windows 7 home 64bit
 
 

Hi there ... Welcome to Seven Forums .. You have switchable Graphics ... Try downloading the Drivers from the Lenovo Website ...
My System SpecsSystem Spec
02 Feb 2014   #3

Microsoft Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by maxie View Post
Hi there ... Welcome to Seven Forums .. You have switchable Graphics ... Try downloading the Drivers from the Lenovo Website ...
The AMD drivers still didn't work when I tried to download from lenovo, it says it failed to detect system configuration.
My System SpecsSystem Spec
.


02 Feb 2014   #4

Win 7 Pro x64/Win 8 Pro x64 dual boot
 
 

The download didn't work or the install didn't work?
My System SpecsSystem Spec
02 Feb 2014   #5

Microsoft Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by Mellon Head View Post
The download didn't work or the install didn't work?
The install didn't work.
My System SpecsSystem Spec
02 Feb 2014   #6

windows 7 home 64bit
 
 

Hi again .. Read the Link below .. And follow the steps to try and Install the Driver .. Do not use any Links in the post to download the Driver .. Use the one from the Lenovos Official Website ..

solution for updating graphic cards for y560 with ... - Lenovo Community
My System SpecsSystem Spec
02 Feb 2014   #7

Microsoft Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by maxie View Post
Hi again .. Read the Link below .. And follow the steps to try and Install the Driver .. Do not use any Links in the post to download the Driver .. Use the one from the Lenovos Official Website ..

solution for updating graphic cards for y560 with ... - Lenovo Community
I can't boot into normal mode, I'm in safemode.
My System SpecsSystem Spec
02 Feb 2014   #8

windows 7 home 64bit
 
 

What has happened please explain ?
My System SpecsSystem Spec
02 Feb 2014   #9

Microsoft Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by maxie View Post
What has happened please explain ?
When I try to boot into normal mode, it just shows a black screen after the start up, but my mouse cursor appears and I can move it. It won't go into the log in screen, I've waited a while to see if it would until rebooting into safemode again.
My System SpecsSystem Spec
02 Feb 2014   #10

windows 7 home 64bit
 
 

Are you able to Uninstall the Driver for the Graphics card ? Try that and a Normal boot ..
My System SpecsSystem Spec
Reply

 Display Adapter not showing up under device manager/AMD not working +




Thread Tools



Similar help and support threads for2: Display Adapter not showing up under device manager/AMD not working +
Thread Forum
Solved Device manager showing Standard VGA graphics adapter after restore Graphic Cards
Network adapter not showing on device manager Network & Sharing
Wireless Adapter not found, yet its working properly in Device Manager Network & Sharing
network adapter not showing up in device manager Hardware & Devices
Wireless device not showing on Device Manager Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:22 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33