Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HD 4650 not detected after Windows reinstall

05 Feb 2014   #11
LinkAJ

W7 64bit
 
 

Quote   Quote: Originally Posted by archer View Post
Alright, Download Driver Sweeper.

Uninstall all the GPU drivers from the PC. After uninstalling, run Driver Sweeper to clean the leftovers of any old driver. Shut down the PC. Wait for some time (10-15 mins. So that there is no static left). Take out the GPU and reseat it properly. Turn on the PC. Make sure the fan on GPU is running.

Boot into Windows. Install the drivers now. Normally simply click on 13-9-legacy_vista_win7_64_dd_ccc_whql and run the setup.
Okay I did exactly that, step by step.
Now during the last setup i get this:


Also I know my graphics card is working, because my motherboard does not have a onboard VGA chip, so the problem lies with updating this graphics card driver...


My System SpecsSystem Spec
.
05 Feb 2014   #12
LinkAJ

W7 64bit
 
 

Catalyst™ Install Manager
Installation Report
02/05/14 13:41:10


Hardware information
Name AMD Radeon Graphics Processor
Manufacturer Advanced Micro Devices, Inc.
Device ID 0x9495
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x00
Subsystem ID 0x0028
Subsystem vendor ID 0x1682
Other hardware

Existing packages
Packages for install
AMD Catalyst Install ManagerFinal Status: Success
Version of Item: 8.0.877.0
Size: 20 Mbytes
AMD APP SDK RuntimeFinal Status: Success
Version of Item: 10.0.937.2
Size: 90 Mbytes
AMD VISION Engine Control CenterFinal Status: Success
Version of Item: 2013.0429.2313.39747
Size: 150 Mbytes


Other detected devices

Manufacturer Advanced Micro Devices, Inc.
Device ID 0xaa38
Vendor ID 0x1002
Class Code 0x040300
Revision ID 0x00
Subsystem ID 0xaa38
Subsystem vendor ID 0x1682

AMD Radeon Graphics Processor
Manufacturer Advanced Micro Devices, Inc.
Device ID 0x9495
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x00
Subsystem ID 0x0028
Subsystem vendor ID 0x1682


Manufacturer Advanced Micro Devices, Inc.
Device ID 0xaa38
Vendor ID 0x1002
Class Code 0x040300
Revision ID 0x00
Subsystem ID 0xaa38
Subsystem vendor ID 0x1682


Manufacturer Advanced Micro Devices, Inc.
Device ID 0x1100
Vendor ID 0x1022
Class Code 0x060000
Revision ID 0x00
Subsystem ID 0x0000
Subsystem vendor ID 0x0000


Manufacturer Advanced Micro Devices, Inc.
Device ID 0x1101
Vendor ID 0x1022
Class Code 0x060000
Revision ID 0x00
Subsystem ID 0x0000
Subsystem vendor ID 0x0000


Manufacturer Advanced Micro Devices, Inc.
Device ID 0x1102
Vendor ID 0x1022
Class Code 0x060000
Revision ID 0x00
Subsystem ID 0x0000
Subsystem vendor ID 0x0000


Manufacturer Advanced Micro Devices, Inc.
Device ID 0x1103
Vendor ID 0x1022
Class Code 0x060000
Revision ID 0x00
Subsystem ID 0x0000
Subsystem vendor ID 0x0000


Error messages
Application Install: install package failure!
My System SpecsSystem Spec
05 Feb 2014   #13
archer

Windows 7 ultimate x64
 
 

Uninstall 'microsoft visual c++ 2010 redistributable' that comes with win7 from windows add/remove programs.

Next if you have problem with INF file,
1. After seeing the "Driver install: the INF file was not found" error message,
use Device Manager to update the driver, navigating to the C:/ATI directory and checking the "search subfolders" box.
2. Reboot the computer.
3. Run Catalyst installer, but this time, select uninstall and get rid of everything.(Just select express)
4. Now reinstall Catalyst using the driver installer as you would. It should work fine.
My System SpecsSystem Spec
.

05 Feb 2014   #14
LinkAJ

W7 64bit
 
 

Hey Archer,

First of all thanks for the support, however after following those steps, it still isnt working.

The problem lies with updating the graphics card driver.
When I select the .INF file in the C:/ATI directory I get either one of these two screens:



So it still does nothing I dont know where the problem lies. Could it be the Windows 7 64bit I have? Or is the driver too new maybe, because the hardware is somewhat old now.
My System SpecsSystem Spec
05 Feb 2014   #15
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

I installed the AMD 13.9 driver and I have an AMD 4290 chipset -- so I would think the situation would be the same with your 4650. I used the standard installer and it did not appear to work, so I used the installation method utilizing the INF directory -- and it did work.

However ... my drivers are not under C:/ATI; instead, they are under C:/AMD/Support/13-9-legacy_vista_win7_32_dd_ccc/Packages/Drivers/Display/W7_INF/

I would think yours would be the same expcept that "win7_32" would be "win7_64".
My System SpecsSystem Spec
05 Feb 2014   #16
LinkAJ

W7 64bit
 
 

Quote   Quote: Originally Posted by Mark Phelps View Post
I installed the AMD 13.9 driver and I have an AMD 4290 chipset -- so I would think the situation would be the same with your 4650. I used the standard installer and it did not appear to work, so I used the installation method utilizing the INF directory -- and it did work.

However ... my drivers are not under C:/ATI; instead, they are under C:/AMD/Support/13-9-legacy_vista_win7_32_dd_ccc/Packages/Drivers/Display/W7_INF/

I would think yours would be the same expcept that "win7_32" would be "win7_64".
Heya, thanks for the reply,

Yeah, what I meant was C:/AMD, my .INF files are in the same location,
also there appear to be 2 .INF files there: CH158498.INF and C7158498.INF
whats the difference between those 2?
My System SpecsSystem Spec
05 Feb 2014   #17
LinkAJ

W7 64bit
 
 

So I noticed 2 installer files, next to the 2 .INF files.

I first tried the CH15849, but that one was not compatible, so it said.
Then I tried the C7158498, which did install something, I driver I would think.
Only after the "succesful" install, nothing happened or changed...

My System SpecsSystem Spec
05 Feb 2014   #18
LinkAJ

W7 64bit
 
 

Could it have something to do with the motherboard chipset? How do I update that?
My System SpecsSystem Spec
06 Feb 2014   #19
archer

Windows 7 ultimate x64
 
 

It seems that you need to do clean install of Windows again. Here's how you can do it. Clean Install Windows 7
My System SpecsSystem Spec
06 Feb 2014   #20
LinkAJ

W7 64bit
 
 

After many hours of searching I finally found a driver that actually works!
I noticed that with all previous drivers Catalyst Control Center didnt install, it was nowhere to be found, which was strange.

But I found this older hotfix driver:
10-2_agp-hotfix_vista_win7_64_dd_ccc.exe
which actually installed CCC for the first time, and after that it changed the 'Standard VGA Adapter' to 'Radeon HD 4600 series' .

So I think I'll just use this older driver for now, as it seems to be working.
My System SpecsSystem Spec
Reply

 HD 4650 not detected after Windows reinstall




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Bluetooth dongle detected, items detected but not connecting.
Hi guys, I bought a bluetooth dongle off of amazon so I could use my bluetooth headset with my comp. Once plugged in it installs driver version 6.1.7601.17889 from microsoft and there are no yellow '?'s. When I look for devices it sees my headset no probs but will not connect, which it does...
Hardware & Devices
Windows 7 new installation with agp radeon 4650 BSOD
(btw sorry for my english) i've got an old pc here asus k8v-mx amd sempron 3000+ 2 gig ram with ATI HD radeon 4650 if im using my radeon to setup windows, i just cant finish the installation so im using my onboard video card, finishing setup trying to upgrade ATI driver but always the...
BSOD Help and Support
ATI Radeon HD 4650 Windows 7 Problem
Hey Guys, This is a help question it isn't my computer though. The person upgraded there video card to the ATI Radeon HD 4650 with 1GB GDDR3 video memory and runs just one display. He downloaded the latest drivers right from the ATI website and not the CD. Now what is happening is every so often...
Graphic Cards
radeon 4650, win 7 and LCD TV - HELP
Hi, I am configuring a media PC, win 7 connected via VGA to a 32 inch LCD TV. Im struggling to configure the system to output consistently to the TV. I am able to connect via VGA to a monitor, set the resolution to 1368x760 which is the res of the TV, reconnect the VGA to the TV and all works...
Graphic Cards
ATI Radeon HD 4650
Hey guys I'd like it if you could help me over clock my Radeon, I'll give you the specs. ATI Radeon HD 4650 AMD Phenom II X4 925 Processor 2.80 GHz 8.00 GB RAM 64-Bit Windows 7 Let me know if there is anything else you'll need to help me : ]
PC Custom Builds and Overclocking
ATI Radeon HD 4650
Play.com (UK) : Play Value ATI Radeon HD 4650 / 1GB DDR2 / PCI Express 2.0 / Graphics Card : Computing - Free Delivery I am looking to buy a new graphics card. I have selected a card, the ATI Radeon HD 4650. I would like to know if any of you know anything about this card performance wise. How it...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App