Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: GTX 660 drivers causing slowed performance and glitchy blocks

21 Feb 2014   #11
badger906

Windows 7 Ultimate x64, & Mac OS X 10.9.2
 
 

personally id get something made by corsair. theyre a little more expensive but all their power supplies come with 7 year warranties and are renound for giving very accurate and stable voltages.


My System SpecsSystem Spec
21 Feb 2014   #12
Solarstarshines

Windows 7 Home Premium 64bit sp1
 
 

Quote   Quote: Originally Posted by badger906 View Post
personally id get something made by corsair. theyre a little more expensive but all their power supplies come with 7 year warranties and are renound for giving very accurate and stable voltages.

Agreed they have fast and no questions asked RMA's

I had a AX850 it died i went got it rma'ed sold it bought a HX1050 80+Silver (now they are 80+Gold)

Damn thing is a Beast never get's worked up and i have had some serious set ups and it still pushes like day one
My System SpecsSystem Spec
24 Feb 2014   #13
TheShadbusher

Windows 8.1 Pro x64
 
 

I got the Corsair 600M PSU, and it's working great so far.

Unfortunately, the problem persists. The card's performing well in its benchmarks though, getting a minimum of 150 FPS with 8x MSAA.

The problem only occurs when Aero mode is on, and/or there's a GPU-"intense" program running (as in more GPU-instense than running the desktop), i.e. a game, Google Chrome, etc.

I'll call EVGA again in the morning, and I'll update the drivers again tonight.

What's funny though, is when it's running the benchmarks, the artifacts disappear until I open another GPU-"intense" program. The benchmark is reporting anywhere from 0 to 7 to 20,000 artifacts at times during the test though.
My System SpecsSystem Spec
24 Feb 2014   #14
AddRAM

Windows 7 Professional x64 Zorin OS 9 Core x64 Xubuntu 13.1 x64 Linux Mint 17 x64
 
 

Now that you`ve got a new PSU, call EVGA again and say ok, now what do we do ?

It`s a 660, they should honor you with a new one or a 760.
My System SpecsSystem Spec
25 Feb 2014   #15
TheShadbusher

Windows 8.1 Pro x64
 
 

I sent in a standard RMA and uploaded the invoice.

A 760 would be nice, but they only send you a better card if they don't have any of your card in stock, which seems unlikely.
My System SpecsSystem Spec
15 Mar 2014   #16
TheShadbusher

Windows 8.1 Pro x64
 
 

The replacement card (a 660) arrived Thursday, and everything's fine now. Thanks for the help, guys. <--- Dang, that's a creepy smile.
My System SpecsSystem Spec
16 Mar 2014   #17
Dude

Windows 8.1 Pro + Windows 10
 
 

Good to hear you are good now, thanks for posting back
My System SpecsSystem Spec
Reply

 GTX 660 drivers causing slowed performance and glitchy blocks




Thread Tools





Similar help and support threads
Thread Forum
Startup And Computer Slowed After Instaling Drivers,Programs,.Dlls etc
Hi all,i recently had an 0xc000007b error with a headset software.I tried everything on the internet to solve problem including uninstalling and installing .net framework, visual c++ (all versions), some .dll s both in system32 and syswow64,reinstalling drivers and some other things that i cannot...
Performance & Maintenance
Win 7 slowed down after GPU drivers update
Hello, I have a pretty confusing problem, that I am unable to solve. Few weeks ago I have reinstalled Windows 7, because my notebook was getting really slow. For about a week after the fresh installation, everything went just perfect. Then I started getting black screen after logging into my...
Performance & Maintenance
Mouse lag / freeze issue (Slowed performance)
Hey guys, It's been a while since I've posted, been missing the great community here! Okay, usually I can solve most of my computer related problems due to everything I've learned here and at VF! But... I can't seem to find out what's wrong this time... Help! My cursor seems to keep...
Performance & Maintenance
Wmpnetwk.exe causing problems with speed and performance.
I recently had some pretty major performance issues with my windows7 laptop. I have now found out the wmpnetwk.exe service is the main problem, if anyone out there is having problems with performance, then i would suggest turning this service off as it uses so much of the physical memory just for...
Performance & Maintenance
HP USB print drivers causing issues
I have an HP4100 printer that I am trying to use with a new Windows 7 laptop, and I have had a range of issues. Let me explain the saga in case any steps are important. At first, it seemed simple. When I plug in the printer, Windows 7 searches for and finds an HP PCL6 driver that it...
Drivers
Performance slowed down by Aero
Hi! I have the following problem: After only one wake up of the PC (resume from sleep) when I close an opened window the Aero close effect seems to freeze on the last frame for 3-4 seconds. I am using the latest updates. This has been so ever since I installed Windows 7. I am not fully sure what...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App