Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Strange Duck this Gigabyte R7-260 video card

26 Feb 2014   #1
idahjo

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Strange Duck this Gigabyte R7-260 video card

I asked for suggestions for a video card on an earlier post Graphics card suggestions please
and decided to purchase a Gigabyte R7-260x (PCIe 3.0), knowing it was overkill for my intended purpose; but having the necessary plug-ins..
The Intel board I wanted it for was a PCIe 2.0 and the new card was a 3.0 (exchangeable according to conventional wisdom). The Intel wants nothing to do with it.
I reinstalled the Sapphire HD 4850 (PCIe 2.0) that I had taken out of the Intel and it was immediately detected and ran fine. To proof it, I put an older MSI R 4550 HD (PCIe 2.0) into the Intel and it also worked fine.
Thinking the Gigabyte R7-260x may be faulty, it was put in a Gigabyte board with PCIe 2.0 and it worked fine.. Video card is OK!
All the BIOS settings have remained the same through the tests. It seems the Intel just does not like the Gigabyte R7-260x, unless the "strange duck" needs some special enticement to kick its butt?


My System SpecsSystem Spec
.
26 Feb 2014   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
It seems the Intel just does not like the Gigabyte R7-260x
You pretty much answered your own question. It is the board that needs a bios update to work with the card. It likely isn't just the 260X you have but anything from the R7/R9 line that won't work with the board. Wouldn't be the first time a new line/generations of video cards have come out and need a motherboard bios update to work. It is entirely up to Intel to come out with the update, which I don't see happening as the last bios update for that board was a year and a half ago.

P.S. It has nothing to do with PCI-E 2.0 or 3.0.
My System SpecsSystem Spec
27 Feb 2014   #3
idahjo

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Technology advances rapidly...

Thanks Stormy for the reply. Kinda figured I was correct in my assumption.
Will just use the R7 260x in something else and maybe replace the old Intel board.

Cheers!
My System SpecsSystem Spec
.

Reply

 Strange Duck this Gigabyte R7-260 video card




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Gigabyte 550 ti gpu no video after install
So I just bought a new gpu and CPU for my pc and when I finished installing it and puting it back together and hooking it up I started it up and came to see that the screen was still black but it sounded like it booted up fine the card is the one in the title And the CPU is core 2 duo e7500
Hardware & Devices
Trying to set up 3 monitors with Gigabyte Radeon 6950 card
Greetings, I am trying to set up 3 separate monitors using a Gigabyte Radeon 6950 graphics card in Windows 7 HP x64. The monitors: 2 - Acer 21.5" DVI-D widescreen 16:9 running natively at 1920x1080 1 - 32" Sony HDTV also at 1920x1080, via HDMI The graphic card's physical outputs are:...
Graphic Cards
Intel Video Card?Driver? Strange Problem
Well, it's not a problem (now). I'm playing old games and i got lags in places, where are many of 3D models and I'm having white spots/dots on them. Here's the pic: http://img195.imageshack.us/img195/7388/spotsb.th.jpg Do I need to reinstall my Windows? Do i need to change my graphics card?...
Graphic Cards
Strange USB Port scenario with Gigabyte Motherboard
Hi. Can someone explain what might be going on here please. MoBo ~ Gigabyte GA-73PVM-S2H on Windows 7 I have a Belkin USB Hub which is connected to one of the rear MoBo USB ports and works fine. I also have a USB Wireless Adapter which is plugged into one of the Hub Ports and works fine. To...
Hardware & Devices
Intel i3 Video Card?Driver? Strange Problem
Well, it's not a problem (now). I'm playing old games and i got lags in places, where are many of 3D models and I'm having white spots/dots on them. Here's the pic: http://img195.imageshack.us/img195/7388/spotsb.th.jpg Do I need to reinstall my Windows? Do i need to change my graphics card?...
Graphic Cards
Gigabyte P5100 TV Card
I have serious problems with this TV card. I installed the latest drivers, but i have no picture only sound. For viewing i'm using Presto player that came with the card. Card is connected to analog antenna.
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App