Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Radeon 3650 HD AGP

28 Oct 2009   #1
Dylantog

Windows 7 Professional 64 bit (x64)
 
 
ATI Radeon 3650 HD AGP

Hello everyone, I registred just because Im getting really annoyed to have no aero and cant play games.

As you see in the title, I have an Sapphire ATI Radeon 3650 HD AGP and I cant get it to work on Windows 7 Home Premium.

I tried many things also listed on this forum, downloaded agp hotfixes, normal catalyst drivers etc, edited the inf and added:


"ATI Radeon HD 3650 AGP" = ati2mtag_RV630, PCI\VEN_1002&DEV_9596

Tried that with this alone and with every other graphic cards, tried manual and auto(trough catalyst setup) setup but I just cant get it too work.

Also many times I cant manually install as windows says that it didnt find any newer driver then the standard VGA.

This is my pc specs:

CPU: Amd Athlon 2400+ 2 Ghz (I know its old :P)
Motherboard: SiS K7S8X
RAM: 1 GB

Please I really need help


My System SpecsSystem Spec
.
28 Oct 2009   #2
torrentg

7600.20510 x86
 
 

Excellent chance you are doing something slightly wrong. I'll upload a package that I'll make for you to lessen the chance of any errors.

Give me a few mins. In the meantime, make sure your motherboard does not use nForce 3 or lower for southbridge. My up is only 50K/sec so....
My System SpecsSystem Spec
28 Oct 2009   #3
Dylantog

Windows 7 Professional 64 bit (x64)
 
 

Thank you man

No my motherboard uses SiS southbridge
My System SpecsSystem Spec
.

28 Oct 2009   #4
torrentg

7600.20510 x86
 
 

You're welcome.

Here's 3650 AGP package, 9.10 Catalyst Suite, x86 32-bit. Use Winrar to extract it to C:\ATI

RapidShare: 1-CLICK Web hosting - Easy Filehosting

Right click your card in device manager, choose update driver software. Browse. Let me pick. Have disk. Browse. Choose CL_83742.inf in

C:\ATI\Support\9-10_vista32_win7_32_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W7_INF

If it complains the driver is not signed, let it install anyway. Reboot and then choose an Aero theme by rt clicking desktop, choose personalize.

Run setup.exe in C:\ATI\Support\9-10_vista32_win7_32_dd_ccc_wdm_enu\Driver
if you want CCC too.
My System SpecsSystem Spec
28 Oct 2009   #5
Dylantog

Windows 7 Professional 64 bit (x64)
 
 

-.- First have to wait rapidshare is too busy right now.

Anyway thanks for your help man but I dont have the english Windows 7 but Dutch and I dont know what you mean by this :
Let me pick. Have disk.

Do I just press update driver then let me search and browse to that folder ?
If I do that there is no file selection only folder selection.

Sorry if this was a stupid question :$
My System SpecsSystem Spec
28 Oct 2009   #6
torrentg

7600.20510 x86
 
 

No question is a stupid question.

It's cool because this gives me a chance to show my l33t Photoshop skill0rz.


Attached Images
   
My System SpecsSystem Spec
28 Oct 2009   #7
Dylantog

Windows 7 Professional 64 bit (x64)
 
 

Thanks


Just from there and litterly select the inf file right ?
My System SpecsSystem Spec
28 Oct 2009   #8
torrentg

7600.20510 x86
 
 

Correct. The .inf is located at C:\ATI\Support\9-10_vista32_win7_32_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W7_INF\CL_83742.inf
My System SpecsSystem Spec
28 Oct 2009   #9
Dylantog

Windows 7 Professional 64 bit (x64)
 
 

Well, it doesnt work, this is what I put in:

C:\ATI\Support\9-10_vista32_win7_32_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W7_INF\CL_83742.inf

But when I click ok it says that that file doesnt has a driver for my device ?
My System SpecsSystem Spec
28 Oct 2009   #10
torrentg

7600.20510 x86
 
 

You don't have to enter that. You have to navigate to that location on the hard drive, then click on the .inf.


Attached Thumbnails
-capture.jpg  
My System SpecsSystem Spec
Reply

 ATI Radeon 3650 HD AGP




Thread Tools




Similar help and support threads
Thread Forum
Amaze ATI Radeon HD 3650
im having problem with ati radeon hd 3650. when i install this card in win 7 it asks for restart and when i restart my pc it stalls just after the windows logo starts shinning when its loading. The manufacturers cd i got doesnt have drivers for ati radeon hd 3650 so i just installed the 3600 series...
Graphic Cards
Radeon 3650 AGP AERO
Hello All i am here new but yesterday Windows 7 on my old PC (not too much old but it isnt any suprise) GPU: Sapphire Radeon 3650 AGP DDR2 MB: ECS nForce 3a k8n 250 CPU: AMD Sempron 3000+ 1.81GHZ @ 2.25GHz RAM A-DATA 1GB DDR400 HDD 160GB Hitachi 7200RPM 8mb cache PSU: Micasse WR 300 300watt ...
Graphic Cards
Need help with drivers for an ATI Radeon HD 3650
When i look into my devices and go under display devices, all i can ever see is Standard VGA graphics adapter. I have downloaded and installed the newest windows 7 32-bit drivers for the card, but whenever i go and check the devices again, it still hasn't changed from the Standard VGA device....
Drivers
ATI radeon HD 3650 not detected
Windows 7 wont detect my graphic card.. I had XP and installed Windows 7 today, but for some reason it wont detect My ATi card. I cant run any games and things that require some sort of graphic. like screensavers. When i check the device manager all it sais is that i have a standad VGA screencard....
Graphic Cards
ATI Radeon HD 3650 can't see my TV
I currently have an ATI Radeon HD 3650 (PCIe) in my WIndows 7 64-bit PC. It works fine except when I went to connect it to my TV via the S-Video cable. For some reason it doesn't see the TV at ALL, even with the latest drivers and Catalyst Control Center. Not sure if I need some special drivers or...
Graphic Cards
ATI Radeon HD 3650 PCIe issue
I've performed a clean install of windows 7 and it loaded the driver for my video card. (Radeon HD 3650 PCIe 512MB) Windows 7 is sooo slow. I looked in the process explorer and the System Interrupts is taking 80-100% of my CPU Usage, its crazy. I can barely do anything. I think/have a feeling,...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:27.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App