Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with my display drivers...

25 Jul 2014   #11
axelas

windows 7 x64
 
 

I have the exact same problem , the driver doesnt install because of
"Error messages

Driver Install: user must be a member of the Administrators group
Driver Install: user must be a member of the Administrators group"
I have enabled the hidden administrator using the methods described here Built-in Administrator Account - Enable or Disable
but to no avail . The driver still doesnt want to install it self , keeps telling me i have to be a member of the admin gr... bla bla bla ...
Anybody got any ideas what i can do next ?


My System SpecsSystem Spec
.
25 Jul 2014   #12
sygnus21

Windows 10 Pro
 
 

Well you still seem to not have admin rights to install said driver. Is this your computer or are you sharing it with someone?
My System SpecsSystem Spec
25 Jul 2014   #13
axelas

windows 7 x64
 
 

My personal home pc .
Specs .
Computer type PC/Desktop
OS windows 7 x64
CPU i7 3770k
Motherboard asus maximus V extreme
Memory Corsair Vengeance RED @1866 -16 Gb- 2x8
Graphics Card Sapphire Radeon HD 7970 Dual-X 3GB
Windows 7 x64 Ultimate SP 1


I can provide other info if needed .
PS Edit : Also i tried installing the 14.7 beta driver with the exact same results.
My System SpecsSystem Spec
.

25 Jul 2014   #14
sygnus21

Windows 10 Pro
 
 

It this is your personal PC you shouldn't be having admin issues unless something happened to mess them up.

Do you have UAC turned off?
My System SpecsSystem Spec
25 Jul 2014   #15
axelas

windows 7 x64
 
 

Yes , ofc . Or should i enable it ?
My System SpecsSystem Spec
25 Jul 2014   #16
sygnus21

Windows 10 Pro
 
 

If UAC if off enable it and try installing the driver.
My System SpecsSystem Spec
25 Jul 2014   #17
axelas

windows 7 x64
 
 

Still the same problem .




Catalyst™ Install Manager
Installation Report
07/26/14 00:57:50


Hardware information

Name AMD Radeon Graphics Processor
Manufacturer Advanced Micro Devices, Inc.
Device ID 0x6798
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x00
Subsystem ID 0x3000
Subsystem vendor ID 0x174b
Other hardware

Existing packages
AMD Catalyst Install Manager
AMD Display Driver
AMD Accelerated Video Transcoding
AMD Drag and Drop Transcoding
AMD Media Foundation Transcoders
AMD Catalyst Control Center
AMD Gaming Evolved App

Packages for install
AMD Catalyst Install Manager
Final Status: Success
Version of Item: 8.0.916.0
Size: 20 Mbytes
AMD Display Driver
Final Status: Fail
Version of Item: 14.100.0.0000
Size: 90 Mbytes
HDMI Audio Driver
Final Status: Fail
Version of Item: 7.12.0.7718
Size: 1 Mbytes
Microsoft Visual C++ 2012 Redistributable (x64)
Final Status: Success
Version of Item: 11.0.50727
Size: 9 Mbytes
AMD Catalyst Control Center
Final Status: Success
Version of Item: 2014.0417.2226.38446
Size: 150 Mbytes


Other detected devices


Manufacturer Advanced Micro Devices, Inc.
Device ID 0xaaa0
Vendor ID 0x1002
Class Code 0x040300
Revision ID 0x00
Subsystem ID 0xaaa0
Subsystem vendor ID 0x174b


Error messages

Driver Install: user must be a member of the Administrators group
Driver Install: user must be a member of the Administrators group


I have turned off ALL antivirus protection and firewall( Windows Defender, Microsoft Security Esentials and Malwarebytes Anti-malware .
Turned UAC ON full to the top .
Turned on hidden administrator using lusrmgr.msc.
Closed all the applications that are being used.
Than I uninstalled the ATI catalyst driver manager with an error occurring


Afther that i rebooted the system and the ATI driver catalyst manager program is unlisted from the list of programs installed in windows ...but its actually still installed ,no changes to resolution ,the program (ccc.exe is still up and running ...program tray is active ...etc .)


What can i try next ?
My System SpecsSystem Spec
25 Jul 2014   #18
sygnus21

Windows 10 Pro
 
 

Are you sure you're installing the correct version for you OS? You indicate you have a 64-bit OS, are you trying the 64-bit drivers?

Also can you post an image of your user profile? It should look something like this...

Problem with my display drivers...-user-account.jpg

Thanks.


My System SpecsSystem Spec
25 Jul 2014   #19
axelas

windows 7 x64
 
 

14-4-win7-win8-win8.1-64-dd-ccc-whql.exe >263mb
That's the name of the file i've downloaded from amd / ati site.
When i got to CP > User Accounts and clicked "Change your account type" it looked like this :
[IMG]

[/IMG]

.If i click to change to ADMINISTRATOR then the CHANGE ACCOUNT TYPE button turns to gray and i cant modify my account .
This is probably due to what i've done over at "lusrmgr.msc" . This is my best guess.
Should i log onto this newly made admin account and try installing there ?

EDIT : or shoud i use "lusrmgr.msc" to disable the admin acount and restore my account ?
My System SpecsSystem Spec
25 Jul 2014   #20
sygnus21

Windows 10 Pro
 
 

You need to restore to the defaults of whatever you did and go from there. And I can't help with hacking around security.

Also could you load you images here instead of off site. Check this tutorial if you don't know how - Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
Reply

 Problem with my display drivers...




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
problem with install of ati display drivers
hi all 2day i started to update my gpu drivers to the 11.10 prev version 3 ready for BF3 2moz. only this time it was slightly differant. when i clicked the bottom option to remove all ati drivers. i got a warning that it may uninstall chipset drivers and somethin else. i havent had this b4. so i...
Drivers
display drivers stop responding on ati 5870 10.11 drivers
Hello all! I'll try to explain my problem. Last week I tried to update my ati 5870 drivers with the latest 10.11. I had 10.9 so far so good. My problem is that with these drivers I got this message from windows : display drivers have stop responding and they've been recoveres (or something...
Graphic Cards
How do I set up drivers for my Pioneer display
Hi, I'm running W7 ultimate 32bit on an old P4 machine with a Sapphire ATI HD4550 graphics card. It's only use is a media player / HTPC for our lounge, using an old Pioneer PDP-433MXE plasma as a display. This is a 1024x768 widescreen, pre-HD unit, without a HDMI port. Connection is via good old...
Graphic Cards
Display driver intel graphics accelerator drivers PROBLEM
Everytime I use explorer on my Toshiba Satellite laptop, my screen turns black and then displays the the intel graphics accelerator drivers has stopped responding and has recovered. Im very frustrated with this as to it is really causing my pc to not work properly. Any input would be very helpful....
Drivers
Display Drivers???
Hello I've got a VAIO VGN-FE11M and got some "display troubles". Everytime I close my laptop the screen stays turned off for ever.... Is there any solution?
Drivers
Display and Monitor Drivers PROBLEM!!
I have a ATI Radeon 7500 and i can't let windows 7 Build 7600 find it. It says under display monitor its a Standard VGA graphics adapter. I'm getting really annoyed because i can't play counter-strike...and i installed many different drivers for it but it just doesn't work. and i also wanted the...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App