Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: GTX 770 2GB DirectCU II issue, monitor goes blank

15 Jun 2014   #1
draptak

Windows 7 Ultimate 64-Bit
 
 
GTX 770 2GB DirectCU II issue, monitor goes blank

Got a new GPU, my monitor goes blank when I try to play a game.
I have the driver up to date

I have a Corsair CX750M PSU, it has 62 A on the +12v rail.

Could my BIOS be the issue ?Should I update it? I dont know how to do it. I have tried a patch from the ASUS bios update but it says 'This patch does not support this card'

Specs:
CPU: Intel® Core™2 Quad Processor Q9400 at 2.66 GHz
GPU: GTX 770 2GB DirectCU II
Memory RAM: 6GB
Windows 7 64bit


My System SpecsSystem Spec
.
15 Jun 2014   #2
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

Quote   Quote: Originally Posted by draptak View Post
Got a new GPU, my monitor goes blank when I try to play a game.
I have the driver up to date

I have a Corsair CX750M PSU, it has 62 A on the +12v rail.

Could my BIOS be the issue ?Should I update it? I dont know how to do it. I have tried a patch from the ASUS bios update but it says 'This patch does not support this card'

Specs:
CPU: Intel® Core™2 Quad Processor Q9400 at 2.66 GHz
GPU: GTX 770 2GB DirectCU II
Memory RAM: 6GB
Windows 7 64bit
You should try also to ask/browse at the Asus ROG GeForce Graphic Cards Forums must be some having kind of this issue you're mentioning.

You're PSU is fine for One GTX 770 DC2 card. Try not use the adapter Asus have furnished inbox but power it directly from the PSU dedicated viudeo PCI-e rails.

Be careful with updading your Graphics card vBios. You could save the original one using latest GPU-Z (small icon in Bios version section).

I saw that the last vBios for that card GTX 770 DC2 is from October 30, 2013, which seems if yours is brand new that it got the most up-to-date vBios.
My System SpecsSystem Spec
Reply

 GTX 770 2GB DirectCU II issue, monitor goes blank




Thread Tools




Similar help and support threads
Thread Forum
2nd monitor screen is blank
Hello , I recently bought a 2nd monitor and i was intending to have my old one as the 2nd monitor however it's not working properly. The PC detects a 2nd monitor and when i drag my mouse far left side the cursor disappears meaning it went to the 2nd monitor but the monitor is blank so any help...
Graphic Cards
Dual Monitor issue one of them goes blank after a few minutes
I am running Win 7 Pro x64, i7, MSI Twin Frozr II R6870 1st Monitor is a Dell SP2309W (dvi on video card to dvi on monitor) 2nd Monitor is a HP W2338 LCD Monitor (dvi on video card to hdmi port on monitor) The 2nd monitor (HP) goes off after a few minutes, but if I'm playing a video on that...
Graphic Cards
Dual monitor problem - 2nd monitor is blank
I have dual monitors set up for extended displays. The monitors are correctly positioned in the virtual display. When I move a window to the second monitor, it disappears from monitor 1 but doesn't show up in monitor 2 - that screen is black. Thanks
Graphic Cards
Monitor goes blank
My windows 7 has been a complete nightmare. Upgrade from Vista, didn't work since it got stuck and the rollback to vista was corrupted. I lost all my data, but that's not why I am here. After cursing at Microsoft I did a complete fresh install of windows 7. It seemed to work except for this...
Installation & Setup
Blank monitor on boot up with win 7, 64 bit
I installed win 7, 64 bit 2 weeks ago on one hard drive with win XP prof on another. The drives are not raided. Thus since none of my old software run on 64 bit I worked on win XP and run the internet on the win 7. Everything worked fine till yesterday . After exiting win XP and restart to win 7,...
BSOD Help and Support
one of my monitor goes blank
I installed win 7 enterprise 32bit over the weekend. so far everything is good except that when i lock my workstation i only see clt-alt-delete option on only one monitor other one goes blank (turn black) thoughts?? thanks yasir
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App