Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Having a problem with my new GTX 770 display adapter?

16 Jun 2014   #1
draptak

Windows 7 Ultimate 64-Bit
 
 
Having a problem with my new GTX 770 display adapter?

Tried to play some games on my Samsung monitor (22'' at 1650x1050max res) with my new GTX 770, but it freezes and the monitor goes blank. Eg. I tried playing watchdogs at 800x600 it works fine. But if I use a higher resolution the GTX 770 freezes.

I tested it on my 42'' TV with a HDMI cable, it works on a high resolution

I'm thinking this is something to do with my monitors display adapter?
I've went to the screen resolution settings>display ... There's only one option, my sync master monitor. Should there be an option to select NVIDIA as my display adapter?


Specs:
CPU: Intel® Core™2 Quad Processor Q9400 at 2.66 GHz
GPU: GTX 770 2GB DirectCU II
Memory RAM: 6GB
OS: Windows 7 64-bit
PSU: Corsair CX750M


My System SpecsSystem Spec
.
17 Jun 2014   #2
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

You`re confusing your monitor with your display adapter, what does it show in Device Manager under Display adapter ?
My System SpecsSystem Spec
17 Jun 2014   #3
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Yeah if this what you're looking at it will always show your monitor. Your GPU will show up where AddRAM said.

-capture.jpg


My System SpecsSystem Spec
.

17 Jun 2014   #4
draptak

Windows 7 Ultimate 64-Bit
 
 

Oh I see thanks guys, I understand now.

The problem im having is that when I try to play Watchdogs, on 800x600 res it works fine. But when I try to use 1680x1050 res the GTX 770 freezes and the monitor goes blank which leaves me no option but to turn off the PSU. Happens all the time.

Solution?

Thanks
My System SpecsSystem Spec
17 Jun 2014   #5
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

What is the native resolution of your mointor?
My System SpecsSystem Spec
17 Jun 2014   #6
draptak

Windows 7 Ultimate 64-Bit
 
 

Quote   Quote: Originally Posted by Boozad View Post
What is the native resolution of your mointor?
Its a Samsung syncmaster 22" at 1680x1050 max resolution
Thanks
My System SpecsSystem Spec
20 Jun 2014   #7
taylorig

Windows 7 Pro x64
 
 

What is the actual connection you are using to connect to your monitor draptak? i.e. Display port, HDMI or DVI

The reason i ask this is because the only time i have had any issue at all was when i connected via HDMI. Didn't have the problem of not being able to run at my screens max resolution of 1920x1080 but was more a case of the screen would go black for no apparent reason. With DVI i have never had this happen.

I have the same GPU as yourself and also have Watch Dogs and can run it flawlessly. May be you have a bad cable or the monitor in question as acquired a fault.
My System SpecsSystem Spec
20 Jun 2014   #8
draptak

Windows 7 Ultimate 64-Bit
 
 

Quote   Quote: Originally Posted by taylorig View Post
What is the actual connection you are using to connect to your monitor draptak? i.e. Display port, HDMI or DVI

The reason i ask this is because the only time i have had any issue at all was when i connected via HDMI. Didn't have the problem of not being able to run at my screens max resolution of 1920x1080 but was more a case of the screen would go black for no apparent reason. With DVI i have never had this happen.

Thanks taylorig, I have the same GPU as yourself and also have Watch Dogs and can run it flawlessly. May be you have a bad cable or the monitor in question as acquired a fault.
I've had this thought for some reason, could be the cable or my monitor. I am currently using the DVI connection to the GPU and the VGA to the monitor (without an adapter). I also tried using the HDMI to HDMI on my Samsung 42'' TV which is capable of running up to 1920x1080, I think it works fine there.

Not sure if the issue is my cable or the monitor
My System SpecsSystem Spec
24 Jun 2014   #9
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

I wonder if the DVI to VGA adaptor you are using is the culprit, I'd swap that out.
My System SpecsSystem Spec
Reply

 Having a problem with my new GTX 770 display adapter?




Thread Tools






Similar help and support threads
Thread Forum
Display Adapter Problem.
My display adapter had a problem...cant Exceed full resolution..already uninstall the driver but cant fix.
Graphic Cards
Problem installing USB Display Adapter driver software
When downloading a USB Display Adapter driver software for the first time, DisplayLink USB Graphics Software for Windows* V7.6 M0 I am recieving 1 repeating (11) Error message - Could not write value MirrorDriver to key \SYSTEM\CurrentControlSet\Services\DisplayLinkGA\Device 1. Verify that you...
Installation & Setup
display adapter is stuck on standard vga adapter
I know there are several threads but they are with different cards and they didn't solve my issue... I bought a new MEDION AKOYA P5334E and the system arrived installed normally with win7 home edition. I've installed on the computer the win7 enterprise edition (x64) and many drivers could...
Drivers
Display HDMI Adapter
Hello, I currently found out that my TV supports 1080p. However, it only works when HDMI is plugged in. And my card only has DVI output. And i was wondering, will the 1080p work with a DVI to HDMI adapter then? Thanks, Alex.
Hardware & Devices
Display adapter disappeared
Hey, I have been looking around and cant find a solution to this problem. Just this morning I turned my laptop on and realised the resolution was at its lowest and when I went into the device manager of my computer the display adapter had gone realising the computer had no graphics driver. I...
Graphic Cards
Nvidia GTS 250 display adapter problem..
Having problem with graphic card and WoW, getting a error when launching the game. ' Failed to find a suitable display device. Exiting program. ' I have reinstalled 195.62 more than 10 times and used driver sweeper also and tried 1.1 also still im unable to launch .
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:54.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App