Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: DVI ports question

24 Jul 2014   #1
mavu

Windows 7 Professional x64
 
 
DVI ports question

Hi,

I have XFX HD 7850 GPU which has two DVI ports. One is DVI-I (marked as Primary) and the other one is DVI-D (marked as Secondary). They both are dual link. I thought it was logical to use DVI-D since I use DVI cable (single link) directly from my monitor. I had freezing, BSODs and problem when waking monitor from sleep every 2-3 days. Now I changed to DVI-I port with the same DVI cable and had no problems in a week. My resolution is 1920x1080. I will wait few more days and then return to DVI-D port to see if problems will occur again. So if I determine that I have problems when I reutrn to DVI-D port, does it mean that there is something wrong with GPU and this port or it is normal that I have to use DVI-I port since it's marked as Primary even if I don't use VGA converter?

Thanks


My System SpecsSystem Spec
.
25 Jul 2014   #2
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

I would email the manufacturer and see what they have to say.

http://xfxforce.com/de/home

What is the difference between DVI-I and DVI-D?
My System SpecsSystem Spec
27 Jul 2014   #3
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

If the problems return when you use the DVI-D port, is there any reason that you can't use the DVI-I port all of the time? Since that is the primary port. The card may be having issues when you plug into the secondary connector without a monitor in the primary port. I assume by your post that you aren't running two monitors. You might just have a fussy card.

I would email the manufacturer as AddRAM suggested. I would also run the monitor off of the primary port if there is no good reason not to.
My System SpecsSystem Spec
.

28 Jul 2014   #4
mavu

Windows 7 Professional x64
 
 

I don't use second monitor and I don't plan to so I could use DVI-I all the time. But I'm afraid that if DVI-D is somehow broken, then some other parts of the GPU could broke in time. I will wait for few more days on DVI-I just to be sure that it's working and then I'll switch back to DVI-D and see what happens. And I will contact XFX too see what they have to say about it. Thanks for answers.
My System SpecsSystem Spec
Reply

 DVI ports question




Thread Tools




Similar help and support threads
Thread Forum
COM Ports Question
Hello, Is it O.K. to have a few programs set up with their COM Ports all the same number, as long as only one program is ever actually being used at a time ? Thanks, Bob
Hardware & Devices
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
USB 3.0 ports refuse to work as USB 3.0 ports
A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC µPD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first...
Hardware & Devices
Why do USB hub's have only 4 ports
I have five USB 2.0 hub successfully operating over 20 devices. As these fail I will upgrade to 3.0. Anticipating more 3.0 devices and a 3.0 motherboard in the future. Why do they only have four ports? If I am mixing 2.0 hub with 3.0 hub's should I plug in. In a certain order
Hardware & Devices
Add More Ports.....
FYI only................... Add More USB Ports to Your PC - PCWorld
Chillout Room
usb ports
hey guys i have had some problams with my usb prots just these past few days it seem when ther under strain thay just cut off and then back on also disconnecting my wireless internet and my ex hdd but i can't find out why the hell this is happening now ther are no errors and no sign of shorting...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:40.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App