Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: unable to get picture on screen after putting in video card

07 Aug 2014   #1

windows 7 home premium 32bit
 
 
unable to get picture on screen after putting in video card

I have a older pc the onboard is really weak. it was meant for win xp but I have Windows 7. I just got a NVidia GeForce FX 5500 250mb 128bit PCI TV+DVI. it came with the driver disk cause I got it new in box, when I put it in and start the pc I get nothing on the screen from onboard or the card. I tried disabling the onboard that didn't work, so then I tried taking the card out and starting pc an installing the drivers first but it said it couldn't find a device for the drivers, meaning I have to have the card in before I can install the drivers. how can I get video to come up weather it be onboard or video card long enough to install the drivers?



My System SpecsSystem Spec
.

08 Aug 2014   #2

windows 7 home 64bit
 
 

Hi there .. Make sure your PCI slot is clean and try reseating the Card ... If it still does not work you would need to test it on another Computer ...
My System SpecsSystem Spec
08 Aug 2014   #3

windows 7 home premium 32bit
 
 

Quote   Quote: Originally Posted by maxie View Post
Hi there .. Make sure your PCI slot is clean and try reseating the Card ... If it still does not work you would need to test it on another Computer ...

thanks. the slot is clean and I had a network card I tried to make sure all the slots are working. the other pc I have has pci express slots so I cant test on it.
My System SpecsSystem Spec
.


08 Aug 2014   #4

Win 7 Pro x64/Win 8 Pro x64 dual boot
 
 

I can't tell from any of the searches I did, but is there a power connector on that card? There shouldn't be, but I thought I'd ask.

You may also have to turn off the onboard video in BIOS to get the new card to show video, or set the new video card to be the first device in BIOS.

Also, what port is your monitor plugged in to?
My System SpecsSystem Spec
08 Aug 2014   #5

Windows 7 Pro-x64
 
 

Ditto on the location (slot). Many of those older motherboards required the video card to be in a specific slot. You might try digging up a manual and check.
My System SpecsSystem Spec
08 Aug 2014   #6

windows 7 home premium 32bit
 
 

Quote   Quote: Originally Posted by Mellon Head View Post
I can't tell from any of the searches I did, but is there a power connector on that card? There shouldn't be, but I thought I'd ask.

You may also have to turn off the onboard video in BIOS to get the new card to show video, or set the new video card to be the first device in BIOS.

Also, what port is your monitor plugged in to?

only power connector I see on the card is the oncard fan plug. I tried all 4 card ports. the bios on this pc is crazy different from the ones im use to, most of the stuff is not a simple enable/disable, its dealing with IRQ's an I don't know anything about that an don't want to mess it up. the pc I had before I simply when in an turned off the onboard, an that halfway worked on that one cause it would display from the onboard till it got to windows then switch to the video card display. but this one there is a couple things in there about video but its dealing with IRQ stuff.
My System SpecsSystem Spec
08 Aug 2014   #7

windows 7 home premium 32bit
 
 

Quote   Quote: Originally Posted by carwiz View Post
Ditto on the location (slot). Many of those older motherboards required the video card to be in a specific slot. You might try digging up a manual and check.

I tried all 4 pci ports an its the same for all of them. ill try to look for a manual online but its gonna be a chore figuring out the proper motherboard name cause the name the bios name the system information gives (which I cant lookup cause im got different pc hooked up right now) I only can find little bits of info about it an not the book.
My System SpecsSystem Spec
08 Aug 2014   #8

windows 7 home premium 32bit
 
 

by the way thank you all for the help
My System SpecsSystem Spec
08 Aug 2014   #9

Windows 7 Pro-x64
 
 

Does the BIOS list the IRQs for the hardware in use? Check to see if IRQ 16 is in use. If not, use that for video. That's what Windows most often assigns. There may also be an "Auto" option too. Can you post a pic of the BIOS?
My System SpecsSystem Spec
09 Aug 2014   #10

windows 7 home premium 32bit
 
 

Quote   Quote: Originally Posted by carwiz View Post
Does the BIOS list the IRQs for the hardware in use? Check to see if IRQ 16 is in use. If not, use that for video. That's what Windows most often assigns. There may also be an "Auto" option too. Can you post a pic of the BIOS?

here is the bios advanced list, and the video card (NVidia GeForce FX 5500 250mb 128bit)

all the bios settings are on default in the pics. im scared to mess with them.


Attached Thumbnails
unable to get picture on screen after putting in video card-2014-08-09-17.40.26.jpg   unable to get picture on screen after putting in video card-2014-08-09-17.40.41.jpg   unable to get picture on screen after putting in video card-2014-08-09-17.40.54.jpg   unable to get picture on screen after putting in video card-2014-08-09-17.41.53.jpg   unable to get picture on screen after putting in video card-2014-08-09-17.42.59.jpg  

unable to get picture on screen after putting in video card-2014-08-09-17.42.48.jpg   unable to get picture on screen after putting in video card-2014-08-09-17.47.40.jpg   unable to get picture on screen after putting in video card-2014-08-09-17.47.50.jpg   unable to get picture on screen after putting in video card-2014-08-09-17.47.15.jpg  
My System SpecsSystem Spec
Reply

 unable to get picture on screen after putting in video card




Thread Tools



Similar help and support threads for2: unable to get picture on screen after putting in video card
Thread Forum
Solved putting assigned picture numbers in order General Discussion
Graphics Card Picture Quality and Video Quality Graphic Cards
Unable to install new video card driver on W7 64 bit Drivers
Solved Unable to update my ATI Video Card Driver Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:20 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33