Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Need help w Radeon HD5470 after clean windows7 install

08 Nov 2014   #1
Walldiver7

Windows 7 Home Premium x64
 
 
Need help w Radeon HD5470 after clean windows7 install

I did a re-install of Windows 7 on my HP Dv6t-3000 based on a friend's recommendation to alleviate my problems with SafeSear.ch. This course of action was decided after my recovery disks would not load (hp factory-made disks in perfect condition).

My laptop is now functional again with a few problems. The first problem I want to fucus on is the mute, orange, light. It now stays lit all the time, but does turn the sound on and off. (Curiously, volume adjustment levels are no longer screen visible; I have to hover over the speaker icon to determine volume level now.) Before I ran the new windows 7... I did one thing good; I ran Belarc Advisor and saved the file. I ran it again after the new W7 install and found that my ATI Mobility Radeon HD5470 graphics card (device?) is not present now. When I go over to HP's site, I can find no driver for this card (I'm making the assumption that this has something to do with the mute light issue.). I've run other web searches looking for this driver and haven't found it.

My question is, can I go into my recovery disks and find this driver?
Please keep your responses simple; I'm not a knowledgeable person in this area. I also need to divulge that I had to tear down this laptop to the frame to repair/re-build the screen hinge. That was prior to new W7 install and every functioned after it was reconstructed.


My System SpecsSystem Spec
.
08 Nov 2014   #2
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

That laptop has both an Intel HD series video card and the Radeon, needs switched over to the Radeon to see it and install a driver.

Called switchable video (not automatic), but couldn't find details on how it's actually done.
My System SpecsSystem Spec
08 Nov 2014   #3
Walldiver7

Windows 7 Home Premium x64
 
 

You are correct; Switchable graphics. Previously, when I put it on charge, a dialog box would come up and ask if I wanted to switch over. That prompt is gone now.
My System SpecsSystem Spec
.

08 Nov 2014   #4
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

I would look for a utility on HP's web site to install for the feature, betting that is it, non-standard 3rd party app not part of Windows, so needs reinstalled, probably tiny and autoloaded at startup, once installed.

If the laptop came with any install CDs/DVDs, that app might be on one of them.
My System SpecsSystem Spec
08 Nov 2014   #5
Walldiver7

Windows 7 Home Premium x64
 
 

While I was taking your suggestion, I also looked at the drivers for audio again. I found AMD driver that was describing switching between cards. I had skipped over this driver before because it was not labeled "ATI" or anything else familiar. I downloaded it... restarted,... nothing, then went into some type of install wizard for IDE and let it run.... then the orange mute light went OUT! ShaaaaaaaWing!

I took a look at the Device manager and it also showed that the ATI card was back. The mute light and button now perform as expected.... although, I'm not sure if the card is functioning because the audio from music doesn't sound as good as it did before. That may be just me,... at this point. The volume on-screen bar is still not working, so maybe all is not well. I'll be back on here tomorrow; have to hit the sack.
My System SpecsSystem Spec
Reply

 Need help w Radeon HD5470 after clean windows7 install




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Failed install windows7 home to windows7 enterprise
I have an HP Compaq dx2000mt desktop that has windows7 32bit enterprise installed on it. I tried to install windows7 home 32bit to replace the enterprise OS. As I was installing it stated the old OS would be marked, XXX.old and it went forward, then came to a point where there were booting errors....
Installation & Setup
OK to do clean re-install windows7 drive C:? Affect other partitions?
Just a basic user here so thought I would ask somewhere on the internet before attempting. Have windows7 installed on drive C:, and have win7 and winxp installed on two other partitions (E: & F: ) on the same hard drive. Last year I used EasyBCD so that 7 and XP could dual boot as options. ...
Installation & Setup
can't clean install windows7, bootmgr is missing problem
Hey guys, I have been trying to troubleshoot my PC for a month now with no success when a standoff on my motherboard came loss and my motherboard shorted-out. I already warrentied my motherboard; no difference. Then I went and bought new RAM; also no difference. How do I get passed this stupid...
Installation & Setup
Installed new SSD clean install of windows7 and now experiencing slow
Last night i installed a new Solid state drive and was pleased, until i shut down the shut down time was horrible. Is this due to something happening with my secondary HDD drive? I did some tweaks to the SSD such as superfetch, paging files, drive indexing, disabled pagefile and prefetch and write...
Performance & Maintenance
Multiple memory errors after clean install of windows7 help!!
Ok guyshere is my problem. I am building a budgetpc. I bought new in box an AMD X3 450 and a asus m4a78lt-mle mobo, and 4gb of DDR3 1333mhz memory Kingston. First off out of the box the processorposts as a amd x4 b50. Not sure if they packaged the wrong one or the mobo is reading wrong. I dont...
Hardware & Devices
Clean Windows7 x64 Install not running ANY 32-bit apps
Hey all, I just did a fresh install of Windows 7 x64, the most current 16385 Build. Set-up was perfectly smooth, detected a lot of my drivers, etc. I go to install Firefox, so I download it, and try to install but nothing happens. I tried to download it again, save the .exe, click on it, and...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:04.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App