Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Install AGP Drivers for HD 3850, 3650, 2400 PRO

03 Jun 2010   #261

windows 7 64b

sir i have an ati ah4650 and i'm using Win 64 , i try your solution but it din't work.

I really appreciated any other suggestion .

CPU:Athlon64 3400+ Processor (2.2 GHz)
Chipset:NVIDIA nForce3 150 SPP (single chipset)
RAM: (2) 1GB Corsair.
OS: Win 7 ultimate 64bit
Graphics Card: Asus Radeon AH4650 1GB AGP
Motherboard: ASUS (K8N8X-LA PES)- Diablo

My System SpecsSystem Spec
19 Jun 2010   #262

windows 7 utimate x64

Quote   Quote: Originally Posted by torrentg View Post
Instructions for installing ATI HD 2400 PRO AGP, ATI HD 3850 AGP, ATI HD 3650 AGP, ATI HD 3450 AGP, ATI HD 4650 AGP, ATI HD 2600 PRO AGP

ALL MODELS x86 32-bit WDDM 1.1:

1) Download the Catalyst 9.11 32-bit driver Suite for Windows 7 from here - Drivers & Support | GAME.AMD.COM - Click on
ATI Radeon™ Video Card Drivers

2) Extract the driver folder by running the .exe you downloaded. It will extract to C:\ATI

3) Close installer after extraction. No longer necessary. Do not continue with install here.

4) Download my attachment (CL_91526.rar) and extract the .inf file from it. Save to desktop or anywhere you want.

5) Copy and paste the CL_91526.inf you just extracted directly overwriting the original at this location - C:\ATI\Support\9-11_vista32_win7_32_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W7_INF

6) Go to device manager and right click on your video card. (Standard VGA or otherwise.) Update driver software, browse my computer, let me pick, have disk, browse.

7) Navigate to C:\ATI\Support\9-11_vista32_win7_32_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W7_INF

8) Click (or double click) on the CL_91526.inf

9) Click ok, then click next and let it install. If it complains that it is not signed, click the part to let it install anyway.

10) Reboot if necessary. Pick an Aero theme by right clicking on desktop, Personalize. (If you previously had a working driver from ATI's site installed, you may skip this step.)

11) Run setup.exe in C:\ATI\Support\9-11_vista32_win7_32_dd_ccc_wdm_enu\Driver\
and let it complete to install the CCC, should you want the functionality. Custom mode is best used here instead of express mode, when it asks.

12) Install ATI Tray Tools (attsetup.rar in my attachments) if you wish to overclock. Ensure adequate cooling. Disclaimer - Should you choose to overclock, responsibility falls entirely on you.

13) Update your WEI score. Start menu | right click Computer | Properties | click Windows Experience Index

If you have a different AGP card, let me know. I will make you a custom .inf.
like most ppl i too am having problems installing my hd 3850 into a win 7 system
what i found is that ati are using the rv630 for th other cards to power the 3850 when th site says its using th rv670 pro...not sure if it makes any difference really, but doesnt seem right to me... have tried moding th latest driver .inf file(hotfix 10.5) like above to no avail ... am getting a system dump on start-up of windows...had this card working in this system before, then it just stopped working. Worked fine in my old system till th mb died on me so had to upgrade a little... need help please
My System SpecsSystem Spec
19 Jun 2010   #263

windows 7 utimate x64

MB: Foxconn P4M800P8MA-RS2 AwardBIOS v6.00PG 58BF1P26
CPU: 3.40GHz HT P4 LGA775
RAM: 2x 1gb 666mhz PC2 6400 running at 533mhz(underclocked)
GPU: Sapphire Radeon HD 3850 512MB AGP

HARDWARE ID: Sapphire Radeon HD 3850 AGP
The card installed fine but then stopped working about 2wks ago
Hav unistalled and reinstalled several times but still the same result
Have attached th dump file... i know its th ati driver causing it to blue screen on start up
My System SpecsSystem Spec

29 Jun 2010   #264

Windows 7 Home 32bit (x86)
Radeon 9800 AIW pro 128 agp

Windows 7 32bit - radeon 9800 AIW pro 128mb AGP


Has anyone made a custom .inf file for this yet? My system specs are listed below and I've updated my intel .inf driver with windows xp compatibility mode drivers. They're the only ones I can find. Everything works with windows XP drivers in compatibility mode for the 9800pro with the exception of the aero effects. Direct-X has also been updated. I beleive my problems may be related to my CPU AGP driver - any suggestions?

Attached Images
Install AGP Drivers for HD 3850, 3650, 2400 PRO-sucesserror1.jpg 
My System SpecsSystem Spec
10 Jul 2010   #265

windows 7

hi i have tried all that was suggested but still no joy.could you suggest anything further?i have included my information in case you can help.many thanks.

My System SpecsSystem Spec
18 Jul 2010   #266

windows 7 ultimate
Sapphire x1600 pro agp 512mb

getting device manager to update driver for this card... the WDDM ati driver has been rolled back to a 2008 version...xt1300/x1600pro/x1650 which do not work for me at all...ati's 10.2 legacy driver gave me a error on startup,,,unable to start windows...startup repair could not fix...running ati 9.11 legacy drivers now...but all drivers ExCEPT VGASAVE cause my display to bsod...are these drivers all broken now for windows 7?(seeing as they downgrade their own driver...) oh...and when it WAS windows experience base score was 4.0 with the graphics scoring 4.5 hard drive 4.7 ...bottleneck is the cpu which gave me the 4.0
My System SpecsSystem Spec
20 Jul 2010   #267

windows 7 ultimate

just saying ...i went nvidia 9400GT PCI ...yup...PCI ...1 gig ...WDDM 1.1 drivers...matches or exceeds my windows experience scores with the ATI card...and no BSODs ...all for $50 canadian... 'nuff said
My System SpecsSystem Spec
21 Jul 2010   #268

Windows 7 Ultimate

Howdy there folks,

I've been reading and re-reading and trying and re-trying various methods across this and other forums, and have found the greatest success (so far) by following torrentG's instructions. Win 7 Ultimate finally recognizes my Gigabyte Radeon HD 4650 on my k8m800 micro am2 MB for what it is! This is much further than I have ever gotten! I can even run the system rating and get a 5.something for the graphics aspect! (F'ing processor is keeping it at 3.5 overall though, but good enough for me, as this will be a secondary/guest system.) Hooray!

Unfortunately, I am getting weird, seemingly random crashes all caused by 'atikmdag.sys'. It's weird; I can run a stress test for hours, I can watch movies in full screen, I can left it on all last night with no problems, but then this morning while browsing in FF it will crash. First, it kinda pixelates and looks jankey, then the monitor flashes and I get 'NO SIGNAL' for a sec, and then a BSOD with 'blah blah blah... 'atikmdag.sys'. I tried to disable the HDMI audio in device manager (I think?) to no avail.

I followed the torrentg's instructions to the letter, even using CC display drivers 9.11. (I've avoided the newer ones because I started with those and they lead to only finding a 'Radeon 4600 series' and constant BSODs, but they were still related to the 'atikmdag.sys'.)

Also, I'm at work now, so I can't post my dump at present. (Heh.) I was wondering if I could use a similar .inf trick for some of the newer CC drivers? Specifically, the ones that supposedly include the AGP hotfix? (10.x; the site now says 10.6 is the newest but it doesn't seem to mesh well with my old MB.) My only concern is I have also read in many places that the Gigabyte card is uber picky when it comes to drivers. Any advice, or should I go ahead and start a new thread? (The only reason I didn't is because so far it appears this has gotten me closer to success than anything else I've tried to far.)


EDIT: Donno if it helps but here's:


Problem signature
Problem Event Name: BlueScreen
OS Version: 6.1.7600.
Locale ID: 1033

Extra information about the problem
BCCode: 116
BCP1: 84EEA178
BCP3: 00000000
BCP4: 00000002
OS Version: 6_1_7600
Service Pack: 0_0
Product: 256_1
Bucket ID: 0x116_TdrBCR:2_Tdr:2_IMAGE_atikmdag.sys
Server information: 7a89dfd0-d4bd-4bdf-9b10-9cac6db21362
My System SpecsSystem Spec
22 Jul 2010   #269

Windows 7 build 7068

hey, I use the official AGP drivers from the ATI page on a Sapphire Radeon HD 4650 1GB AGP and it works fine.
My System SpecsSystem Spec
22 Jul 2010   #270

Windows 7 Ultimate

Yes, I think I posted too soon. Anyhoo, so I got home last night a wee bit tipsy and started messing about because the computer kept crashing when I was trying to do simple things like stream movies or check my damn email. So I got all upset and was just like 'well, let's try the damn hotfix 10.6 ones that I tried again, but this time load via the .inf file'.

And it took (after a little fandangling) - rebooted, and tada! So far, after at least a few hours and all night and this morning of use, not a single BSOD! Hooray, I can finally use 7 at home!

I do think it had something to do with first installing CC 9.11 w/ the custom .inf file first though. Maybe. Because this is the very first thing I originally tried when I first loaded Win7 and was having similar issues(Whoda thunk, use the most recent drivers?)

Oh, I also may have tweaked some BIOS settings. But hey I was drunk, so I can't recall which ones. I'll post back here if anything changes, otherwise:

GIGABYTE RADEON HD 4650 works fine on the H8K800 AM 2 micro MB with the latest CC 10.6 AGP Hotfix drivers, if you manually load them. Just FYI.
My System SpecsSystem Spec

 Install AGP Drivers for HD 3850, 3650, 2400 PRO

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
ATI Radeon HD 3850 Install Error
I recently got a ATI 3850 for my PC, i set everything up and i come to install the CCC & Driver i get an error message which says Failed To Load Detection Driver when i boot my PC in safe mode the monitor is clear which is normal but when i boot it normally (Win7 64 Home) i get lines going...
Graphic Cards
HP Deskjet 3650 Drivers
Does anyone know where to get the Windows 7 drivers for an HP Deskjet 3650 printer?
Sapphire 3650 AGP GDDR Drivers
Hi There, The links aren't active any more. Is it possible to post on other link with the drivers for this card. I'm running on Windows 7 Ultimate x64. I have a Sapphire 3650 AGP GDDR Having trougble with installing. System shuts down when starting windows before showing welcome screen...
Graphic Cards
HD 3850, which DirectX to install?
I'm using Windows 7 x64, and I have a Sapphire HD 3850 card. On the box it says DirectX 10. But I've read in a couple of searches Win 7 uses DirectX 11, and is backwards compatible with DX10. I don't see DirectX 10 or 11 on Microsoft's DirectX website, only downloads for 9.0c installer. A few...
Graphic Cards
Need help with drivers for an ATI Radeon HD 3650
When i look into my devices and go under display devices, all i can ever see is Standard VGA graphics adapter. I have downloaded and installed the newest windows 7 32-bit drivers for the card, but whenever i go and check the devices again, it still hasn't changed from the Standard VGA device....
ATI Radeon HD 3650 AGP install problem
Hey, I got major problem (i think). I've been trying to get my drivers working for like 2 days now (bout 20-30 hours). So i just installed windows 7 and i can't get my graphic card working. Problem is that, if i install just driver from amd home page then i dont even get message by windows that it...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:50.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App