Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphic Glitches (Artifacts?) on GTX 970

03 Dec 2014   #11
RoasterMen

Windows 10 Pro 64-bit
 
 

Now that's driver Issue. I hope NVIDIA gives a fix soon.


My System SpecsSystem Spec
.
03 Dec 2014   #12
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

I hope so too, on stock I get these glitches just like the first screenshot and downclocking it doesn't seem to fix the issue though. Note on stock and downclocked, these glitches appear rarely from time to time. Thankfully for heaven, valley, and 3D Mark (Steam Demo version) didn't have this. Dota, WoW and ACIV Black Flag didn't have that either (except for that missing texture model that flashes when I turn my boat to the right).

Also I found these through my shadowplay replays which of these glitches are in the game. Plus, I don't think it's Shadowplay's fault. In fact, I get these without using shadowplay and uninstalled gforce experience. Quite frankly, it kinda appears in version 344.65 and this version I have didn't seem to have an effect since that driver released on the week after 344.65 was released for game optimization on new games. I have to tell Nvidia about this.
My System SpecsSystem Spec
03 Dec 2014   #13
RoasterMen

Windows 10 Pro 64-bit
 
 

Yeah man they need to fix it asap. Please mark the thread as solved
My System SpecsSystem Spec
.

03 Dec 2014   #14
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

Quote   Quote: Originally Posted by RoasterMen View Post
Yeah man they need to fix it asap. Please mark the thread as solved
Oh sure! I'll mark this as solved for now. If anything else happens, I'll come back to this thread. Thanks for your help, though.
My System SpecsSystem Spec
06 Dec 2014   #15
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

And btw, here's the video of these glitches:

https://www.youtube.com/watch?v=NXZ5k3ErwKw

Btw, you have to set the video quality up to 1080P 60 FPS in order to see those glitches
My System SpecsSystem Spec
07 Dec 2014   #16
SBones

win 7 64 bit
 
 

IM having the same artifacts,evga gtx 970 superclocked
in video playback(i rarely if ever saw in games yet but ive only just bought it.green artifacts appearing in movies.not too frequent but a number of times per movie,an they disappear in a second or two.also weird was in the movie silent hill the tv in backround of the scene where the father is on the phone at home showed a weird ghosted artifact effect on his tv screen

this has to be that they overclocked it too much an we dont have the best cards onn the bunch.u had gtx 770 overclock from pny right before this an they have the same driver so its not drivers.

but anyways this artifacting happens when things are too hot or too overcloked.
although ive seen it more shown as white ones in other peoples examples
i ran into the green awith power dvd 13 ultra.which is the best media player picture wise,an ive tired alotta players.it also happens in vlc player but less so

im at 24c on idle so i doubt its getting to hot during movies,as games would run much hotter

this really annoys me,if i see it more in games ima think to ask for replacement,i hope you registered your card.i may try to keep an leave underclocked until running games.i paid like $40 more for a supercloked version an if it cant perform at that level(or is struggling) then it would have a shorter lifespan as well(tho maybe only slightly,an only possibly)

hope this helps.
My System SpecsSystem Spec
07 Dec 2014   #17
SBones

win 7 64 bit
 
 

im hoping that evga precision x will underclock it as it appears to do so?ill do some more testing an write back what i find,what underclocks work an if its happening in games,etc

ill try out teamfortress2 as well as others

do the same ok?

also my cpu temps are real low,like 3c idle with a after market fan so thats no problem there
My System SpecsSystem Spec
07 Dec 2014   #18
SBones

win 7 64 bit
 
 

oh an lastly i know that our evga gtx's are the highest or 2nd highst clocked of any brand for the 970,so theyre pushin it.still it should be able to work at the norm speeds,this sucks
My System SpecsSystem Spec
07 Dec 2014   #19
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

Quote   Quote: Originally Posted by SBones View Post
IM having the same artifacts,evga gtx 970 superclocked
in video playback(i rarely if ever saw in games yet but ive only just bought it.green artifacts appearing in movies.not too frequent but a number of times per movie,an they disappear in a second or two.also weird was in the movie silent hill the tv in backround of the scene where the father is on the phone at home showed a weird ghosted artifact effect on his tv screen

this has to be that they overclocked it too much an we dont have the best cards onn the bunch.u had gtx 770 overclock from pny right before this an they have the same driver so its not drivers.

but anyways this artifacting happens when things are too hot or too overcloked.
although ive seen it more shown as white ones in other peoples examples
i ran into the green awith power dvd 13 ultra.which is the best media player picture wise,an ive tired alotta players.it also happens in vlc player but less so

im at 24c on idle so i doubt its getting to hot during movies,as games would run much hotter

this really annoys me,if i see it more in games ima think to ask for replacement,i hope you registered your card.i may try to keep an leave underclocked until running games.i paid like $40 more for a supercloked version an if it cant perform at that level(or is struggling) then it would have a shorter lifespan as well(tho maybe only slightly,an only possibly)

hope this helps.
Have you tried evga oc scanner? Use it on furry e on both memory and core and select artifact scanner. Run it for about 30 mins to an hour, if you don't see artifacts then you good to go. If not, you have to start rma from the looks of it.

I ran that and I don't see any artifacts, which is good but man, this is strange. I upload the video of these glitches on YouTube.

Here's the link: Glitches or Artifacts on GTX 970 - YouTube

Make sure you select 720p 60fps
My System SpecsSystem Spec
21 Dec 2014   #20
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

Bump! Well, things are not very good after I update the drivers into 347.09 beta drivers and it seems the glitches (artifacts) in Team Fortress 2 are still there. I underclocked to -105 in both Memory and Core and the artifacts are more noticeable. So, I tried testing on 2Fort map on an empty offline server, miminalized the game and ran gpu z. All of the sudden, it black screens for a sec and I got a TDR error saying nvidia driver kernel crashed and recovered sucessfully bla bla bla. Thus making Team Fortress 2 frozed (which I have to use task manager to exit it out) Then, I tried Heaven with GPU-Z too and it black screens but no TDR, so I closed it.

Somehow I think I came to the conclusion that my card is unstable due to the factory overclock because of that one game. Funny thing is that I didn't get any artifacts in all the tests I've done and benchmarks too. These freezes made me indicate that its a possible sign of unstable gpu and it kinda needs an rma. You know, I also read one of the threads where some users have a similiar problem with black screens in one game and stuff and it seems that RMA fixed the issue with them.

Right now, I'm using my old Zotac GTX 560 2GB and so far, no artifacts in Team Fortress 2. So with that matter, its the card. :/

Its really sad because I really love the performance that EVGA has to offer. Its ACX 2.0 cooling solution and
maxwell architecture is really well designed, especially the performance in Far Cry 4 on high settings. Sigh...guess I gotta wait until I got the gtx 970 card back in working order. I doubt that the gtx 560 could barely run on that game, making it a bottleneck.

And btw, in 344.75, I realized the game frozed for about 7 seconds on World of Warcraft and Heaven while using geforce experience then it goes back to normal when I used my gtx 970 on my rig.

It was my first time RMA'ing a product so I'm a bit nervous about shipping it to EVGA RMA department, despite the fact that the customer service was amazing. I hope it goes well for the most part.

Since the RMA was approved during the holidays so that'll take me like an extra 2 weeks before they even start doing the rma process. So, should I wait after January 5th or send it now? I got like 45 days to send it to EVGA.

So far, I would like to thank RoosterMan for helping me out on the situation. Sorry that things didn't work out on my gtx 970 card.
My System SpecsSystem Spec
Reply

 Graphic Glitches (Artifacts?) on GTX 970




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Bad GPU? Freezing, black screen, and graphic artifacts.
Hello. Recently my hp pavilion dm4 with switchable radeon 5000 series gpu has started acting funny. It started months ago with poor performance in streaming videos online when the radeon was activated (dubbed "hi performance" in the OS.) This problem seemed to get better after reinstalling...
Graphic Cards
Strange sporadic graphic issues, graphic lock ups (with Pictures)
Hello all, I think I have only seen something like this once :huh: and the problem was attributed to damaged RAM. This time around, the RAM seems to be in perfect working condition (tested with Memtest) and the problem still remains. I am starting to wonder if the graphic chip is not having...
Graphic Cards
graphic driver can't detect graphic card
Hi, i'm running window 7 32-bit OS. My graphic card is (ATI Radeon HD 3200 Graphics) My problem is that after i went to www.amd.com, downloaded,uninstall the old catalyst and installed a new catalyst which matches my OS and yet i got this message whenever i tried to run that catalyst. "No AMD...
Drivers
GTA4 artifacts.
Only game to cause it. The temp on my card is only going to 60c area. That isn't much considering its a 4850. Is there a fix? It almost never happened on xp. Frame tearing was the worst, now this. Any idea?
Gaming
Graphic glitches/stutter leading to BSOD BCcode: 124.
Hi! I got a Vista ultimate 64, Asus M4A78-E, AMD Phenom II 3.0, Powercolor 4870X2, 4 gig 800mhz ram, Corsair TX 650, and latly when i play games i get graphic glitches and studder and reduced flow in the game and then crash. This happens in many games but in different ways, Starcraft 2 Beta gives...
BSOD Help and Support
My WEI graphic and gaming graphic score just dropped?
Recently did a reinstall of Windows 7, and ran the assessment. Before the reinstall my graphic score was 7.6, now it dropped to 6.0. Same driver, no new hardware. What can this be? The graphics card is ATI 4890 1GB, running latest catalyst 9.12
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App