Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphic Glitches (Artifacts?) on GTX 970

21 Dec 2014   #21
RoasterMen

Windows 10 Pro 64-bit
 
 

If I can remember, ACX Cooler had problems in a card (I forgot it's name lol). Looks like it's EVGA's fault.


My System SpecsSystem Spec
.
21 Dec 2014   #22
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

Quote   Quote: Originally Posted by RoasterMen View Post
If I can remember, ACX Cooler had problems in a card (I forgot it's name lol). Looks like it's EVGA's fault.
Yeah. Actually it was ACX 1.0 fan that made the fault, according to Evga on Reddit. The ACX 2.0 cooler, was a good improvement with less fan noise. Thank goodness I didn't buy the acx 1.0 version of it. I heard the ACX 1.0 has some problems on the gtx 700 series, if I remember correctly.

TeamEVGA comments on The ACX cooler used on the EVGA GTX 970 appears to have a manufacturing defect.
My System SpecsSystem Spec
18 Jan 2015   #23
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

Anyway, I got the replacement card and the first thing I gotta do was clean the drivers using DDU in safe mode and finally turned it off. Next, I installed the gtx 970 in, ran Heaven for 10 loops and didn't find any crashes, black screens, blue screens, nor artifacts. Around a day later, I tested Team Fortress 2, loaded up on 2 fort server and I saw some artifacts. Yep, those artifacts that I seen on the last card. *facepalm*

Weird thing is when using the gtx 560, I saw similar issues but not as noticeable.

I'm absolutely stumped....like literary stumped. I just want TF2 to work flawlessly.
What am I going to do? ><
My System SpecsSystem Spec
.

18 Jan 2015   #24
RoasterMen

Windows 10 Pro 64-bit
 
 

Wooh..Have you tried asking for help in NVIDIA Forums? It doesn't look like a GPU problem now.
My System SpecsSystem Spec
18 Jan 2015   #25
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

Quote   Quote: Originally Posted by RoasterMen View Post
Wooh..Have you tried asking for help in NVIDIA Forums? It doesn't look like a GPU problem now.
I did, but there are like a few post. One would think it was a source engine problem and one, where I posted in the beta drivers thread, where one user think it was due to the clock being too high.

Oh yeah, I have some screenshots where I have some geometrical artifacts on my first 970 card. And of course, underclocking it didn't help unfortunately, so I RMA'd.

The replacement card I get....still the same, only with light turquoise flickering on the textures. ><
My System SpecsSystem Spec
20 Feb 2015   #26
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

Well, I might as well updating on the situation. I logged in to tf2 without using afterburner, seems like I don't see the artifacts when I loaded the 2 fort map server. During that time I had TDR errors which it said Nvidia kernel mode driver stopped responding and recovered after tf2 screen was freezes for a second then it black screens. At least I can open task manager and closed tf2. It didn't happen again afterwards. Around last week, I updated to 347.52 drivers (did clean the old drivers using DDU) and played tf2 for 3 to 4 hours without problems until one day. On that day I played tf2 for 4 hours and on the last 10 minutes, I decided to check in the 2 fort server and I get a TDR error again, but this time I don't see it on the reliability monitor where TDR errors reported as video hardware error. Although, I checked out event log where the event I'd 1001 where it shows live kernel event that occurred during a crash. That's how I know there's a TDR error.

Because of that I decided to test my hardware. So far, I completed memtest86+ for 10 passes, no errors. I also run 3D Mark and did all of the test with no problems. And I completed the Intel burn test at maximum setting with 10 passes and no problems during that test.

I honestly don't know what to do at the point. If anyone has any input or suggestions, I'll be very appreciated.

Quite a bit on the off topic, but I have this ongoing problem with my x58 motherboard having missing ram. I'll make a new thread somewhere else on this forum since I wanted to make an on topic about my gpu problem so forth.
My System SpecsSystem Spec
27 Jun 2015   #27
puhaa

Windows 8 64bit
 
 

Quote   Quote: Originally Posted by RyougaLolakie View Post
Well, I might as well updating on the situation. I logged in to tf2 without using afterburner, seems like I don't see the artifacts when I loaded the 2 fort map server. During that time I had TDR errors which it said Nvidia kernel mode driver stopped responding and recovered after tf2 screen was freezes for a second then it black screens. At least I can open task manager and closed tf2. It didn't happen again afterwards. Around last week, I updated to 347.52 drivers (did clean the old drivers using DDU) and played tf2 for 3 to 4 hours without problems until one day. On that day I played tf2 for 4 hours and on the last 10 minutes, I decided to check in the 2 fort server and I get a TDR error again, but this time I don't see it on the reliability monitor where TDR errors reported as video hardware error. Although, I checked out event log where the event I'd 1001 where it shows live kernel event that occurred during a crash. That's how I know there's a TDR error.

Because of that I decided to test my hardware. So far, I completed memtest86+ for 10 passes, no errors. I also run 3D Mark and did all of the test with no problems. And I completed the Intel burn test at maximum setting with 10 passes and no problems during that test.

I honestly don't know what to do at the point. If anyone has any input or suggestions, I'll be very appreciated.

Quite a bit on the off topic, but I have this ongoing problem with my x58 motherboard having missing ram. I'll make a new thread somewhere else on this forum since I wanted to make an on topic about my gpu problem so forth.
hi, I am having exact same problems with you, send card back for RMA, they didn't accept it, could you solve the problem ? I was trying to contact you for nearly 1 month . Please help me, thanks
My System SpecsSystem Spec
27 Jun 2015   #28
RyougaLolakie

Windows 8.1 (z97 build - main) Windows 7 Premium 64 bit (x58 build - backup)
 
 

Quote   Quote: Originally Posted by puhaa View Post
Quote   Quote: Originally Posted by RyougaLolakie View Post
Well, I might as well updating on the situation. I logged in to tf2 without using afterburner, seems like I don't see the artifacts when I loaded the 2 fort map server. During that time I had TDR errors which it said Nvidia kernel mode driver stopped responding and recovered after tf2 screen was freezes for a second then it black screens. At least I can open task manager and closed tf2. It didn't happen again afterwards. Around last week, I updated to 347.52 drivers (did clean the old drivers using DDU) and played tf2 for 3 to 4 hours without problems until one day. On that day I played tf2 for 4 hours and on the last 10 minutes, I decided to check in the 2 fort server and I get a TDR error again, but this time I don't see it on the reliability monitor where TDR errors reported as video hardware error. Although, I checked out event log where the event I'd 1001 where it shows live kernel event that occurred during a crash. That's how I know there's a TDR error.

Because of that I decided to test my hardware. So far, I completed memtest86+ for 10 passes, no errors. I also run 3D Mark and did all of the test with no problems. And I completed the Intel burn test at maximum setting with 10 passes and no problems during that test.

I honestly don't know what to do at the point. If anyone has any input or suggestions, I'll be very appreciated.

Quite a bit on the off topic, but I have this ongoing problem with my x58 motherboard having missing ram. I'll make a new thread somewhere else on this forum since I wanted to make an on topic about my gpu problem so forth.
hi, I am having exact same problems with you, send card back for RMA, they didn't accept it, could you solve the problem ?
Hey! Firstly, I would suggest you make a new thread, since I believed it was part of the rules but antway. As for the card not accept to rma, how come? Have you tried the benchmark programs to see if the artifacts appear? Who manufactured your card? Was the card overclocked from manufactured?

Right now, I'm using a PNY gtx 970 on my z97 build which is a reference model and clocks are within nvidia spec which means a nin factory overclocked card. Guess what? There are still graphic glitches/artifacts in Team Fortress 2. However, I run Far Cry 4, GTA 5, WoW, and Unigine benchmarks and they run nicely without the glitches/artifacts. I'm still stumped right now.
My System SpecsSystem Spec
27 Jun 2015   #29
puhaa

Windows 8 64bit
 
 

Quote   Quote: Originally Posted by RyougaLolakie View Post
Quote   Quote: Originally Posted by puhaa View Post
Quote   Quote: Originally Posted by RyougaLolakie View Post
Well, I might as well updating on the situation. I logged in to tf2 without using afterburner, seems like I don't see the artifacts when I loaded the 2 fort map server. During that time I had TDR errors which it said Nvidia kernel mode driver stopped responding and recovered after tf2 screen was freezes for a second then it black screens. At least I can open task manager and closed tf2. It didn't happen again afterwards. Around last week, I updated to 347.52 drivers (did clean the old drivers using DDU) and played tf2 for 3 to 4 hours without problems until one day. On that day I played tf2 for 4 hours and on the last 10 minutes, I decided to check in the 2 fort server and I get a TDR error again, but this time I don't see it on the reliability monitor where TDR errors reported as video hardware error. Although, I checked out event log where the event I'd 1001 where it shows live kernel event that occurred during a crash. That's how I know there's a TDR error.

Because of that I decided to test my hardware. So far, I completed memtest86+ for 10 passes, no errors. I also run 3D Mark and did all of the test with no problems. And I completed the Intel burn test at maximum setting with 10 passes and no problems during that test.

I honestly don't know what to do at the point. If anyone has any input or suggestions, I'll be very appreciated.

Quite a bit on the off topic, but I have this ongoing problem with my x58 motherboard having missing ram. I'll make a new thread somewhere else on this forum since I wanted to make an on topic about my gpu problem so forth.
hi, I am having exact same problems with you, send card back for RMA, they didn't accept it, could you solve the problem ?
Hey! Firstly, I would suggest you make a new thread, since I believed it was part of the rules but antway. As for the card not accept to rma, how come? Have you tried the benchmark programs to see if the artifacts appear? Who manufactured your card? Was the card overclocked from manufactured?

Right now, I'm using a PNY gtx 970 on my z97 build which is a reference model and clocks are within nvidia spec which means a nin factory overclocked card. Guess what? There are still graphic glitches/artifacts in Team Fortress 2. However, I run Far Cry 4, GTA 5, WoW, and Unigine benchmarks and they run nicely without the glitches/artifacts. I'm still stumped right now.
Hey, thanks for answer. I created my own topic at GTX 970 In Game Artifacts and Stopped Working Error, so I am waiting for your input if it is possible. Can you suggest me tools to use for artifacts scanning other than evga artifacts scanner, which can't find any artifacts in my case.
My System SpecsSystem Spec
Reply

 Graphic Glitches (Artifacts?) on GTX 970




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Bad GPU? Freezing, black screen, and graphic artifacts.
Hello. Recently my hp pavilion dm4 with switchable radeon 5000 series gpu has started acting funny. It started months ago with poor performance in streaming videos online when the radeon was activated (dubbed "hi performance" in the OS.) This problem seemed to get better after reinstalling...
Graphic Cards
Strange sporadic graphic issues, graphic lock ups (with Pictures)
Hello all, I think I have only seen something like this once :huh: and the problem was attributed to damaged RAM. This time around, the RAM seems to be in perfect working condition (tested with Memtest) and the problem still remains. I am starting to wonder if the graphic chip is not having...
Graphic Cards
graphic driver can't detect graphic card
Hi, i'm running window 7 32-bit OS. My graphic card is (ATI Radeon HD 3200 Graphics) My problem is that after i went to www.amd.com, downloaded,uninstall the old catalyst and installed a new catalyst which matches my OS and yet i got this message whenever i tried to run that catalyst. "No AMD...
Drivers
GTA4 artifacts.
Only game to cause it. The temp on my card is only going to 60c area. That isn't much considering its a 4850. Is there a fix? It almost never happened on xp. Frame tearing was the worst, now this. Any idea?
Gaming
Graphic glitches/stutter leading to BSOD BCcode: 124.
Hi! I got a Vista ultimate 64, Asus M4A78-E, AMD Phenom II 3.0, Powercolor 4870X2, 4 gig 800mhz ram, Corsair TX 650, and latly when i play games i get graphic glitches and studder and reduced flow in the game and then crash. This happens in many games but in different ways, Starcraft 2 Beta gives...
BSOD Help and Support
My WEI graphic and gaming graphic score just dropped?
Recently did a reinstall of Windows 7, and ran the assessment. Before the reinstall my graphic score was 7.6, now it dropped to 6.0. Same driver, no new hardware. What can this be? The graphics card is ATI 4890 1GB, running latest catalyst 9.12
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App