Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XFX One +Plus 1GB ATI Radeon HD 5450 Aero Issues

07 Dec 2014   #1
Alexeon

Windows 7 Pro x64
 
 
XFX One +Plus 1GB ATI Radeon HD 5450 Aero Issues

Hi, this is my first post here. I just got a new graphics card to replace an old one that died on me a few months back and while it works, Windows isn't letting me use Aero with it. Here is the story:

I had my old graphics card and it died on me while I was doing some cleaning on the PC. I guess I touched it with some static or something. So, I went to using the on-board graphics from my mobo and it worked fine. Aero worked, I had dual monitors, etc. It was just a bit slow with Youtube videos (it would take a few seconds before playing video even while audio was already playing.) Not a big deal, its both on-board graphics and outdated so it was to be expected. Eventually, my little brother got a new graphics card for his PC because he games a lot on his (I prefer gaming on the PS3 so graphics aren't a big deal on my PC, but I have noticed that programs compile slower since I switched to my mobo's graphics card so that was the incentive for me to switch.) Before the upgrade, his PC, also running Windows 7 Pro, had Aero and worked just fine. I upgraded his card yesterday and installed drivers and everything is fine with his. As thanks, he gave me his old card which I just installed on my PC today. Unfortunately, while Windows detects the card, and I was able to install the latest drivers and everything, I can't get Aero to work on with it. I know the card can handle it because it ran on my little brother's PC. My PC ran Aero before the upgrade, too, so it's not something else, either. I did a lot of reading today and was lead to the Performance Options where you can enable or disable fancy graphics features for Windows. There should be Aero options since I have Windows 7 Pro but I am actually missing a lot of options, based on screenshots from around the web.

Things I've tried:
I reran the Windows rating, to see if maybe it requires that. I got a 4.1 as my lowest score (Desktop Performance for Windows Aero.)
I ran the Troubleshoot Problems with Aero tool in Personalization with no improvements. No problems were detected.
I tried poking around the registry based on some people who had similar issues. No go there.
I installed the latest graphics drivers, uninstalled the old graphics card's nVidia drivers, reinstalled the new drivers again, updated to the beta drivers, and rebooted the machine several times in-between.
I changed between themes going from an Aero theme to a classic theme to a high-contrast theme, and back to an Aero theme. Didn't work.


I can't think of anything else to try. Sorry for the wall of text, but I figured I'd give as much information as possible. I attached a picture with the Performance Options I'm getting.


EDIT: I forgot to mention that I had a second graphical issue. Windows recognizes that my left-most monitor's left-most border is the end of the road and won't let my cursor go past that. But, my second monitor on the right's right-most border is not being detected as the end. I can move my cursor way past it, and bringing it back takes just as long. I only have two monitors being detected on Display, and they are arranged properly on there (left monitor is on the left, etc.) Needless to say, this didn't occur before the upgrade.




Attached Thumbnails
XFX One +Plus 1GB ATI Radeon HD 5450 Aero Issues-2014-12-07-14_44_08-greenshot.png  
My System SpecsSystem Spec
.
07 Dec 2014   #2
Gator

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1
 
 

Hello Alexeon, welcome to Sevenforums.

Have you tried forcing Aero to work?

Try this:
Force Enable Aero in Windows 7 1. Click on Start and type regedit at run

2. Now Navigate to the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM

3. In the right details pane, create following Three DWORD (32-bit value) entry
UseMachineCheck, and set its value to 0.
Blur, and set its value to 0.
Animations, and set its value to 0.

4. Close Regedit

5. Click on Start and type CMD with administrative Priviliges

6. Now type following command
Net Stop uxsms
Net Start uxsms
Above command will stop and start Desktop Window Manager Session Manager.

7. Now you can turn on Aero by right clicking on desktop-> Personalize -> Select Windows Colors


Windows 7 Aero Disabled - How can I enable it again? - Microsoft Community
My System SpecsSystem Spec
07 Dec 2014   #3
Alexeon

Windows 7 Pro x64
 
 

I saw someone else had a similar issue and was told to try that, so I did. It didn't work, though. I forgot to mention a symptom I am having. Right-clicking on the desktop has some serious delays, but right-clicking anywhere else (My Computer, taskbar, etc) doesn't. This also began with the graphics card upgrade.

If I can't figure this out, I'll probably end up uninstalling it but it really bothers me that such a simple upgrade would be so problematic.
My System SpecsSystem Spec
.

07 Dec 2014   #4
Gator

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1
 
 

Just as a shot in the dark, have you ran sfc /scannow in an elevated command prompt? Really the only reason is because you mentioned that you're having other problems.

SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
07 Dec 2014   #5
Alexeon

Windows 7 Pro x64
 
 

I have not, I will have to try that. It just seems to me that the other issues are all graphics-related someway or another, or started with the new graphics card anyway. But maybe there was an underlying issue that I never came across all along. I'll try that and see.
My System SpecsSystem Spec
07 Dec 2014   #6
Gator

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1
 
 

Quote   Quote: Originally Posted by Alexeon View Post
I have not, I will have to try that. It just seems to me that the other issues are all graphics-related someway or another, or started with the new graphics card anyway. But maybe there was an underlying issue that I never came across all along. I'll try that and see.
Yeah its probably a good chance that it won't work, but sometimes it can tell us if certain files are missing from your computer. It can never hurt.
My System SpecsSystem Spec
07 Dec 2014   #7
Alexeon

Windows 7 Pro x64
 
 

Welp, results are in. Windows Resource Protection did not find any integrity violations. So, that didn't work. :/
My System SpecsSystem Spec
08 Dec 2014   #8
Gator

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1
 
 

Its strange, your visual effects options seem as if you have Home Basic or Starter installed and not Professional. Lets try a few things.

First, we need to ensure your machine is ready for Aero. Please read everything in the red box in the link below and ensure everything on your machine matches up with the requirements. In addition, Windows needs to be activated to use Aero.
Aero Peek - Turn On or Off

Next, follow the link below to try and re enable your Aero settings:
Visual Effects Settings - Change

In addition, here is a Fix-it that may help:
Windows Aero Glass visual effects are not working or displayed

Ensure the following settings are correct in the registry:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\DWMAeroPeekEnable d
On the right pane - "DefaultApplied"=dword:00000001
HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM
On the right pane - "EnableAeroPeek"=dword:00000001


If all of this fails, you can try a repair install:
Repair Install
My System SpecsSystem Spec
08 Dec 2014   #9
Alexeon

Windows 7 Pro x64
 
 

Well, like I said, I had Aero running in this very same PC this morning before the upgrade. I have a legitimate copy of Windows 7 Professional 64-bit I bought through my school for about $20 and its activated. Has been for years since I've had this PC for a while (as you can tell, its not exactly cutting-edge.)

Everything in the first link matches up. 32-bit color, services are set to automatic, graphics score is 4.1, way higher than the minimum. My options are indeed missing out of the Performance Options. I mean, before now, I never had to look at them so I can't say they were there yesterday or something, but I have been very clearly running Aero since I installed Windows 7 (and Vista before that) like four years ago. Sometimes, driver updates for my old graphics card would break it and I'd need to roll back, and sometimes the updates would work fine. Aero also works on my virtual machines running on top of this, so the hardware is capable of it. I have screenshots I can post of my PC just a few months ago, but I took them while browsing 4chan, so I don't know if posting content from other sites here is bad or not. I mean, it's not bad stuff, just talking about giant robots, but some sites don't like even mentioning other sites.

I ran the Microsoft fixit earlier today before opening this thread. That didn't work either. The registry keys already existed and were set to the right values, too. I just checked that.

A repair install is the last suggestion I haven't tried yet. I'll give that a shot later in the week but I have some projects I need to get done and I can't devote another day to reinstalling and fixing things right now. Any other suggestions that aren't as time intensive, though, I'm willing to try them.
My System SpecsSystem Spec
08 Dec 2014   #10
Gator

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1
 
 

Quote   Quote: Originally Posted by Alexeon View Post
Well, like I said, I had Aero running in this very same PC this morning before the upgrade. I have a legitimate copy of Windows 7 Professional 64-bit I bought through my school for about $20 and its activated. Has been for years since I've had this PC for a while (as you can tell, its not exactly cutting-edge.)

Everything in the first link matches up. 32-bit color, services are set to automatic, graphics score is 4.1, way higher than the minimum. My options are indeed missing out of the Performance Options. I mean, before now, I never had to look at them so I can't say they were there yesterday or something, but I have been very clearly running Aero since I installed Windows 7 (and Vista before that) like four years ago. Sometimes, driver updates for my old graphics card would break it and I'd need to roll back, and sometimes the updates would work fine. Aero also works on my virtual machines running on top of this, so the hardware is capable of it. I have screenshots I can post of my PC just a few months ago, but I took them while browsing 4chan, so I don't know if posting content from other sites here is bad or not. I mean, it's not bad stuff, just talking about giant robots, but some sites don't like even mentioning other sites.

I ran the Microsoft fixit earlier today before opening this thread. That didn't work either. The registry keys already existed and were set to the right values, too. I just checked that.

A repair install is the last suggestion I haven't tried yet. I'll give that a shot later in the week but I have some projects I need to get done and I can't devote another day to reinstalling and fixing things right now. Any other suggestions that aren't as time intensive, though, I'm willing to try them.
A repair install wouldn't take too long and all of your settings will be in place. You may have to grab updates but thats about it.

Did you try this from my post above? Just wondering since you didn't mention it:
Visual Effects Settings - Change
My System SpecsSystem Spec
Reply

 XFX One +Plus 1GB ATI Radeon HD 5450 Aero Issues




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
ATI Radeon HD 5450 Driver problem!
First of all, hi guys :) I made my own pc, using a ASUS P5N-D MoBo; Intel 775 3.2 ; 3 GB DDR2 Ram memory -3x 1 Gb (2x 800mhz, 1x 553mhz); ATI Radeon HD 5450 1GB DDR3; LC-Power LC6480S Scorpio-480W PSU FULLY Modular, I have Windows Ultimate x86 currently installed on my WD HDD 40 Gb ( i use that...
Graphic Cards
Ati Radeon HD 5450 1gb good for this???
my system specs: Intel Pentium G620 (dual core) 4gb DDR3 1333mhz ram ASROCK H61M-VS do you think these games will run fine on hd 5450 (about 20-30fps) GTA 4 dirt 3 nfs the run the upcoming most wanted 2012
Graphic Cards
Cannot find a driver for Radeon HD 5450
Have a VTX Radeon HD5450 silent GPU and I cannot find the driver from either the VTX or AMD sites. The download which half an hour from VTX was in Latvian (no insult intended) or some such language and included a heap of Microsoft stuff. The AMD site doesn't throw one up when I click on the HD...
Drivers
New System w/ Radeon HD 6450 and Radeon HD 5450 Need Help
Asus mother board. Radeon HD6450 pcie x16 card and HD Radeon 5450 pcie x1 card. I want to run 2 monitors on each card. Installed both and the HD4650 installs the software and drivers. Install second and at first got BSOD. It installed but shows as video controller (VGA compatible). I go into the...
Graphic Cards
Geforce GT 210 or Radeon HD 5450..better in gaming??
Dear All, Need a quick suggestion before i seal the deal. I intend to buy the Radeon HD 5450. It has PCI-e 2.1 x16 bus interface. My motherboard model is Foxconn WinFast NF4K8MC. It has PCI-e 1 x16 graphics slot. My query is- will the graphics card work with this motherboard or not?
Graphic Cards
HIS Radeon HD 5450 Make window aero score lower!
I purchased a HIS Radeon HD 5450 Graphics card as on windows performance score was only 4.3 on aero and 4.5 for games< After I put the graphics card in the score on windows aero went down to 4.1 but he gaming part went up to 5.9 so quite a good increase! The only reason I did this was to increase...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App