Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Nvidia GTX 660 acting weird!

28 Dec 2014   #1
bhaveshzzz

WINDOWS 8.1
 
 
Nvidia GTX 660 acting weird!

PC SPECS:

CORSAIR CX 600 PSU
GIGABYTE GTX 660
8GB DDR3 CORSAIR RAM
GIGABYTE GA-B75M-D3H REV 1.0

So guys basically what's happening is my GPU Won't "boot" and I get no signal on screen if I leave the pc off for a long time. Whenever I cold boot the pc I have to wait for around 5 minutes and then restart the pc to get output from the GPU thereafter it works flawlessly until I turn my PC off again...!
I have run CPU burner and GPU Furmark test and I didn't see any artifacts or experience any crashes. No change in FPS in games. All run fine same as before when I didn't have this problem. What can cause this ?


My System SpecsSystem Spec
.
28 Dec 2014   #2
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Do you have onboard graphics you can switch to temporarily? If so, remove the graphics card and try to boot using the onboard graphics. Is the machine POSTing when you boot and you just get no video output or is it not POSTing?
My System SpecsSystem Spec
28 Dec 2014   #3
bhaveshzzz

WINDOWS 8.1
 
 

Thanks for replying. The machine boots anyway without the GPU. It just switches to onboard graphics whenever Gtx 660 is not detected on cold boots. Once booted I restart the pc and get output from the GPU. PSU is corsair CX600. Based on a thread here I saw an user who fixed this similar problem of cold boot by replacing the PSU. He too had the corsair CX series PSU. This doesn't happen on all cold boots. It's very random.
My System SpecsSystem Spec
.

28 Dec 2014   #4
bhaveshzzz

WINDOWS 8.1
 
 

Very Rarely the machine does this too : it starts for a second, stops then turns on.
My System SpecsSystem Spec
01 Jan 2015   #5
bhaveshzzz

WINDOWS 8.1
 
 

Help pls..
My System SpecsSystem Spec
Reply

 Nvidia GTX 660 acting weird!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
tab key acting weird
Hello, If this is the wrong forum, please move to the appropriate one! I have Windows 7 installed, IE8, Office 2007 etc. Recently I've noticed that the tab key isn't doing what it should be doing - i.e. tabbing between cells in a form, or web page. When you press the tab key, the form...
General Discussion
My mouse is acting weird
I have a mouse that I have had for a long time, it is a Logitech laser mouse and I love it. Just about a week ago I started to notice that when I single left click it is acting as if I am either double clicking or when I click it acts like I am clicking more than once. The latest thing that...
General Discussion
IE acting weird (but working)
windows 7, updated both IE 32 bit and IE 64 bit do this. dhrome and firefox do not. i've frequesn'tly cleared my cache i keep software and such up to date another trick someone told me that sometimes works when nothing else does: in taskmanager, processes: fine=d "explorer.exe" and end the...
Browsers & Mail
Keyboard is acting weird
my windows seven ultimate keyboard is acting weird. there is almost no stop to pressing ctrl+shift to reset the keyboard to normal. once i press ctrl+shift the keyboard only function normal for about 1~2 minutes and then it starts getting weird again. how can i fix this?
Customization
Really weird acting...
Ive got a problem with my windows 7 computer. Ive had it for about six months now and its working OK. Although now all of the sudden it started like... Acting weird... I was able to click on some places but i couldnt exit my web browser, neither change to another tab as it deleted the one i...
BSOD Help and Support
PC Acting really weird.
Hi, I have some sort of problem here, and I am hoping you could help me. Sometimes, MY PC just freezes and I have to shake the Chassis to make it unfreeze again. What problem is this? Any help appreciated.
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App