Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Black screen, loud fan, no BSOD on Radeon 6870 HD

07 Jan 2015   #1
bullfights

W764 & W764
 
 
Black screen, loud fan, no BSOD on Radeon 6870 HD

Hey guys,

First some background, then info:

Have a friends Desktop PC that he is having me check out, as he said the LAN wouldnt work after re-installing W7 on top, so I had him buy an regular PCI-e adapter and install it, but he said still wouldnt take, so I brought it home and checked it out.

I was able get the LAN working, download from ASUS website, then DL's more drivers and updated. I DL'd the Radeon HD 6870 drivers from Sapphire and installed, after the reboot I logged in and was going to install a couple more drivers and after a few minutes the screen went black, TV monitor said "no signal", tapped on keyboard and nothing, so hit the reboot button. NO BSOD.

After reboot and login, I decided I might as well do a clean install, as there were already 3 .old files, so I went to the first .old file and backed up user's docs, it was taking a bit to move 30 GB so I went to do something else. Came back and screen was at "no signal", took a look at PC and since no lights were flashing I rebooted, but before I did wondered if maybe the Power profile was set to shut screen off after XX minutes, so after reboot check and it was the case, set to 10 minutes, changed to "never" just for testing.

After that I wanted to check the BIOS and see if anything in there needed adjusting, so rebooted to BIOS and checked around, made some changes to the SATAs, from IDE to AHCI, changed a couple others that I cant remember, rebooted and W& hung up, I know due to ahci change, so figured reinstall, and clean install.

Clean install went fine, after changing ahci back to ide, didnt need it. But after installing CCC I got black screen again while trying to install another driver for the system, and then out of blue I hear a loud noise that came from vid card, like the fan was on MAX and blowing out the exhaust, I tried a reboot but heard beeps, so I pressed power button down and turned it off, never heard that before.

I went to my other monitor and rebooted, but just as I clicked to login windows screen went black "no signal", hmm no clue whats causing it. I rebooted again but in safe mode with networking. Sat around a few minutes and bang screen went black "no signal" and fan began blowing out the exhaust just like earlier real hard and loud, then it shut itself off, I kept it off and dont know what could be issue.

I called friend and he told me that while his son was playing games that sometimes the screen would go black as mentioned here, so what could it be, without a BSOD?

Sorry for the long info but wrote as it happened.

HIS PC:

ASUS M4A88TD-V EVO/USB3
AMD Phenom II X6 1100T Black Edition Thuban
G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3
WD1002FAEX 1TB 7200
LITE-ON DVD Burner - Bulk 24X
SAPPHIRE 100314-2SR Radeon HD 6870 1GB 256-Bit GDDR5 PCI Express 2.1 x16
Rosewill DESTROYER Black Gaming ATX Mid Tower
CORSAIR TX Series CMPSU-750TX 750W ATX12V


My System SpecsSystem Spec
.
08 Jan 2015   #2
Gornot

Windows 7 Home Premium x64
 
 

Sounds pretty much like a graphics issue, either the drivers are causing havoc on the system or, since you used it in safe mode and the same issue occurred, the GPU has some problems; probably overheating.

Have you tried peeking into the case, maybe cleaning some stuff inside, especially the graphics card?
My System SpecsSystem Spec
11 Jan 2015   #3
bullfights

W764 & W764
 
 

Well I decided to take apart the video card and found nothing dirty, maybe a little but but not enough to cause it to overheat. I removed and reapplied thermal paste to the chip, and re-installed it on the PC, it looked as though it was going to work so I let windows update 189 files lol, it got to about 140 of 189 updates and it started to flicker then screen went black. Had to reboot and it wouldnt come up, so I took out a video card (GeForce 9800 GTX) from a computer of mine. I installed it without installing drivers, just used windows standard.

All was going good so I continued the updates, I went to sleep but woke up at 0300 to go to work, checked the PC and was doing fine, no black screen at all, even went ahead and downloaded the video drivers via windows update and left for work.

returned home late evening and turned on the TV monitor to find the PC in a reboot but stuck on the boot up splash screen. uh oh. so hit the reboot and came on for a bit but started with flashes again, then just shut it down went to bed to play another day.

I have turned on the PC again but remembered that the Motherboard also has an integrated video, so maybe with that enabled could be issue? Well I went into bios and disabled internal graphics, saved and rebooted. Going good so far no flickering and updating some files.

hmm, 7 to update, 3 succeeded and 4 failed, restart and now stuck on splash screen. great.
My System SpecsSystem Spec
.

12 Jan 2015   #4
Gornot

Windows 7 Home Premium x64
 
 

Odd.

Would be good to know if the 4 failed updates were just some random KBs or drivers-related.

Maybe try doing a clean boot?
My System SpecsSystem Spec
14 Jan 2015   #5
society misfit

Windows 7 Professional
 
 

Bullfights, not sure if this helps or not but I had the exact same problem a few years ago with a Sapphire 6850. In my case it turned out to be a bad (or poorly made) power connection. Perhaps what you are experiencing is due to faulty power?


Here’s the thread if you wish to have a laugh, I mean look.
Radeon 6850 sporadic crashes
My System SpecsSystem Spec
14 Jan 2015   #6
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

There are a few things I noted when skimming your thread Bullfights. If you know this stuff, great, if you don't this might help.

1) The beeps - POST error. Get the manual (user or service) and determine what they're telling you (3 beeps, 7 beeps, LED flashes).

2) Take the machine down to the lowest level (bare bones machine that will still boot into Windows)
take out extra RAM, extra graphic cards, extra network adapters - anything you don't absolutely need

3) Beeps? Boot? black screen? hangs?
if you can get by with this configuration, then you can start building things back up
memory first, see how far you get
then one by one add in another piece
It might turn out that it all works after this, simply because you reseated the components

4) CCC has some issues on some machines (mine ) - all you really want is the driver.

5) The fan indicates to me that the CPU is overheating. IF after all components are back in and the issue continues, you might consider applying new thermal compound.
Everyone has their favorite - mine is Tuniq TX-2 (nearly as good as TX-4, but less expensive)

See how far you get with the strip down / build up procedure.
My System SpecsSystem Spec
28 Jan 2015   #7
bullfights

W764 & W764
 
 

I found the issue, it was the motherboard. The PCIe 16x slot was dead, I swapped video cards, taking my nvidia GTX 9800 out of my PC and installing it in friends PC, only to have found that it had same issues, same everything, hmm. so I took the radeon vid card and installed it into my PC and it worked great, played games watched movies, etc.

So I called friend and ordered up new motherboard and all fixed.

Thanks all for the feedback, everything helps
My System SpecsSystem Spec
29 Jan 2015   #8
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Thanks for the update bull, and thanks for marking your thread solved.

Bill
.
My System SpecsSystem Spec
Reply

 Black screen, loud fan, no BSOD on Radeon 6870 HD




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
XFX Ati Radeon HD 6870 malfunctioning?
Hello guys:) Firstly i want to say that i registrated here because i dont know what to do anymore. I know how to fix most computer problems, but i am about to give up with this one. Secondly, im no native english speaker, so excuse me for typos or bad grammar ;). so lets get to the problem. I...
Graphic Cards
Looking for fix to ATI drivers that cause BSOD with radeon 6870
Owner of a xfx radeon 6870 since June 2011, no problems what so ever till 2 days ago. Booted into windows normally and noticed my daul screens were displaying funny, rebooted the computer and got a BSOD. Noticed BSOD message said something about a time out failure with my display driver. Booted...
Graphic Cards
AMD Radeon 6670 vs 6870
Good morning everyone. I have an interesting concern. On another message board, I asked which would be a great card for the Sims 3 that isn't two expensive, but would allow me to max out the settings. Someone told me the 6670 would be an excellent card. Boy were they wrong! The camera continued...
Graphic Cards
AMD HD Radeon 6870 Crossfire causes BSOD and Freezing in games
Hey everyone. I just recently bought another card to xfire for my rig. Since ive done this however my games randomly freeze or bsod, or freeze with a loud buzz until i shut my rig down.. i think its a driver issue, because it used to do it when i had 1 card and i bumped it down to like 11.10 and...
BSOD Help and Support
Radeon HD 6870 Driver Problems
I'm not sure if there is a driver problem but I am pretty sure it that it is since i put my CPU and power supply under a stress test to see if they were faulty but they both past. Same with my ram. So, I just recently built a new computer and after a day or two I have been having problems with...
Drivers
AMD Radeon 6870 black lines around screen
Hi I have just finished a pc build and everything went smoothly except for one thing: the display won't show the entire screen! I have connected the computer to my full hd monitor via hdmi and Windows recognizes it as full hd, although the screen seems to be scaled down. There are black...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App