Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Removed GPU, put back in, Pc not picking up GPU now..

28 May 2015   #1
Rick Grimes

Windows 7 Ultimate 64bit
 
 
Removed GPU, put back in, Pc not picking up GPU now..

I removed my GPU (Palit 550TI) from my computer to so I could have more room in my case to add another HDD to my pc, i left the HDD unplugged as I wasn't going to use it just yet, just wanted it in my case, then put my graphics card back in, literally about 5 minutes later, plugged it in properly and connected the 6 PIN correctly and I booted up, black screen, so I changed from my graphics card VGA to my motherboard VGA to see what was happening and my computer loaded up normally, I checked device manager to see my graphics card wasn't listed under display adapters.

So I went to google and found this, nVidia graphic card does not show up in device manager, unable to - Microsoft Community

I did "method 2" and found my graphics card there but it was unhighlited and i couldn't click on it. So I turned my pc off and made sure graphics card was plugged in correctly, restarted, nothing, went to device manager, graphics card still not there..


I am un sure what to do next, also the fan is spinning on the card so it is receving power I assume, any help is greatly appreciated.

Many thanks.


My System SpecsSystem Spec
.
28 May 2015   #2
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Can you check in to see if C: > NVIDIA > Display Drivers folder exists.
My System SpecsSystem Spec
28 May 2015   #3
Rick Grimes

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by Boozad View Post
Can you check in to see if C: > NVIDIA > Display Drivers folder exists.

Hi, yes the folder exists, this is what is in the folder.

Gyazo - 03ce9f155fd9b83d35f1c1b27c88e46a.png
My System SpecsSystem Spec
.

28 May 2015   #4
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Could you upload files directly to this site please mate? Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
28 May 2015   #5
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
The proper or the way I do it anyway,
Is after unplugging the computer from a power source is hold down the power button for 60 seconds to discharge any left other power from the mother board...

Then make sure your grounded so no static electricity happens when you touch the device,
Then remove the card always having touched the case as you work on removing or re-installing the device.

How old is the machine in question ?
My System SpecsSystem Spec
28 May 2015   #6
Rick Grimes

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi and welcome to SevenForums,
The proper or the way I do it anyway,
Is after unplugging the computer from a power source is hold down the power button for 60 seconds to discharge any left other power from the mother board...

Then make sure your grounded so no static electricity happens when you touch the device,
Then remove the card always having touched the case as you work on removing or re-installing the device.

How old is the machine in question ?
Hi, I have tried removing and plugging it back in the correct way, and sadly still doesn't pick it up, also the machine will be 3 years old in 2 months, it was working perfectly last night and before I screwed in the other hard drive and now it's not picking it up at all.
My System SpecsSystem Spec
28 May 2015   #7
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

  • Remove the GPU and boot up.
  • Download DDU and follow Display Driver Uninstaller: How to use to remove all traces of your current driver.
  • Power down and reinstall the GPU.
  • Boot and see if the GPU is detected by Windows.
My System SpecsSystem Spec
28 May 2015   #8
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
You would of had to do the correct process every time especially the first
Very odd did you see any sparks ?
My System SpecsSystem Spec
28 May 2015   #9
Rick Grimes

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi,
You would of had to do the correct process every time especially the first
Very odd did you see any sparks ?
Hi, yes I was very careful every time I did something with my computer, and did it correctly every time, and no there wasn't any sparks.
My System SpecsSystem Spec
28 May 2015   #10
Rick Grimes

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by Boozad View Post
Could you upload files directly to this site please mate? Screenshots and Files - Upload and Post in Seven Forums

I tried to winrar the folders and then uploading them but the attachment link didn't work and I can't upload them.
My System SpecsSystem Spec
Reply

 Removed GPU, put back in, Pc not picking up GPU now..




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Can the "All Programs/Back" & "Search" entries be removed?
Using the Windows Classic theme, can the 'All Programs' & 'Search' (which is useless) be completely removed from the Start Menu? I'm talking about the entry All Programs bar and the Search entry, or can the useless MS Search be replaced with one of the many substitutes? I do not mean the Search...
Customization
Need help picking out a SSD from Newegg
I've been wanting to try my first SSD and have been looking at this one. Newegg.com - Intel 335 Series SSDSC2CT080A4K5 2.5" 80GB SATA III MLC Internal Solid State Drive (SSD) This is my motherboard GIGABYTE - Motherboard - Socket 1156 - GA-P55M-UD2 (rev. 1.0) Would these be compatible and a...
Hardware & Devices
Login name removed after ransom virus removed
Please help! After a ransom virus was removed from our desktop computer (originally a display model at Sam's), my administrator account is no longer visible...Only "Kiosk" and "Other User" . I have checked to see that net user administrator /active yes is successful but still do not see my user...
General Discussion
I removed a hdd and then placed it back no windows 7 is not loading.
Quick description. i Removed the HDD froma computer, plugged it into a different pc then back. windows failed to load. now, HDD is unplugged and windows 7 starts up ok. More Info, -i placed a 3tb seagate drive into an enclosure and plugged the enclosure into a windows xp x86 system. the hdd...
Hardware & Devices
Help!!!! I accidently removed IE and want it back!
I accidently removed Internet Explorer and am having a hard time getting it back, I think I removed it in services. I was just trying to disable it. I tried to download another one from the internet but none of them work with 7. is there a way to reinstall it using the upgrade disk? if so then...
Browsers & Mail
picking which HD to boot from?
before i reformated a window would come up asking which HD i wanted to boot into.....now i reformatted both my HD's...and it just automatically boots into one....how do i get this menu back so i dont have to go into bios every time i wanna switch HD's??
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:06.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App