Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Radeon Mobility HD 4570 Not working after win 7 upgrade

10 Nov 2009   #11
torrentg

7600.20510 x86
 
 

Usually that error comes from when you choose a folder to install from instead of clicking on the .inf itself.

See if that helps..?


My System SpecsSystem Spec
.

10 Nov 2009   #12
MrPipe

Windows 7
 
 

Hmmm. No, afraid not. Definitely selected the file and it gives the same message unfortunately
My System SpecsSystem Spec
10 Nov 2009   #13
torrentg

7600.20510 x86
 
 

I just double checked the file. It's for x64. You downloaded x64 driver from ATI. Start over again with the x86 32-bit version for Windows 7.
My System SpecsSystem Spec
.


10 Nov 2009   #14
torrentg

7600.20510 x86
 
 

If you download this link, and use my attachment with it, it should be good.

Extract from ATI's site, then overwrite the .inf with this one.

Use same .inf in the install process.


Attached Files
File Type: rar CL_83742.rar (9.0 KB, 88 views)
My System SpecsSystem Spec
10 Nov 2009   #15
MrPipe

Windows 7
 
 

Thanks again. Still no joy though I am afraid - I followed instructions and installed your driver file, but this time it says that "Windows has encountered a problem - code 10 error, card will not start"

Very frustrating!
My System SpecsSystem Spec
10 Nov 2009   #16
imagine

window 7
 
 

try ati modder and follow instruction in site
ATI MobilityModder - DriverHeaven.net
My System SpecsSystem Spec
11 Nov 2009   #17
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by MrPipe View Post
Thanks again. Still no joy though I am afraid - I followed instructions and installed your driver file, but this time it says that "Windows has encountered a problem - code 10 error, card will not start"

Very frustrating!
Did you copy it over the original one you downloaded from ATI's site, before installing from it?
My System SpecsSystem Spec
11 Nov 2009   #18
MrPipe

Windows 7
 
 

Thanks Imagine - will try that
My System SpecsSystem Spec
11 Nov 2009   #19
MrPipe

Windows 7
 
 

Hi torrent G,

Yes I did. It is getting a bit confusing now because I have so many driver downloads from ATI, but 90% sure I got the right one (even the amd site you pointed me too had multiple downloads)

The one I replaced had the same file name as the one you sent over
My System SpecsSystem Spec
11 Nov 2009   #20
seb1188

Windows 7
 
 

I'm getting very frustrated with this now.

I just tried removing both drivers and ATI's install manager, CCC, PowerExpress... any software relating to ATI so that I could reinstall it from scratch with some of torrentg's suggestions. Well, after removing the driver (half way through the ATI software uninstall) my screen went black, which makes sense if I've taken away the hardware that makes the screen colourful and pretty doesn't it, so yes, I'm an idiot for removing both at once. On the other hand, I took the power away and rebooted (it came on in 640 x 480) and Windows started trying (and succeeded) to install the cards. It seems that both card drivers are now working, as no error is reported. I have disabled the 3200 display adapter in device manager and still get windows aero in 1600 x 900 resolution so I guess it really WAS working? But then I enabled the 3200 again and the screen went to back to black... but on rebooting they're both working!!?!? PowerExpress is NOT running.

I reckon this is a problem with switching between the two cards as torrentg suggested with updating motherboard drivers. Otherwise it wouldn't have worked until I enabled the other one, would it? Unless it doesn't work at all, and it was just Windows (or me) being stupid.

But I don't actually know what I'm talking about, so I can only hope this stuff helps for someone who does know what they're doing.
My System SpecsSystem Spec
Reply

 Radeon Mobility HD 4570 Not working after win 7 upgrade




Thread Tools





Similar help and support threads
Thread Forum
ATI Mobility Radeon HD 4570 Series problem
I have laptop ASUS K50AB, with 2 graphic cards, one is ATI Radeon HD 3200 and it works fine, but another one is ATI Mobility Radeon HD 4570 Series, and I have huge problems to instal drivers on it. First I reinstaled my Windows 7 Ultimate x64, and all drivers are updated except this one(there is...
Graphic Cards
ATI Mobility Radeon HD 4570 problem
can anyone tell me how to see this graphic card performance as when i havent installed this graphic card (512MB) and after i installed there are no changes yet.....if yes then how can we take full use to it
Graphic Cards
Not enough resources for Mobility Radeon X1400 after RAM upgrade
Hi! I've been running Windows 7 Professional 64bit on a LG laptop with Mobility Radeon X1400 graphics with no problems. I went from 2GB RAM (2 x 1GB) to 3 (1 x 2GB, 1 x 1GB) two weeks ago and everything went on working without a hitch. Now, I've just tried to upgrade from 3GB to 4 (2 x 2) and...
Graphic Cards
ATI Mobility Radeon HD 4570 and Windows 7
Hi boys and girls :) I am a new windows 7 user after just buying a brand new Acer Aspire 5738G laptop. Here are the specs (maybe that will help someone try fix my problem :)) Windows 7 Core 2 Duo T6600 (2.2GHz, 800MHz FSB) 4GB RAM ATI Mobility Radeon HD 4570
Graphic Cards
Any way to get a Mobility Radeon 9200 working?
...without using a generic driver? I never got it to fire under Vista so I figured I would give it one last shot. The notebook is pretty nice for its age so I wanted to see if it will work. Thank you! Eric
Graphic Cards
ati radeon mobility 4570 windows7
Hi, just bought a vaio vgn-nw21sf (windows 7)with ati radeon mobility 4570. everything looks nice on my laptop but when I plug it in my LG 226WTQ-sf then the problems begin. when I duplicate screens the resolution at the LG can get up to something rubbish. When I use only the LG or extend...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App