Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AMD APU/Hardware Acceleration Issue - Sound but no Video

05 Aug 2015   #1
mattyb151

Windows 7 Ultimate x64
 
 
AMD APU/Hardware Acceleration Issue - Sound but no Video

Hi, so this problem is really really starting to annoy me since there seems to be plenty about it on the internet but solutions seem to work properly for me.

I installed a clean version of Windows 7 on my HP laptop which has an AMD A6-3420m APU with Radeon 6520G graphics. Before this clean install everything worked perfectly so I'm hoping that it must be some driver issue that I'm missing.

Basically Youtube videos work absolutely perfect (I'm assuming because it's HTML5) but non-Youtube videos produce no video unless I disable hardware acceleration HOWEVER with hardware acceleration the video is choppy and maybe every 30 seconds or so the sound jitters. The playback is watchable but after seeing it working perfectly before the clean Windows 7 install and perfectly on Youtube, to me it is horrible.

I've uninstalled AMD Catalyst drivers and installed the latest but it's still the same. Tried Chrome and Firefox both are the exact same. Was thinking about upgrading to Windows 10 out of sheer in hope that it may fix it somehow but not sure yet.

Any suggestions are greatly welcomed.


My System SpecsSystem Spec
.
05 Aug 2015   #2
maxie

windows 7 home 64bit
 
 

Hi ... What is the Model Number of your Laptop ? ... Have you tried the Drivers from the Vendors Website ? ...
My System SpecsSystem Spec
05 Aug 2015   #3
mattyb151

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by maxie View Post
Hi ... What is the Model Number of your Laptop ? ... Have you tried the Drivers from the Vendors Website ? ...
Thanks for replying. The laptop is an HP pavilion g6, not sure the exact model number now (used HP's auto detection program). Yes, tried a range of Catalysts versions including the one HP offered (14.12 Omega).
My System SpecsSystem Spec
.

05 Aug 2015   #4
maxie

windows 7 home 64bit
 
 

Does it not state the Model Number in System Information ? ...


Would like to know what Chipset Version is Installed ...


A lot of HP Laptops include the Driver for the Graphics in their Chipset ...


Was your Original OS Windows 8 ? ...
My System SpecsSystem Spec
05 Aug 2015   #5
mattyb151

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by maxie View Post
Does it not state the Model Number in System Information ? ...


Would like to know what Chipset Version is Installed ...


A lot of HP Laptops include the Driver for the Graphics in their Chipset ...


Was your Original OS Windows 8 ? ...
Found it through the HP detect program again, it's an HP Pavilion g6-1337sa. I'm actually not sure about the chipset as I'm sure it's installed with the graphics driver. There's definitely no downloads for the chipset on the HP website. Nah, the original was Windows 7.
My System SpecsSystem Spec
05 Aug 2015   #6
maxie

windows 7 home 64bit
 
 

I would try this Driver then must contain the Chipset ...

AMD High-Definition Graphics Driver
8.900.7.1000 Rev. 175.0 MB Apr 17, 2015
My System SpecsSystem Spec
05 Aug 2015   #7
mattyb151

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by maxie View Post
I would try this Driver then must contain the Chipset ...

AMD High-Definition Graphics Driver
8.900.7.1000 Rev. 175.0 MB Apr 17, 2015
Ah, I tried this driver, this is the one that contains the catalyst 14.12 omega driver. Still the same as the rest of the drivers unfortunately.
My System SpecsSystem Spec
06 Aug 2015   #8
maxie

windows 7 home 64bit
 
 

Doubt it is not a Driver issue then
My System SpecsSystem Spec
Reply

 AMD APU/Hardware Acceleration Issue - Sound but no Video




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Hardware acceleration alt. driver issue
My wife bought an ACER AX3400 64-bit (4GB memory, GeForce 315 video card) with "empty" HDD and no drivers CD from her friend. Installed WIN7 ULTIMATE and installed all the ACER X3400 drivers available on Acer download site. When she tries to play a quite simple card game, she gets the message...
Graphic Cards
Hardware acceleration is disabled or not supported by your video
Hi Friends i have faced a problem just after upgrading from xp to win 7 (currently there are no updates on my machine, my control panel is completely empty i didn't installed any programs till now) while playing the default games like mahjong titans, purple place i got an error message like...
Graphic Cards
hardware issue, sound & frame shocking
Hello, So when I play games, the sound sometimes "hangs" (short fragment gets repeated) This also happens with the screen, and at first I would claim it on software (game to heavy, drivers, ect) but I recently re´nstalled my computer (full clean). So my windows is bright clean. The games them...
Hardware & Devices
No sound at all, possible hardware issue
Ok so, for a few days now whenever i plug in any audio device into the front of back plug ins on my computer, headphones or speakers no sound plays at all. Windows doesn't think anything is plugged in at all. I know both the headphones and speakers work because they have on multiple other devices....
Sound & Audio
Video Playback issues with hardware acceleration
I am having an issue trying to playback videos. Anytime hardware acceleration is used the screen is either green or black, depending which app I use for playback. I am using the latest ATI drivers 10.6 and the latest drivers for all other hardware. I need the acceleration because I am on an...
Music, Pictures & Video
Hardware acceleration
I recently changed my hardware acceleration and lowered it to the lowest option. Now I want to change it back to the original settings that it was on, how can I achieve that? When I go back to screen resolution->advanced settings->trouble shoot the change settings button is not clickable, so...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

ę Designer Media Ltd

All times are GMT -5. The time now is 07:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App