Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphics card not working?

16 Sep 2015   #1
Mugen14

Windows 7 Ultimate x64
 
 
Graphics card not working?

Hello everyone!

First off i am going to post my specs here then continue on with my problem.


OS - Windows 7 ultimate x64

CPU - Pentium(R) Dual-Core CPU E5200 @ 2.50GHz

MotherBoard - Dell Inspiron 530

RAM - 6.00 GB (5.99 usable)

Graphics Card - NVIDIA GeForce GT 630 DDR3




So here is my problem one day i was playing this game and i left (AFK) to go run errands leaving the cpu on and as soon as i get back i have no display on my monitor. At first i thuoght my cpu was on idle mode or sleep mode but i kept trying to wake it but it did not show any display. So then i tried rebooting it but i still get no display; but i can hear audio and yes my monitor works because i tried plugging the vga cable too the mobo and i get display. SO is it my graphic cards doing? All fans are working fine even the one on the graphic card. Someone please help i don;t want to go out and spend money on a new one :/.


My System SpecsSystem Spec
.
17 Sep 2015   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
Hold down the power button and do a hard shutdown,
Unplug the unit and hold down the power button for at least 45 seconds

Now you could remove the graphic's card and use the onboard graphic's and restart see what happens.
My System SpecsSystem Spec
17 Sep 2015   #3
Mugen14

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi and welcome to SevenForums,
Hold down the power button and do a hard shutdown,
Unplug the unit and hold down the power button for at least 45 seconds

Now you could remove the graphic's card and use the onboard graphic's and restart see what happens.
Hello ThrashZone, I think i've mistaken but it's my NVIDIA Graphics card that does not show any display. My onboard graphics works fine, but when i plug the vga cable into the NVIDIA graphics port i get not display.
I have done every step you told me though but in that case the graphics card still doesn't give me visual. any ideas?
My System SpecsSystem Spec
.

17 Sep 2015   #4
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Yes try the DVI port instead
At least your onboard graphic's still works
If the DVI port or HDMI port will not work I suppose the card is bad
My System SpecsSystem Spec
17 Sep 2015   #5
RoasterMen

Windows 10 Pro 64-bit
 
 

If the said things above still does not work, Try installing that card into your friend's PC to see if it will work.
My System SpecsSystem Spec
19 Sep 2015   #6
Mugen14

Windows 7 Ultimate x64
 
 

Sorry for the late reply but all the suggested options above doesn't work.
My System SpecsSystem Spec
22 Sep 2015   #7
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Use cpu-z open it and go to the Main board section and post a screen shot,
CPUID
My System SpecsSystem Spec
23 Sep 2015   #8
Mugen14

Windows 7 Ultimate x64
 
 

Hi,
Here is a screenshot of the main board.


Attached Images
Graphics card not working?-mainboard.png 
My System SpecsSystem Spec
23 Sep 2015   #9
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and thanks,
Well I doubt it's anything other than gpu dying
Is this a compact/ mini case ?
If so probably doesn't have a lot of space under the gpu = poor ventilation.
My System SpecsSystem Spec
24 Sep 2015   #10
Mugen14

Windows 7 Ultimate x64
 
 

Yeah most likely the gpu is dead and no it's a dell inspiron 530 case. well thanks again you guys for the help. BTW can someone direct me too the laptop technical issues on the fourms? thanks
My System SpecsSystem Spec
Reply

 Graphics card not working?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Graphics card not working
I installed an AMD Radeon HD 6450 today and when i booted my computer up my sreen was blue from the getgo. When I tried to install a driver for the new graphics card, it didnt detect the program or OS or the graphics card. The imbedded graphics card also isnt disabled. The catalyst AMD driver...
Graphic Cards
New graphics card not working
I have just recently acquired a new radeon HD 7870 to replace my two old gtx 260's. I have installed the new hardware but the monitors are not picking up a signal and I have been trying for hours to fix the problem and nothing has happened. The graphics card has 6 mini DP outputs but I am using VGA...
Graphic Cards
PSU Smoking and Graphics card not working now
Yesterday my 500w powersupply started smoking up so I went out and bought a Thermaltake Lightpower 700w powersupply. After I finished rewiring my computer I noticed my graphics card wasn't working on my computer so I changed my input from HDMI to VGA to use the integrated graphics card. I'm not...
Hardware & Devices
PSU Smoking and Graphics card not working
Yesterday my 500w powersupply started smoking up so I went out and bought a Thermaltake Lightpower 700w powersupply. After I finished rewiring my computer I noticed my graphics card wasn't working on my computer so I changed my input from HDMI to VGA to use the integrated graphics card. I'm not...
Graphic Cards
I need to get this graphics card working! *HELP*
Here is a link to my computer: Compaq Presario SR5600 Desktop PC series- Compaq Presario SR5602FH Desktop PC Product Specifications - c01547875 - HP Business Support Center This is the graphics card I am trying to get to work Reviews : ATI Radeon X600 SE 128MB DDR PCI Express (PCIe) DVI...
Graphic Cards
Graphics Card not working.
I bought a HP p7-1003w Desktop the other day. After finding out the "3gb" video card only had 256mb of dedicated video memory, I bought a VisionTek Radeon HD 5450 2gb graphics card. I installed it and ran the install disk and everything. It works, but doesn't fit my monitor. I am using the HDMI...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App