Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Black screen after graphics card install (Nitro R9 380)

20 Nov 2015   #1
Morbid Monkee

Windows 7 Home x64
 
 
Black screen after graphics card install (Nitro R9 380)

Currently running a radeon 6850 and decided to upgrade to the Nitro R9 380, when I took my old card out and replaced with the 380 I only get a black screen and the power save mode message on my monitor. I cant figure out the onboard graphics thing because my 6850 is the only thing I see under device manager and in advanced bios there is no setting to disable onboard graphics. I installed the drivers that came with the 380 off of the disc and that didnt help either ...anyone know what I am doing wrong? Baby step walk me through the process because Im somewhat a novice these days lol, my other graphics card continues to work when I plug it back in so its got to be a driver issue unless my motherboard cant handle the new card which I find unlikely


My System SpecsSystem Spec
.
20 Nov 2015   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
Mostly gpu's are plug and play,
If you're sure it is inserted correctly and the new one has 2-6 pin power connectors not sure if the old one does or not but if they too are connected :/
Dud rma
My System SpecsSystem Spec
20 Nov 2015   #3
Morbid Monkee

Windows 7 Home x64
 
 

yeah I thought it was supposed to be plug n play too, I connected the 6-pins, both of the fans on the Nitro are running just fine on start up, it just that the screen remains black, its got to be a driver issue Im thinking
My System SpecsSystem Spec
.

20 Nov 2015   #4
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

Try plugging in the 6850 and remove the Radeon display driver. Put in the new 380 and boot.

Do you see BIOS messages on bootup?

If the video card shows video and you can boot into Windows (it should start up as Standard VGA), load the drivers for the new card.

If it still doesn't work, try the card in a friends machine.

If that doesn't work. RMA the card.

EDIT:

I checked the manual for that PC and it has no internal graphics card to conflict with your new GPU. The problem must lie with the new GPU or drivers.
My System SpecsSystem Spec
20 Nov 2015   #5
Morbid Monkee

Windows 7 Home x64
 
 

Yeah I have no internal graphics card so its complicated, I might have to call Saphire and see what they say, it seems like a lot of people have similar problems especially with Windows 7. I am going to try a few more things and than maybe upgrade to Windows 10 and try again, Im just hoping its not something like my motherboard but I dont think it is because my old card still works its just not as strong as I would like it to be
My System SpecsSystem Spec
21 Nov 2015   #6
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

How many Watts is your power supply? It might make a difference. Radeon cards are not known for their low power consumption.

EDIT:

I just looked it up and the power consumption is 225W, which is a fair chunk of a small power supply.
My System SpecsSystem Spec
21 Nov 2015   #7
Morbid Monkee

Windows 7 Home x64
 
 

I am pretty sure its 525w
My System SpecsSystem Spec
22 Nov 2015   #8
Viscon

Windows 7 Ultimate x64 SP1
 
 

Talking about PSU, actually the most important is how many ampers is provided on +12V rail, so check this in your PSU specs.
For example my Corsair HX750 provides 62A on 12V rail and that would be more than enough for your new GPU.
I think even 50A should do just fine.
My System SpecsSystem Spec
22 Nov 2015   #9
Morbid Monkee

Windows 7 Home x64
 
 

Yeah Ive been lookin at a new psu, I think mine is strong enough to push that it pushes the fans but nothing else
My System SpecsSystem Spec
23 Nov 2015   #10
Morbid Monkee

Windows 7 Home x64
 
 

figured it out, there was a tiny dip switch on the video card, I switched it and it took right off
My System SpecsSystem Spec
Reply

 Black screen after graphics card install (Nitro R9 380)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Black Screen on 2nd Monitor after a graphics card update
Im running Windows 7 dual monitor setup (BENQ BL2411). Which were working fine i replaced a faulty graphics card which was an Nvidia 520 GT 1 screen was connectedhttp://images.intellitxt.com/ast/adTypes/icon1.png via a DVI cable and the 2nd was connected via a VGA cable. I changed the graphics...
Graphic Cards
AMD Graphics card gives black screen after updating drivers
My card runs fine without the drivers. With drivers installed, I get a black screen on Windows 7 after 20 seconds. Anyone know what this could be? My onboard video runs just fine as well. My card is an HIS Radeon 6950 HD.
Graphic Cards
ATI/AMD Graphics Card error, black screen
I have a ATI/AMD Graphics Card on my Dell Studio 1558, and the chip has become faulty (design fault from manufacturer). Now the screen display is black and does not come on. Temporary workaround I am using I plugged in my separate VGA monitor to the laptop and using it, I switched on my...
Graphic Cards
Black Screen death-Linked to Graphics Card!
Hi, I recently turned on my laptop for it to constantly arrive to a black screen just before I select the user login. I read some instructions on a different forum stating that I need to log in to the computer via the safe mode and un install my display driver which is Intel(R) HD Graphics, I...
Graphic Cards
New Graphics card causes black outline around screen
I just installed my new 7950, and upon installing the drivers then rebooting back to windows I found that although my screen resolution is listed at 1080p, either my screen or my graphics card isnt doing this properly because I have a black outline, about 2cm thick, all around my screen where the...
Graphic Cards
put in graphics card bt only black screen wen turn on!!
i have just put in a graphics card (asus EN9800gt 512mb hybrid power) and wen i turn it on all i get is a black screen! what could the problem be? I have a 500w pc and its a very brand new pc with 64bit windows 7 and intergrated grraphics. also note that the first time i put it in i forgot to...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App