Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Discrete GFX Card - No Signal

26 Dec 2015   #1
HC1Gunner

Windows 7 Professional x64
 
 
Discrete GFX Card - No Signal

Normally I would not bother posting something this simple, but things have escalated, and I'm a bit perplexed.
This all started with good intentions, I was going to install and play some older RTS games on my AV PC connected to my TV via my AV receiver with HDMI. All was working well, last night I decided I would install an extra v-card I had laying around (AMD 7970) to give the system a boost in graphics. The Asus mobo has built in HD 4200.
Last night I prepped my 7970 install by uninstalling the AMD drivers for the on-board 4200. After driver uninstall, resolution defaulted to a low setting. I shut down the system, and hit the sack. Today I installed the 7970, only question was to whether I had the proper power connectors, card has one 8-pin and one 6-pin, but power supply only offering (2) 6-pin connectors. Powered on the PC, TV said no signal for HDMI 1, connected HDMI back to the on-board 4200, still no signal.


I then connected on an extra monitor I have, no signal via HDMI, or DVI from the 7970.
On a 2nd Monitor I connected via VGA, and DVI from the ports on the on-board 4200, no signal.
Removed 7970 from the system thinking there might be conflict, connected everything back the way it was before I started this project, and no signal from HDMI to my TV. I canít even get back to where I started, even though everything is connected same way. I donít see a post or anything, Iím sure its posting, just no video signal getting out.


Win 7 64bit
Asus M4A785-M


My System SpecsSystem Spec
.
26 Dec 2015   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
You'd need another vga cable that has a 8 pin = 2x4 ports to connect to the card.

Most of these cables are split 3x3+2 or at least evga vga cables are so you can use 6 or 8 to the gpu.

Possibly enermax your psu manufacture has one for sale or came with the psu still in the box or for sell seperately.

No telling why your other card will not work now :/
My System SpecsSystem Spec
27 Dec 2015   #3
HC1Gunner

Windows 7 Professional x64
 
 

Figured it was power connection issue. Probably have a double molex to an 8-pin buried in a box somewhere. Just ordered one online, hopefully that will solve the issue.
My System SpecsSystem Spec
.

27 Dec 2015   #4
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Yep without all the power I wouldn't guess the card would work
Might be time for a new modular psu then you can get away from molex connections and use real vga cables
My System SpecsSystem Spec
27 Dec 2015   #5
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

I'm going to ask the stupid question here, and please don't be insulted...

Did you reinstall the drivers for the 4200 when you put this all back together?
My System SpecsSystem Spec
Reply

 Discrete GFX Card - No Signal




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Graphics Card spinning but no signal to the monitor
Earlier today I replaced my RAM and GCU, everything was working fine before I tried installing these new things. Like I said the Graphics Card fans spin but there is no signal, idk what to do? no DGI
Graphic Cards
New graphics card shows no signal.
Hello, I recently purchased an nvidia GeForce gt 640 graphics card for my pc and it shows no signal to my monitor.I will try to provide as much information but sorry if I miss things out. After seeing my brother buy this card and it worked fine on his pc I bought one myself along with a new...
Graphic Cards
DVI No Signal with graphics card plugged in (on board work)
Hello all! I turned on my computer today and everything loaded normally. I opened up google chrome, and the screen froze for a second and the dvi went offline (computer kept running). I turned the computer back on and the dvi kept going to no signal. I took out the graphics card and I am currently...
Graphic Cards
New GFX Card w/ DVI-I - VGA Adapter -> No Monitor Signal
I honestly have no clue what to do, I been googling forever and none of them seem to be for me, so I decided to post here. Ok so I bought a new GFX Card : EVGA GTX 560 Amazon.com: EVGA GeForce GTX 560 1024 MB GDDR5 PCI Express 2.0 2DVI/Mini-HDMI SLI Ready Graphics Card, 01G-P3-1460-KR:...
Graphic Cards
No signal from Graphics Card :(
Hi Just built my first new PC and I'm having trouble with getting the video card to work. The spec is the following: Gigabyte Z77MX-D3H Intel i5 3450 Sapphire Radeon 7870 2gb Kingston Value Ram Thermaltake SMART 530w PSU
Graphic Cards
Switched dvi connection from discrete radeon to i3-2120 gpu "no signal
I tried connecting the dvi cable from the discrete radeon 6670 to the onboard igpu i also changed gpu setting to onboard in bios. the computer turns on but the led monitor says no signal and goes to sleep. i switched the dvi cable back to the discrete card and the bios setting back to pci x16 and...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App