Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New MSI R7 370 Not showing on Monitor

17 Feb 2016   #1
tkendall66

Windows 7 Home Premium 64 bit
 
 
New MSI R7 370 Not showing on Monitor

I just recently bought a new R7 370 from MSI to replace my old AMD 6500 Series card. I bought the card because I've been getting into gaming recently. I installed the card, made sure it fit in place then proceeded to try and start my computer. When I try to start it up, it doesn't display anything on my monitor. Any help or suggestions will be greatly appreciated


My System SpecsSystem Spec
.
17 Feb 2016   #2
BorisTheAnimal

Windows 7 Home Premium
 
 

Hello tkendall66 and welcome to 7forums!

What kind of cable do you have connecting the card to the monitor? Does the monitor say anything at all?

Cheers, Boris
My System SpecsSystem Spec
17 Feb 2016   #3
tkendall66

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by BorisTheAnimal View Post
Hello tkendall66 and welcome to 7forums!

What kind of cable do you have connecting the card to the monitor? Does the monitor say anything at all?

Cheers, Boris
I tried with a DVI-I and a HDMI and neither showed anything on the monitor
My System SpecsSystem Spec
.

17 Feb 2016   #4
BorisTheAnimal

Windows 7 Home Premium
 
 

Okay, are you sure that your power supply is adequately suited for the power hungry card you've got?
My System SpecsSystem Spec
17 Feb 2016   #5
tkendall66

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by BorisTheAnimal View Post
Okay, are you sure that your power supply is adequately suited for the power hungry card you've got?
I have a 700w power supply, Everything inside the tower turns on and lights up including the fans
My System SpecsSystem Spec
17 Feb 2016   #6
BorisTheAnimal

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by tkendall66 View Post
Quote   Quote: Originally Posted by BorisTheAnimal View Post
Okay, are you sure that your power supply is adequately suited for the power hungry card you've got?
I have a 700w power supply, Everything inside the tower turns on and lights up including the fans
Okay but what does the GPU say, all fans spinning? In what pci slot do you have it plugged in?
My System SpecsSystem Spec
17 Feb 2016   #7
tkendall66

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by BorisTheAnimal View Post
Quote   Quote: Originally Posted by tkendall66 View Post
Quote   Quote: Originally Posted by BorisTheAnimal View Post
Okay, are you sure that your power supply is adequately suited for the power hungry card you've got?
I have a 700w power supply, Everything inside the tower turns on and lights up including the fans
Okay but what does the GPU say, all fans spinning? In what pci slot do you have it plugged in?
On a calculator it says I should only need 540w and yes all fans spin, I have it plugged into a PCi 2.0
My System SpecsSystem Spec
17 Feb 2016   #8
BorisTheAnimal

Windows 7 Home Premium
 
 

Okay you might need to update the BIOS however one more thing do you hear any beeps or do you see the POST/splash screen?

If none of the above, go here and download the BIOS file:
https://www.asus.com/Motherboards/M5...Desk_Download/

If you are unfamiliar on how to do the update there is information on how to use the AMI FLASH DOS Utility, click the link called BIOS-Utilities.

Cheers, Boris
My System SpecsSystem Spec
17 Feb 2016   #9
tkendall66

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by BorisTheAnimal View Post
Okay you might need to update the BIOS however one more thing do you hear any beeps or do you see the POST/splash screen?

If none of the above, go here and download the BIOS file:
https://www.asus.com/Motherboards/M5...Desk_Download/

If you are unfamiliar on how to do the update there is information on how to use the AMI FLASH DOS Utility, click the link called BIOS-Utilities.

Cheers, Boris
Everything seems up to date, and no, I don't hear any beeps or see any screens
My System SpecsSystem Spec
18 Feb 2016   #10
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

Have you got the 6-pin power supply connector plugged in to the video card?
My System SpecsSystem Spec
Reply

 New MSI R7 370 Not showing on Monitor




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
New monitor is not showing anything from my new tower.
Hi, I just got a pre-built iBuypower gaming PC with a new monitor today and I set up everything and put everything together from VGA to HDMI, but nothing is working. The monitor is still black. The only time the monitor shows something is when I turn it on after a few seconds in which it flashes...
General Discussion
Monitor not showing picture after new gfx card
I borowed my friends graphics card because mine was broken. I tryed to put the card in with the power on the pc ON, after that my pc rebooted all of a sudden, and when i connected the card and the monitor, the monitir is not showing anything, and the inside of my PC smells like burned plastic,...
Graphic Cards
Nothing showing on monitor after not using 2-monitor cmputer fr awhile
A couple of years ago I bought a used corporate desktop PC with Windows 7 and used it for a while. Then I bought a new laptop and I haven't used the desktop since. Now I need to get a couple of programs off the desktop. But when I turn it on nothing shows on the monitor. The computer sounds...
Hardware & Devices
Only one monitor showing in display settings?
I did have two showing even though I am only using one at the moment but for some reason only one showing now....any ideas? Thanks
Graphic Cards
display showing one monitor when two are conected
i have a Sapphire hd 7850 graphics card and two monitors connected to it one hdmi one dvi-d. both screens are showing the same image and when i go into screen resolution it shows only one "generic PnP montitor". this was a fresh install of windows seven and it did work before that. the driver for...
Graphic Cards
Monitor not showing up in device manager
i'm using 64 bit win 7. Monitor not showing up in device manager. my monitor is samsung 2232bw. any solution ? ty
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App