Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Multicolored Lines, computer crash, Drivers?

07 Mar 2016   #31
Aemornion

64 bit win 7
 
 

Alright guys,

So after a 5 days of just the computer, minimal installations, no steam, etc.

I am not sure what exactly driver verifier is supposed to do, but if i understand correctly if drivers are in conflict i would get a BSOD with the driver conflict information. Is that correct?
regardless I did not get any BSOD's during this period of time.
typeing verified /query popped up another cmd type black screen briefly. But whatever it said just scrolled rapidly by, making it unreadable.

However,
I got a singular crash with matching symptoms, those being, in this case the computer completely locked up forcing a restart. Certainly not the multicolored death lines, but previously when using steam and troubleshooting, it would occasionally freeze in this fashion as well. Refer to post #24 for my mention of the different failure mode, last time.
Still no dump file or BSOD.

During this crash, I was letting windows media player do its thing and discover all the music in my music directory, and reading an article on chrome.

So, I am wondering 2 things.

Is it possible that this is all related to some glitch inside either my SSD or RAID5 triple drive? I did find an obscure post on one of the steam forums, saying that if the drive has some sort of error it can cause the GPU to hang and lead to these kinds of multicolored displays.

And if so, How does one go about diagnosing such a thing, if their is no trace left behind in the form of a dump file or whatever?

I am debating, installing windows on just the SSD with no raid5 triple drive connected, and then switching it, installing windows on just the raid5 and not SSD. But would this be a real test? As I am unsure I could keep the computer in raid5 mode, while simultaneously testing the drive, ie invalidating it being driver or drive related.

Are their any direct tests I can put the drives through to see if i get errors when trying to quickly push a lot of data and the like.

Thank you all for any and suggestions.


My System SpecsSystem Spec
.
07 Mar 2016   #32
GEWB

Linux (Mint is primary) / XP, Win7 Home / Win7 Pro, Ultimate / Win8.1 / Win10 archived VM
 
 

Did you turn the Cool 'n' Quiet OFF (as recommended in the mobo manual page 48)?

"Please note that enabling this function may reduce CPU voltage and memory
frequency, and lead to system stability or compatibility issue with some memory
modules or power supplies. Please set this item to [Disable] if above issue occurs."

Can you enter the OC Tweeker setup and provide screen shot of the DRAM Timing Configuration settings?

Regards,
GEWB
My System SpecsSystem Spec
07 Mar 2016   #33
Aemornion

64 bit win 7
 
 

GEWB, thanks for the reply.
Anak & ICIT2LOL, Thank you both for your recommendations on driver locating as well.

I did not, but it is now off, per your and apparently the manuals recommendation.

for everyone's reference here is the manual
ASRock > 970M Pro3

Ill let that change settle in for a couple days and see if i get a crash.

I did not make any adjustments to the bios settings, aside from setting up the RAID stuff. I don't really know what any of it is, and just assumed that its defaults were set intelligently, and I have no plans to overclock, i don't really have the need to.



Here is the DRAM Timing controls


Not sure if you want this info, but For good measure here are what the bios has to say about the rail voltages



Anything seem suspect to you?
My System SpecsSystem Spec
.

07 Mar 2016   #34
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

I would set overclock mode to "manual", and turn off "Spread Spectrum" It impacts performance.

The reason to set overclock mode to manual is when it's set to auto, the PC may overclock without you realizing it. That could cause stability issues.

And I think it's hilarious that your maximum processor speed is 6300 MHz. Should be 3600. Same with your Northbridge. It should be 2600. Someone goofed when making the BIOS.
My System SpecsSystem Spec
07 Mar 2016   #35
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Driver verifier is a utility/tool that has the capability to apply stress to drivers as they are being used, it could be compared to other stress testing tools such as Furmark and Passmark, but it is designed to only deal with drivers.

Quote:
Driver Verifier is a tool included in Microsoft Windows that replaces the default operating system subroutines with ones that are specifically developed to catch device driver bugs.[1] Once enabled, it monitors and stresses drivers to detect illegal function calls or actions that may be causing system corruption. It acts within the kernel mode and can target specific device drivers for continual checking or make driver verifier functionality multithreaded, so that several device drivers can be stressed at the same time.

Source: https://en.wikipedia.org/wiki/Driver_Verifier
Related: https://support.microsoft.com/en-us/kb/244617
As before, to make sure your machine didn't throw a BSOD, you could run the BSOD tool again for checking.


To diagnose the drives you would disconnect all but the one that has the OS on it and if it is in RAID mode, return it to AHCI and test.

Is there a particular reason you need to run RAID?

Your suggestion to swap drives that have the OS on it and test is a good one. My earlier suggestion to test in AHCI mode only may have been a bit harsh; I would proceed with this test in both AHCI and RAID.

There are stress tests for HDD, I'd try checking the western digital site to see if they have one for your drive. I'm not sure I'd suggest one for your SSD, Mellon, and or ICIT2 would know more about that than me.
My System SpecsSystem Spec
08 Mar 2016   #36
GEWB

Linux (Mint is primary) / XP, Win7 Home / Win7 Pro, Ultimate / Win8.1 / Win10 archived VM
 
 

Quote   Quote: Originally Posted by Aemornion View Post

Ill let that change settle in for a couple days and see if i get a crash.

I did not make any adjustments to the bios settings, aside from setting up the RAID stuff. I don't really know what any of it is, and just assumed that its defaults were set intelligently, and I have no plans to overclock, i don't really have the need to.

Anything seem suspect to you?
Thanks for following up with my request. Let's see what happens with C 'n' Q turned off.

I didn't think you made changes to timing but I have learned that the manufacturer doesn't always set things properly - just look at the earlier post about their BIOS text.

I don't see anything unusual but I concure with member Mellon Head about checking some settings in Manual instead of Auto.

Keep us posted!

Regards,
GEWB
My System SpecsSystem Spec
04 Apr 2016   #37
Aemornion

64 bit win 7
 
 

Hello all,

So long story short, I seem to have fixed my issue. its been a few weeks and I have not had any problems (fingers crossed).

I had installed windows on just my Raid 5 array, and the problem was non existent, so that lead me to check out my SSD further. Updated the firmware (no change), bought a new SSD (no change). Changed the sata port on the mother board (no Change).

I thought well ok, what if these cables as a batch just suck. I had swapped the cables previously, but they all came from the same bag, same manufacturer, etc, etc.

So, I bought a new batch of cables from a different supplier, and behold!!
Swapped in the cables from the new batch, and haven't had a problem since!

I guess in the old batch the shielding was ineffective or something, but now they are in the trash.

I thank you all for your support and help along the way, I did in fact learn a lot about troubleshooting my computer in the process, and cannot thank you enough for the assist.

Cheers,
Aemornion
My System SpecsSystem Spec
Reply

 Multicolored Lines, computer crash, Drivers?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Computer Crashing with multicolored horizontal lines
I have been having this problem since I built my computer in January. My entire computer freezes up and I am presented with the following. I have no Idea what is causing this. Please Help!
Graphic Cards
Post crash computer errors, missing drivers and adaptors
My laptop recently crashed, it wipped everything from my computer and all i have is the basic left, i would usually be able to just start over bot a huge loss, but i can't connect to the internet, via wifi or ethernet cable, i checked and it says it is missing the network drivers, amd i tried to...
General Discussion
HP Pavilion dv5-1125nr vertical lines crash
Hello! I've been experiencing a particular crash for about 3 months now and can't seem to figure it out. -No slowdown or errors prior to crash -display fills compleyely with vertical lines of varying colors in most cases -occacionally, the screen will start to gradually fade to white around the...
BSOD Help and Support
Black or grey&white lines crash
I hope you can help me solve this problem: About a month ago I've upgraded my rig, and since then I'm encountering black or grey and white screeb crash when I'm watching videos on youtube or embedded youtube videos (something like this or this ). But I can play DX9 or DX10 games like Half Life 2,...
BSOD Help and Support
Game Crash, Green lines Please Help [PIC included]
I currently own a 8800gt and happily play cod4 on max, battlefield bad company on medium and a handful of other games which came out within 3 years on max-medium max with reasonable fps. But on some games like eg Crysis, I play in on medium-low fine, i get around 40fps but all of a sudden within 10...
BSOD Help and Support
Green screen with black lines crash
Ok, so i just finished building a new PC consisting of... i7-860 asus p7p55 Sapphire Vapor-x 5870 4gigs gskill 1600 Windows 7 HAF 932 case
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:10.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App