Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Drivers don't seem to work

18 Nov 2009   #1
p0staboy

windows xp
 
 
Drivers don't seem to work

Well i have a ATI radion 7500 graphic card and I downloaded the drivers and installed them,installation went smooth. In my settings it still says generic pnp ect and its not showing the name of my graphic card in device manager. any suggestions?


My System SpecsSystem Spec
.
18 Nov 2009   #2
torrentg

7600.20510 x86
 
 

Hey ya. This will fix it right up for you.

Download this driver and extract it to C:\ATI

Then go to the device manager and right click on the video card (standard vga.)

Update driver software. Browse my computer. Let me pick. Have disk. Browse. Now navigate to inside C:\ATI to where the .inf file is and double click on it. Click ok then click next and let it install.
My System SpecsSystem Spec
18 Nov 2009   #3
p0staboy

windows xp
 
 

Quote   Quote: Originally Posted by torrentg View Post
Hey ya. This will fix it right up for you.

Download this driver and extract it to C:\ATI

Then go to the device manager and right click on the video card (standard vga.)

Update driver software. Browse my computer. Let me pick. Have disk. Browse. Now navigate to inside C:\ATI to where the .inf file is and double click on it. Click ok then click next and let it install.
Their is no .inf file in C:\ATI
It goes C:\ATI\Support
then their is 3 more folders
9-11_legacy_vista32-64_dd_ccc
9-11_legacy_vista32-64_wdm
9-11_vista64_win7_64_dd_ccc_wdm_enu
and theirs no .inf file in any of those folders. Not sure whats going on here


I acually have a radeon 7500 not 9500 and their is no drivers for the 7500.
My System SpecsSystem Spec
.

18 Nov 2009   #4
torrentg

7600.20510 x86
 
 

Go to C:\ATI in Windows Explorer and in the top right, search for *.inf

You gave to be able to see hidden and system files first.
My System SpecsSystem Spec
18 Nov 2009   #5
p0staboy

windows xp
 
 

Quote   Quote: Originally Posted by torrentg View Post
Go to C:\ATI in Windows Explorer and in the top right, search for *.inf

You gave to be able to see hidden and system files first.
Did that and abunch of files showed up. But no files are showing up when i try to loacte them from trying to browse for driver
My System SpecsSystem Spec
18 Nov 2009   #6
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by p0staboy View Post
Quote   Quote: Originally Posted by torrentg View Post
Go to C:\ATI in Windows Explorer and in the top right, search for *.inf

You gave to be able to see hidden and system files first.
Did that and abunch of files showed up. But no files are showing up when i try to loacte them from trying to browse for driver
The CL_89303.inf location is at

C:\ATI\Support\9-11_legacy_vista32-64_dd_ccc\Packages\Drivers\Display\LH_INF

You have to do it exactly like this:

Then go to the device manager and right click on the video card (standard vga.)

Update driver software. Browse my computer. Let me pick. Have disk. Browse. Now navigate to

C:\ATI\Support\9-11_legacy_vista32-64_dd_ccc\Packages\Drivers\Display\LH_INF and double click on CL_89303.inf.

Click ok then click next and let it install.
My System SpecsSystem Spec
18 Nov 2009   #7
p0staboy

windows xp
 
 

Got it to work. Thanks a alot. hope this thread helps others.
My System SpecsSystem Spec
22 Nov 2009   #8
p0staboy

windows xp
 
 

Ok I have to bump this thread again, I have re formated my computer and cannot get the drivers to work. Now when i navigate to CL_89303.inf it shows me a list of all the radeon video cards and I have to pick one in order to click next. My video card is not listed as I have a 7500. Before when I did this this list never came up. I tried clicking the 9500 and it doesn't work. Any help?
My System SpecsSystem Spec
22 Nov 2009   #9
torrentg

7600.20510 x86
 
 

Ohh...yeah the 7500 is not supported at all on 7 or Vista. Too old by a large margin.
My System SpecsSystem Spec
22 Nov 2009   #10
p0staboy

windows xp
 
 

Quote   Quote: Originally Posted by torrentg View Post
Ohh...yeah the 7500 is not supported at all on 7 or Vista.
Well I had it working before i formatted my computer and it showed up on my display settings.So this is not making any sense now
My System SpecsSystem Spec
Reply

 Drivers don't seem to work




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
do 64 bit drivers work for 32 bit windows
i have a hp laptop which had windows 7 64 BIT , then i planned to reinstall windows so i used two different driver backup programs (driver magician and driver genius) , and i completely backed up the drivers then i formatted the system partition and performed a clean windows installation , but...
General Discussion
How to check whether the drivers will work?
Hello friends, So I have the DVD with Windows 7 installed on it, it is booting on start up, everything's fine. I have also downloaded and burned on another DVD all the drivers for my laptop. I downloaded them from the official website of the manufacturer of the motherboard of the laptop. Now...
Drivers
Will drivers work in Windows 8?
I have a Toshiba Satellite C655-S5061. It is running Windows 7 Home Premium 64 bit. I just downloaded the ISO for Windows 8 Developer Preview (without developer tools) and I want to install it over Windows 7 without erasing ANYTHING. If I install this, will my Wireless drivers and other things like...
Drivers
new ati drivers don't work
just downloaded these drivers (10-10_vista64_win7_64_dd_ccc_enu) from (Graphics Drivers & Software) for my ati 5750 and keep getting this error. Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a...
Drivers
Finding Drivers that WILL work with Win. 7
Hello there, i am having trouble getting this crappy Wireless USB Adapter to work Ativa Wireless-G USB Network Adapter. I have the latest Beta* Vista Drivers from there site. Their support is complete crap. The FAQ say the supplied Drivers will work with Vista and they don't. I had to download the...
Drivers
Vista drivers don't work in W7!!!!
Well i downloaded the drivers from Intel for my express family drivers(graphic drivers ofcourse) built for vista OS when i install them it says its not for the OS i have?
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App