Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Radeon Control Centre Messing With Fan Speed

10 Oct 2016   #1
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 
Radeon Control Centre Messing With Fan Speed

I have an AMD/Radeon R9 280 GPU. It works great for the limited gaming that I do, and performs really well, even at ultra settings. The only problem with it is that the automatic fan control in the driver software package does not work and never has. I can merrily play a game and the card's fan will stay at 20% until it overheats and practically catches fire. At least the card stops working before it causes damage and I can shut down.

I usually have the fan set manually at 65% and this covers me for even intense gaming, as the card never breaks 45C that way.

I noticed a problem the other day when I was playing a game. I could smell something getting really hot and I checked my temps. The GPU was over 70C and the fan was running at 20%. Just then my monitors went black and the audio continued in the game. My card had shut down. Checking the fan control when I got the PC rebooted, it was set to Auto and 20%. I reset the fan control to manual and 65% and everything was fine. Until I rebooted, then the fan control went back to Auto. I can set the card to manual but the settings will not persist like they used to over reboots.

AV scans came back negative, and I haven't updated the driver for over a month. This has just happened in the past few days. I can't figure this out.

I'm out of ideas and would really appreciate any advice. I won't even mind heckling from you Nvidia guys out there.


My System SpecsSystem Spec
.
12 Oct 2016   #2
EatPeat

Windows 7 ultimate x64
 
 

That crimson screwed my card as well.ridiculous software.
My System SpecsSystem Spec
12 Oct 2016   #3
IoNGeNeRaL

Windows 10 Pro x64 (UPGRADED - 10/20/2016)
 
 

I would highly recommend you use the Display Driver Uninstaller tool and reinstall your drivers. Be sure to also remove the Control Centre software. Once you've done that, reboot your system. Download and install the latest display drivers for your R9 280 and be sure not to install the Control Centre software. Just install what is necessary. (Display driver) Once you've done that, go to the ASUS website and see if your board has the ASUS GPU Tweak II tool and download/install it. It doesn't have to be for your board as it'll work nonetheless.

I understand that some people here may disapprove of using GPUTweak II as it's been known to cause BSODs in Windows 7, however, I still use it and haven't had any further crashes since my lost BSOD thread and I'm still using it to control my fan speeds.

Display Driver Uninstaller
AMD Drivers

Even though your card is an XFX I assume you already know that you can download the drivers from AMD as "Radeon R9 2xx" from the manual selection list?


My System SpecsSystem Spec
.

13 Oct 2016   #4
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

Uninstalled the drivers and Crimson and resinstalled just the drivers. Now I can't control my fan at all, there is no interface to alter the fan speed. It's stuck at 20% and stays there no matter how hot the card gets.

I'm reinstalling Crimson, at least that way I can control the fan, even if I have to reset it after every reboot.

Any ideas why it won't retain its settings?
My System SpecsSystem Spec
18 Oct 2016   #5
IoNGeNeRaL

Windows 10 Pro x64 (UPGRADED - 10/20/2016)
 
 

Did you download the ASUS GPUTweak II tool?


Attached Thumbnails
Radeon Control Centre Messing With Fan Speed-ss-2016-10-18-11.55.57-.jpg  
Attached Images
Radeon Control Centre Messing With Fan Speed-ss-2016-10-18-11.56.28-.png Radeon Control Centre Messing With Fan Speed-ss-2016-10-18-11.56.34-.png 
My System SpecsSystem Spec
23 Oct 2016   #6
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

Quote   Quote: Originally Posted by IoNGeNeRaL View Post
Did you download the ASUS GPUTweak II tool?
I just did, but haven't installed it yet. I'm reluctant to add yet another program to my system tray. But I'll give it a try if I can't get this fan issue resolved.
My System SpecsSystem Spec
23 Oct 2016   #7
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

UPDATE:

Upgraded to the newest Radeon Crimson driver. Problem solved.

Must have been a bug is their previous driver package.
My System SpecsSystem Spec
25 Oct 2016   #8
IoNGeNeRaL

Windows 10 Pro x64 (UPGRADED - 10/20/2016)
 
 

Ah! Glad you finally fixed it.
My System SpecsSystem Spec
Reply

 Radeon Control Centre Messing With Fan Speed




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Catalyst control centre not starting up - AMD Radeon 6630M
Hi all, I'm using a HP ENVY 14-2020NR and I've had this problem for quite a while now but it has never bothered me until recently as I began playing Diablo and was surprised that my Envy was struggling to cope with medium-low graphics. When I first bought it, I was able to load up catalyst...
Graphic Cards
Where's Catalyst Control Centre?
Hey everyone, I noticed that my previous ATI drivers seemed to be outdated a little bit, and so decided to try to update them. I've currently got the AMD Vision Engine Control Centre, which is version 12.2, but where can I download an updated version of Catalyst Control Centre? The CCC version for...
Drivers
ATI Catalyst Control Centre Not Opening
Hi, I have updated to the latest ATI drivers on this page below for my GFX card. The drivers installed okay. However, I'm no having a problem with catalyst control centre not opening I have removed the drivers and used Driver Sweeper in safe mode and reinstalled the the drivers and catalyst...
Drivers
ATI Catalyst Control Centre not installing with 7
Hey guys New guy here. I am in HELL! I installed Windows 7 on My Vaio laptop a few days ago. The machine had factory installed Vista. Its a Due core 2.4 with ATI Radeon HD 3400, 4 GHZ ram The install went fine and it asked for the nuking of the ATI software to facilitate install. I did that...
Graphic Cards
catalyst control centre problem
everytime i open my pc i get this message: catalyst control centre: host application has stopped working... http://img710.imageshack.us/img710/7489/pr0blem.png
Graphic Cards
ATI Radeon 4870 messing up windows 7??
Hi, i currently got two of the Asus AEH4870 gpu's (Ati Radeon 4870 Hd). The problem is that i can't find out whether it's a hardware issue or a software issue. I've been formating and reinstalling drivers for weeks now, and disabled the HD Audio ports on the two cards but the computer always...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App